abiword shows strange behaviour when using an unknown filename.

Asked by Shirish Agarwal

Hi Vincent,
    Let's say one makes a new file example.txt

$ abiword example.txt

Then when abiword opens, it doesn't have the file name as example.txt
It says untitled0 (this is also a bug but a different bug)

so I copy some content on the file. then save it with the same name.

On the CLI I get this output

gnowledge@gnowledge-desktop:~$ abiword example.txt
Wrong Grammar|Wrong Grammar| Original material :- Yellow 2.|
 LowOff 0 HighOff 44
Wrong Grammar|abiword version: 2.|
 LowOff 0 HighOff 18
Wrong Grammar|4.|
 LowOff 19 HighOff 20
Wrong Grammar|6-2ubuntu2 |
 LowOff 21 HighOff 31
Wrong Grammar|ubuntu version: 7.|
 LowOff 0 HighOff 17
Wrong Grammar|10 |
 LowOff 18 HighOff 20
gnowledge@gnowledge-desktop:~$ abiword example.txt
Wrong Grammar|ubuntu version: 7.|
 LowOff 0 HighOff 17
Wrong Grammar|10 |
 LowOff 18 HighOff 20
Wrong Grammar|abiword version: 2.|
 LowOff 0 HighOff 18
Wrong Grammar|4.|
 LowOff 19 HighOff 20
Wrong Grammar|6-2ubuntu2 |
 LowOff 21 HighOff 31
Wrong Grammar|Wrong Grammar| Original material :- Yellow 2.|
 LowOff 0 HighOff 44

Is this the way it should be?

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu abiword Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Vincent (vinnl) said :
#1

Could you attach the affected .txt file? I can't seem to reproduce the issue.

Revision history for this message
Shirish Agarwal (shirishag75) said :
#2

Hi Vincent,
       Sorry the bug is little different, I have modified the bug, sorry for wasting ur time.

Revision history for this message
Vincent (vinnl) said :
#3

Well, I've followed the steps you described, and I get the following output:

===
$ abiword example.txt

Wrong Grammar|// With all modules set, start the dispatch loop |
 LowOff 0 HighOff 48
Wrong Grammar|// Make sure errors are only thrown when developing |
 LowOff 0 HighOff 51
Wrong Grammar|// Load the modules and run their bootstrap code |
 LowOff 0 HighOff 48
Wrong Grammar| // Do nothing - not possible to connect to the database |
 LowOff 0 HighOff 56
Wrong Grammar|// Load a logger that can be hooked into |
 LowOff 0 HighOff 40
Wrong Grammar|$cacheConfig = new Vogel_Config_Ini('.|
 LowOff 0 HighOff 37
Wrong Grammar|ini'); |
 LowOff 57 HighOff 63
Wrong Grammar|// Load the cache configuration and save it to the registry |
 LowOff 0 HighOff 59
Wrong Grammar|$generalConfig = new Vogel_Config_Ini('.|
 LowOff 0 HighOff 39
Wrong Grammar|ini'); |
 LowOff 61 HighOff 67
Wrong Grammar|// Load the general configuration and save it to the registry |
 LowOff 0 HighOff 61
Wrong Grammar|php'; |
 LowOff 21 HighOff 26
Wrong Grammar|naming-conventions.|
 LowOff 55 HighOff 73
Wrong Grammar|// Enable the auto-loading of classes that follow the ZF naming convention |
 LowOff 0 HighOff 74
Wrong Grammar| .|
 LowOff 0 HighOff 17
Wrong Grammar| PATH_SEPARATOR .|
 LowOff 18 HighOff 34
Wrong Grammar| '.|
 LowOff 35 HighOff 37
Wrong Grammar|'); |
 LowOff 38 HighOff 41
Wrong Grammar| .|
 LowOff 0 HighOff 17
Wrong Grammar| PATH_SEPARATOR .|
 LowOff 18 HighOff 34
Wrong Grammar| get_include_path() |
 LowOff 35 HighOff 54
Wrong Grammar| .|
 LowOff 0 HighOff 17
Wrong Grammar| PATH_SEPARATOR .|
 LowOff 18 HighOff 34
Wrong Grammar| 'application/models' |
 LowOff 35 HighOff 56
Wrong Grammar| .|
 LowOff 0 HighOff 17
Wrong Grammar| PATH_SEPARATOR .|
 LowOff 18 HighOff 34
Wrong Grammar| 'modules' |
 LowOff 35 HighOff 45

===

===
$ abiword example.txt
Wrong Grammar| .|
 LowOff 0 HighOff 17
Wrong Grammar| PATH_SEPARATOR .|
 LowOff 18 HighOff 34
Wrong Grammar| 'modules' |
 LowOff 35 HighOff 45
Wrong Grammar| .|
 LowOff 0 HighOff 17
Wrong Grammar| PATH_SEPARATOR .|
 LowOff 18 HighOff 34
Wrong Grammar| 'application/models' |
 LowOff 35 HighOff 56
Wrong Grammar| .|
 LowOff 0 HighOff 17
Wrong Grammar| PATH_SEPARATOR .|
 LowOff 18 HighOff 34
Wrong Grammar| get_include_path() |
 LowOff 35 HighOff 54
===

I do not notice any strange behaviour though.

Also, I think the reason that it says untitled0 is that you can't have Abiword create a new file from the command line.

Revision history for this message
Charlie Kravetz (charlie-tca) said :
#4

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs .

Revision history for this message
Charlie Kravetz (charlie-tca) said :
#5

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs .

Revision history for this message
Charlie Kravetz (charlie-tca) said :
#6

The report is asking whether or not the behavior is correct. That is not something we determine through a bug report, but rather through a support area. This could be asked in the forums, mailing lists, or launchpad questions.

Revision history for this message
Launchpad Janitor (janitor) said :
#7

This question was expired because it remained in the 'Open' state without activity for the last 15 days.