the resolution won't stay when I reboot

Asked by tim on 2009-11-22

I have the latest driver version installed 190.42. I'm using Linux-x86. My graphic card is Geforce 6100 nForce405. The resolution reverts back to 800 by 600 everytime I reboot the computer. It also crashed once while using the computer.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
tim
Solved:
2009-11-28
Last query:
2009-11-28
Last reply:
2009-11-28
tim (brucetim100) said : #1

I'm really having a tough time, please someone can you help me?

tim (brucetim100) said : #2

I tried some of the FAQ but I just going around in circles.

tim (brucetim100) said : #3

i tried removing the old stuff and got this:

Purging configuration files for nvidia-glx-180 ...
dpkg - warning: while removing nvidia-glx-180, directory `/usr/lib/tls' not empty so not removed.
Removing nvidia-180-kernel-source ...
Removing all DKMS Modules
Done.
Removing nvidia-180-libvdpau ...
Purging configuration files for nvidia-180-libvdpau ...
Removing nvidia-settings ...
Purging configuration files for nvidia-settings ...
Processing triggers for man-db ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
brucetim@brucetim-desktop:~$

tim (brucetim100) said : #4

I think maybe part of problem is I'm logged in as root...I don't how to get out of it....of course I shouldn't be in as root either, I know, it was a mistake

sudo apt-get install linux-headers-2.6.31-14-generic linux-headers-2.6.31-14 linux-headers-generic

Then try again

tim (brucetim100) said : #6

E: Couldn't find package linux-headers-2.6.31-14-generic

tim (brucetim100) said : #7

thanks for helping...that's what I got when I did the command sudo apt-get install linux-headers-2.6.31-14-generic linux-headers-2.6.31-14 linux-headers-generic

linux-headers-2.6.31-14-generic (source: linux): Linux kernel headers for version 2.6.31 on x86/x86_64. In component main, is optional. Version 2.6.31-14.48 (karmic), package size 654 kB, installed size 8568 kB (Only available for all i386 amd64 lpia ia64 powerpc sparc armel)

Its in the main repo, try running:

sudo apt-get update

first.

andy@fileserver:~$ apt-cache policy linux-headers-2.6.31-14-generic
linux-headers-2.6.31-14-generic:
  Installed: 2.6.31-14.48
  Candidate: 2.6.31-14.48
  Version table:
 *** 2.6.31-14.48 0
        500 http://gb.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

tim (brucetim100) said : #9

what do I do? I'm not very good at this. I ran sudo apt-get update and got that, then I try again "sudo apt-get install linux-headers-2.6.31-14-generic linux-headers-2.6.31-14 linux-headers-generic", but the same error....am I to run "apt-cache policy linux-headers-2.6.31-14-generic"?

sure, see what it says, you need the headers file dude

You can use this link to manually download for 32bit:
http://packages.ubuntu.com/karmic/i386/linux-headers-2.6.31-14-generic/download

You can use this link to manually download for 64bit:
http://packages.ubuntu.com/karmic/amd64/linux-headers-2.6.31-14-generic/download

If you are unsure of your architecture you can run:

uname -a

If you see i686 you are using 32bit, If you see x86_64 it is 64bit.

tim (brucetim100) said : #11

Mine is i886.
This what i got :
brucetim@brucetim-desktop:~$ apt-cache policy linux-headers-2.6.31-14-generic
W: Unable to locate package linux-headers-2.6.31-14-ge

tim (brucetim100) said : #12

this has been a problem I had for the last 24 hours getting what I need....it's either unable to locate the package or permission is locked

tim (brucetim100) said : #13

can anyone help please?

Philip Muškovac (yofel) said : #14

Which version of Ubuntu are you using? Can you please paste the contents of your /etc/apt/sources.list here? Thanks!

tim (brucetim100) said : #15

 This is what I got.
brucetim@brucetim:~$ /etc/apt/sources.list
bash: /etc/apt/sources.list: Permission denied.

I had upgraded to 9.1.0 a few months ago...then a week ago my system crashed when I was fooling around trying to get a certain version of Vuze to work. (I promise not to fool around with root again) My LiveCD was 9.0.4, and I had that on until just today when I couldn't figure what else to do so I reinstalled 904 hoping that would fix my problem, and then I upgrade once again 910 just a little bit ago.

tim (brucetim100) said : #16

I tried the command with both sudo and su, and got:

brucetim@brucetim:~$ sudo /etc/apt/sources.list
sudo: /etc/apt/sources.list: command not found
brucetim@brucetim:~$ su /etc/apt/sources.list
Unknown id: /etc/apt/sources.list
brucetim@brucetim:~$ /etc/apt/sources.list
bash: /etc/apt/sources.list: Permission denied
brucetim@brucetim:~$

try:

gedit /etc/apt/sources.list

tim (brucetim100) said : #18

Here's the read - out of gedit command:

# deb cdrom:[Ubuntu 9.04 _Jaunty Jackalope_ - Release i386 (20090420.1)]/ jaunty main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://ro.archive.ubuntu.com/ubuntu/ karmic main restricted multiverse
deb-src http://ro.archive.ubuntu.com/ubuntu/ karmic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://ro.archive.ubuntu.com/ubuntu/ karmic-updates main restricted multiverse
deb-src http://ro.archive.ubuntu.com/ubuntu/ karmic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://ro.archive.ubuntu.com/ubuntu/ karmic universe
deb-src http://ro.archive.ubuntu.com/ubuntu/ karmic universe
deb http://ro.archive.ubuntu.com/ubuntu/ karmic-updates universe
deb-src http://ro.archive.ubuntu.com/ubuntu/ karmic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://ro.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
# deb-src http://ro.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu jaunty partner
# deb-src http://archive.canonical.com/ubuntu jaunty partner

deb http://security.ubuntu.com/ubuntu karmic-security main restricted multiverse
deb-src http://security.ubuntu.com/ubuntu karmic-security main restricted
deb http://security.ubuntu.com/ubuntu karmic-security universe
deb-src http://security.ubuntu.com/ubuntu karmic-security universe

tim (brucetim100) said : #19

When I booted the computer this morning I'm back to the original problem....600 by 800 resolution...I knew my fix was temporary....guys I am so desperate to fix this....I'll be in and out of office today...but will be looking frequently for your help.

tim (brucetim100) said : #20

Here is some further info the might help:

tim@brucetim:~$ sudo uname -a
[sudo] password for brucetim:
Linux brucetim 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux

tim (brucetim100) said : #22

ok, thanks. So first I do this command, right?

For Ubuntu Karmic Users

Use the following command to add PPA

    sudo add-apt-repository ppa:nvidia-vdpau/ppa

And then I do the rest of this, right?

Install GPG key using the following command

    sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys CEC06767

Update source list

    sudo apt-get update

Install beta drivers

    sudo apt-get install nvidia-190-modaliases nvidia-glx-190 nvidia-settings-190

tim (brucetim100) said : #23

Something else is I have no bottom toolbar now. So, my habit is to minimize things like terminal and firefox, but then they just disappear.

tim (brucetim100) said : #24

I did those commands I listed above and everything seemed to go ok, but when I rebooted the resolution switched back to 800/600 and no bottom tool bar. Thanks for your help.

If you right click the bar -> add item then add window list then the minimised windows will appear

Can you run:

dpkg -l | grep nvidia | grep 190

If the driver is installed then please run:

nvidia-settings

To configure your display, if you get any warning messages, please let us know.

tim (brucetim100) said : #26

If I right click what bar? The only bar I have now is the one with date, time, system, etc...if I right click that I only get options to add to panel, new panel...I tried the new panel, but it's just a blank panel and nothing minimizes to it.

dpkg -l | grep nvidia | grep 190....doesn't do anything I can tell of

Nvidia gives me this error: " MetaMode 32 of Screen 0 is the same as MetaMode 2. All MetaMod must be unique."

use ADD TO PANEL, you can then add the item to the panel.

tim (brucetim100) said : #28

But I'm not missing items I missing the whole bottom toolbar.
Any thoughts on MetaMode?

add a new p[anel then, then add the windows list applet as I described earlier. You can construe things together yourself.

tim (brucetim100) said : #30

ok....but how do I get things windows I close to stick down on this new panel. For example I minimize firefox but it still disappears.

add the windows list item to the panel, this will show you the running app. I've told you 3 times now.

tim (brucetim100) said : #32

I wish I knew computers as well as you. Ok...I got 'window list' added and it works...sorry I didn't understand. Thanks. How about the bigger problem...when I reboot I loses my resolution.

tim (brucetim100) said : #33

This thread is still active. The resolution won't stay when I reboot.

if you run:

gksudo nvidia-settings

You can write the settings to xorg.conf, this will make the settings stick.

tim (brucetim100) said : #35

WARNING: No Layout specified, constructing implicit layout section using screen "Default Screen".
I get this warning...I'll reboot now and see what happens

WARNING: Unable to find CorePointer in X configuration; attempting to add new CorePointer section.

WARNING: The CorePointer device was not specified explicitly in the layout; using the first mouse device.

WARNING: Unable to find CoreKeyboard in X configuration; attempting to add new CoreKeyboard section.

WARNING: The CoreKeyboard device was not specified explicitly in the layout; using the first keyboard device.

tim (brucetim100) said : #36

I did that...write the settings to xorg.conf. When I rebooted it went back to 800 by 600. What's weird about this is I never had any problem before with resolution. I have a Windows OS on this computer and it doesn't have a resolution problem so I assume my graphic card is ok.

Yes because the driver support and such are phenominal in Windows. The fact it works in Windows is completely moot.

Here, use mine, you may get somewhere fast:

run:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_old; gksudo gedit /etc/X11/xorg.conf

press ctrl+a then press delete to empty the file, then paste the below text:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Tue Nov 4 17:18:57 PST 2008

Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load "dbe"
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx"
EndSection

Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 30.0 - 110.0
    VertRefresh 50.0 - 150.0
    Option "DPMS"
EndSection

Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
        Depth 24
    EndSubSection
EndSection

Section "ServerFlags"
EndSection

You should then save the new file and reboot the system. This is from my desktop on a CRT monitor but the range of refresh rates will encompass a TFT screen too.

See how you go.

tim (brucetim100) said : #38

I did all that & rebooted but it didn't work.

ok what happened? "Didn't work" helps nobody and nothing. Details?

tim (brucetim100) said : #40

Well...I did as you wrote, and then rebooted and I'm back to the 800 by 600 resolution

ok then change

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
        Depth 24
    EndSubSection
EndSection

to:

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
        Depth 24
        Modes "1024x768" "1280x1024" "800x600" "720x400" "720x350" "640x480"
    EndSubSection
EndSection

Then reboot. Should be ok then.

If that doesn't work change it to:

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
        Depth 24
        Modes "1024x768_60" "1280x1024_60" "800x600_60" "720x400_60" "720x350_60" "640x480_60"
    EndSubSection
EndSection

(just add _60 to each mode) then reboot again

tim (brucetim100) said : #43

I did the first Section "screen" change, I haven't done the second one adding 60 to each. However I realize that none of the other changes had stayed. As you see below this is what I have. Anyway I'm going to redo the procedure you fist said, that is delete everything and then put in the new screen section you suggested.

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
 DefaultDepth 24
EndSection

Section "Module"
 Load "glx"
EndSection

Section "Device"
 Identifier "Configured Video Device"
 Driver "nvidia"
 Option "NoLogo" "True"
EndSection

tim (brucetim100) said : #44

This is what my xorg.conf file looks like after rebooting and trying all the ways you suggested:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Tue Nov 4 17:18:57 PST 2008

Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load "dbe"
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx"
EndSection

Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 30.0 - 110.0
    VertRefresh 50.0 - 150.0
    Option "DPMS"
EndSection

Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
        Depth 24
        Modes "1024x768_60" "1280x1024_60" "800x600_60" "720x400_60" "720x350_60" "640x480_60"
    EndSubSection
EndSection

Section "ServerFlags"
EndSection

However still the resolution jumps back everytime to 800/600

tim (brucetim100) said : #45

Just now I went to NVIDIA Sever Setting...and put in 1280/1024 resolution and got this error message:
Your current changes to the X server display configuration may no longer be applied due to changes made to the running X server.

You may either reload the current X server settings and lose any configuration setup in this page, or select "Cancel" and save your changes to the X configuration file (requires restarting X to take effect.)

If you select "Cancel", you will only be allowed to apply settings once you have reset the configuration.

tim (brucetim100) said : #46

Should I hit Cancel or Reload current X server settings?

if the file has been editted as I said then reboot the system and it will be read freshly and applied.

Do you get this message after a cold boot or after you have ran nvidia-settings? Does the nvidia-settings now work?

tim (brucetim100) said : #48

I got the message after I rebooted. I got it because when I rebooted I was in faced with same unwanted resolution, so I went to Nividia settings to get a 1280/1024.

did you put 1280/1024 or 1280x1024 in the xorg.conf file? If thats the only res you use yuo can set the screen section to:

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
        Depth 24
        Modes "1280x1024_60"
    EndSubSection
EndSection

An reboot

tim (brucetim100) said : #50

But it doesn't matter what I put in the xorg.conf file, when I reboot I lose the resolution. I've already tried 3 different times.

tim (brucetim100) said : #51

and yes 1280/1024 was one of resolution put in xorg.conf

tim (brucetim100) said : #52

I don't know if related, but before my system crashed, that is I got the black screen and after that can't keep the resolution, my sound would get muted. Sometimes on rebooting but also sometimes going from one media use to another the sound would just disappear. It wasn't a big problem, but I would have to go to sound preference where my output volume would be all the way down and the muted box checked. Anyway it just happen last time I rebooted.

tim (brucetim100) said : #53

the system is crashed this morning, here is the crash report:
Mount of file system failed. 27d23d-16ad-41ea-b54e-26d628f17f80

then there is:
A maintence shell will be started.....give root password for maintenance

however it doesnt' except my password, if I do control D I get more error messages, it seems my sda8, which is just a storage partition not my root or home, is screwed up.
I'm told to run fsck manually...I don't know how
it says the dev/sda8 is an unconnected directory inode 1726632 (/tmp/???)----]

tim (brucetim100) said : #54

in a previous post 87964 I received help to correct the problem of the sda 8 partition that I couldn't mount...when the system first crash 4 days ago, I lost that sda8 partition, that is it wouldn't mount again...I figure I could correct it with info I received in answer to my post on that subject. However it seems to be a problem now? Anyway I'm waiting with instructions on what to do about the maintence shell and password

tim (brucetim100) said : #55

Looks like your busy today, I'll just rebooting the computer and see what happens.

tim (brucetim100) said : #56

No, it doesn't boot into Ubuntu...it's the error I reported above

tim (brucetim100) said : #57

what if I just reformat everything...the problem is finding space for all my data...and then to make sure stuff like thunderbird is properly backed up as it's very important for my job here.

tim (brucetim100) said : #58

I have a crashed computer if anyone could help please

tim (brucetim100) said : #59

I'm wondering something; in NIVIDIA X Server Settings...there is a Configure Display Device, (it booted back into Ubuntu in spite of the crashed file system), the tab reads, 'How should the display device be configured?' with 3 options...Disable (requires X restart) or Seperate X Screen or Twinview. However the only option I have is Seperate X Screen. Is this anything to the problem?

Thats to do a dual display system

tim (brucetim100) said : #61

ok, what do you think I should do or try next?

tim (brucetim100) said : #62

this morning it booted to this maintenance shell thing I described above...how do I run the maintenance?

tim (brucetim100) said : #63

I don't know, maybe be I'm wrong, but it seems you have given up on me. Sorry, but I don't understand a lot of the concepts. Of course if they are new concepts that is why I don't grasp them yet. Anyway, I have to get the system running for my work, and so I'm thinking to reformatted the whole drive. What do you think?

Right now I'm trying to make space on an external so I can back up all my data and mail accounts, etc.

If you think this could solve the problem...I have some questions about reformatting

tim (brucetim100) said : #64

I'm dead in the water. Anyone with suggestions?

I'd reinstall the OS

tim (brucetim100) said : #66

A couple questions then...one is my main concern is not to lose any thing from my thunderbird mail account, I need address plus, emails, plus templates. What do you suggest for backing up such data, as well as for firefox. I already got my other data off.

Second is my computer is a desktop Acer (I got if for a great price in the States.) So I don't have a Windows installation CD, the installation is on the hard drive. I think you know the system and what I mean. I think this installation is at the beginning of my hard drive, in which case my question is should I have Windows as the first part of the partition? The reason I ask is because I read somewhere that seems I'm using Linux basically all the time it's better, and I guess quicker to have it first, then the Windows, so again in this situation can I do that?

If Windows is first I wonder if first I should formatted the entire drive under Windows, and then after install Linux. What would you suggest. I want to devote most of the harddrive to Linux. It's 500GB.

Thanks for your help.

backup ~/.thunderbird is the main folder, you should websearch round where the other data is stored. You should have a backup regime anyway if the data is important to you. What would you do if the disk motor suddenly failed?

If you are dual booting, only partition the disk as much as you wish to give to windows and leave unpartitioned space to give to Ubuntu.

tim (brucetim100) said : #68

Well the situation kind off grew to become important, anyway I'll back-up next time. I don't understand what ~/. is. I think you are saying to copy the whole thunderbird folder, yes? If so when I have Ubuntu up and running would I just add the data manual to the new folder?

I think this is the end of this thread.

tim (brucetim100) said : #69

manually

~/ == $HOME == /home/$USER

tim (brucetim100) said : #71

Alright, thanks again. I copied a pasted what you just wrote to try and understand what it will do and nothing comes up in Google. I'll dick around and try and figure it out on the net like I often do; the problem is there's so much information out there one doesn't know which to try. I do appreciate your help, but most the time you talked over my head so it's been hard to get the information I need to help me and help me learn. Sorry I'm such a dummy, but I think you have to come down from a level of your knowledge to meet mine if your to help the next dummy. I just converted to Linux a year ago and up to this disaster Ubuntu has been a lot like Windows where you don't have to type in terminal and such. Finally to say, I realize Ubuntu is freeware, and that is cool because Bill Gate is just a euthanasiatic, global elitist, that is on my poop list. And I realize your service is free, so I really appreciate that and what you do for the Ubuntu community. Keep up the good work.

tim (brucetim100) said : #72

Thanks you, Actionparsnip