Changed Kernel, Won't Boot

Asked by mavsman4457

I recently installed a custom kernel on my PS3 in order to enable its wifi card and here is where that kernel can be found: http://psubuntu.com/forum/viewtopic.php?t=449&postdays=0&postorder=asc&start=0 I, unfortunately then installed the recommended updates in the update manager, even though I tried to uncheck the kernel updates but it still changed the kernel. I think the custom kernel changed it so that sda1 is now ps3sda1 or something like that and the recommended update tried to change it back but didn't fully succeed and now when I boot up it gets confused. I just want to know how to boot up so I can fix the kernel to be only the custom kernel that I downloaded and none of the recommended kernel. When I try to boot up normally it goes through some text then hangs for a while and tells me this (the numbers and stuff in the top line might not be exactly what I'm getting, I'm not really sure, but I just found this online and it is pretty much the same as what I'm getting):

BusyBox v1.1.3 (Debian 1:1.1.3-2ubuntu3) Built-in shell (ash)

Enter 'help' for a list of built-in commands.

/bin/sh: can't access tty;job control turned off
(initramfs)_

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
mavsman4457
Solved:
Last query:
Last reply:
Revision history for this message
Dennis Dirdjaja (dcd-ditsch) said :
#1

If you are lucky, your old custom kernel is still available. You could try to enter 'old' at the kboot:-Prompt and see if that boots the old custom kernel. Another option is to boot into recovery mode ('linux single' at kboot:-Prompt) in order to change your kboot.conf back to original. The last resort is to boot from the Live-CD, mount your installation and change kboot.conf from there.

To avoid these situations in future, you could lock your original kernel version by setting the package on »hold« in the Package Manager.

Hope this helps,
Dennis

Revision history for this message
mavsman4457 (bdsport445) said :
#2

In that last scenario by "mount your installation" do you mean reinstall the whole thing?

Revision history for this message
mavsman4457 (bdsport445) said :
#3

I just checked through my Live CD and the kboot.conf hasn't changed at all so it must be something in the kernel itself. Is there any way to install a kernel in the live cd or kboot and get the original kernel from the live cd onto my ubuntu without having to reinstall?

Revision history for this message
mavsman4457 (bdsport445) said :
#4

OK after further inspection the error message I am getting when I try to boot is this:

 Check root= bootarg cat /proc/cmdline
 or missing modules, devices: cat /proc/modules ls /dev
ALERT! /dev/ps3da1 does not exist. Dropping to a shell!

BusyBox v1.1.3 (Debian 1:1.1.3-2ubuntu3) Built-in shell (ash)

Enter 'help' for a list of built-in commands.

/bin/sh: can't access tty;job control turned off
(initramfs)_

Revision history for this message
Dennis Dirdjaja (dcd-ditsch) said :
#5

Did you try the other options I mentioned? The error you mention
indicates that you try to boot the new kernel with the options of the
custom one. Please be aware of which kernel you boot with which options.

Could you please try to boot by entering
'/boot/vmlinux initrd=/boot/initrd.img root=/dev/sda1'
at kboot?

Hope this helps,
dennis

Revision history for this message
Best mavsman4457 (bdsport445) said :
#6

Thank you but I just reinstalled altogether. I hate having to do that but I felt it was appropriate.