Can not install libgtk2.0-dev

Asked by Tien Nguyen on 2009-11-17

Hi All,
After install 9.10, I can not install libgtk2.0-dev. Here is what I got:

sudo apt-get install libgtk2.0-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libgtk2.0-dev: Depends: libgtk2.0-0 (= 2.18.3-1) but 2.18.3-1ubuntu1 is to be installed
E: Broken packages

Any ideas what is wrong with my installation?

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Cristi Nistor
Last query:
Last reply:
Best Cristi Nistor (cristi-nistor) said : #1

First check your /etc/apt/sources.list and see if there are any references for an old Ubuntu version. If there is any, comment the lines (add # in front). You can try the following commands:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install -f

and then try to install the desired package.
Or you can use the Synaptic Package Manager (under System --> Administration) and use Edit --> Fix broken packages and use Search to find the package you want to install.

Good luck

Tien Nguyen (tienhn) said : #2

Miraculously, after today upgrade, installation of libgtk2.0-dev went fine without error.


Tien Nguyen (tienhn) said : #3

Thanks Cristi Nistor, that solved my question.