Kernel Panic in Ubuntu 9.10

Asked by Daniel on 2009-11-15

Hi,

          I restarted my computer after updating it, then it appeared a "Kernel Panic" message: "Kernel panic - not syncing: VFS: unable to mount root fs on unknown-block (8,1)". The updates were about apparmor and gnome about screen, basically. It doesn't even start in recovery mode. Ubuntu is installed in Windows, with Wubi. I need help to know if I can solve this error without having to reinstall Ubuntu. I'll appreciate any suggestions.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-11-16
Last reply:
2013-05-26
A. Denton (aquina) said : #1

Try to turn your "sata mode" in your systems BIOS from from "AHCI" or "IDE" or "RAID". Optionally you can boot with the Kernel parameter "irqpoll". To see how to start with a specific parameter see [L1]

[L1] http://translate.google.de/translate?hl=de&sl=de&tl=en&u=http%3A%2F%2Fwiki.ubuntuusers.de%2FBooten

"You can enter these options in grub during PC startup [..]"

- Aquina

Daniel (netsdaniel) said : #2

          In the BIOS, the SATA compatibility is enabled. I tried the irqpoll parameter, and it still displays the Kernel Panic error.

Colin Ian King (colin-king) said : #3

Daniel, I suspect this needs to be opened up as a kernel bug report, with a photo of the kernel panic attached to the bug report.

brettdonahue (brettsan) said : #4

I have the exact same issue, I tried changing the SATA but no luck.

my kernel crash is: (sorry didn't send the screen shot, little hard to do since the boot is messed up, btw my GRUB version is 1.97~beta4)

[Linux-bzImage, setup=0x3400, size=0x3bef40]
[Initrd, addr=0x3782d000, size=0x7c2a54]
[1.971919] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,1)

If I go to enter the commands I have: (also, I am running WUBI on a 64bit vista)
insmod ntfs
set root=(hd0,1)
search --no-floppy --fs-uuid --set 9ee01c97e01c782b
loopback loop0 /ubuntu/disks/root.disk
set root=(loop0)
linux /boot/vmlinuz-2.6.31-41-generic root=dev/sda1 loop=/ubuntu/disks\
/root.disk ro quiet splash
initrd /boot/initrd.img-2.6.31-14-generic

Hopefully there are no typos, the only thing to add, is the last thing I did was accept updates to the system and do a reboot. This was 3 days ago (Nov 13,2009)

A. Denton (aquina) said : #5

Daniel, I agree with Colin King. You problem probably is something new. Try to make a screenshot with a digital camera or mobile phone, upload it and attach it to your filed bug report.

brettdonahue, did you try the irqpoll parameter? Is the backslash in "loop=/ubuntu/disks\" correct? I still assume it's related to Daniels problem since it was caused by an update. It's most likely something in the kernel.

brettdonahue (brettsan) said : #6

I have screen shots with a camera, how do I upload them here? Or should I post to a free site somewhere and link? Not fussed either way. I will confirm the direction of the slash when I get home later.

brettdonahue (brettsan) said : #7

I can confirm the the "\" in question is what is display on the screen, haven't done the research but I am guessing that it just means the command is continued on the next line. I tried to change it the other way and the the line below it jumped one. IRQ pull didn't work either.

The photo question I had earlier I just read your mail again, I see where to post the pics.

A. Denton (aquina) said : #8

When it occours at the end of a line it's indeed a delimiter. Just thought you printed the lines that way for better readability. ;-)

Post the pic maybe at "http://imageshack.us/".

A. Denton (aquina) said : #9

Unfortunately I do not have the powers to change the state of this question to SOLVED, EXPIRED or INVALID. Someone here at Launchpad either grant me that permission or simply apply the change in state to this question, please.

Can you help with this problem?

Provide an answer of your own, or ask Daniel for more information if necessary.

To post a message you must log in.