Terminal window size

Asked by Xpatnat on 2009-11-12

My terminal window always opens maximized and I need to minimize it each time.
How can i get the default size to be minimized?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-11-16
Last reply:
2009-11-17
Cristi Nistor (cristi-nistor) said : #1

You can type in a terminal the following command:

sudo gedit /usr/share/vte/termcap/xterm # this is the file where you can set the behavior of terminal

Look for something like 'co:#134:it#8:li#43:\' (134 cols and 43 lines is the maximum size for a 1024X768 display). You should change it to something like 'co:#80:it#8:li#24:\' or whatever values you want and the window will open in the desired size.

Good luck.

Xpatnat (xpatnat) said : #2

Actually I didn't have to change anything, it already was on the setting you suggested :

# This is a cut-down version of the termcap file from my box with some entries
# removed (add them back in to override the terminal's behavior):
# kI (Insert, Delete is handled programmatically)
# kP/kN (Page Up, Page Down)
# ku/kd/kl/kr (Up, Down, Left, Right)
# k1/kd2/k3/k4/k5/k6/k7/k8/k9/k; (F1-F10)
# K1/K2/K3/K4/K5 (KP Up, Down, Left, Right, Begin)
xterm-xfree86|xterm-new|xterm terminal emulator (XFree86):\
 :am:km:mi:ms:xn:\
 :co#80:it#8:li#24:\
 :AL=\E[%dL:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
........
I tried to reset it even smaller and save (just for the sake of trying something) but no change, the window still opens maximized :-(

Thanks for answering anyway. If you (or someone out there) has any other idea...

Cristi Nistor (cristi-nistor) said : #3

You have another two options to modify the terminal window size.

First type in a terminal the command gconf-editor and Gnome Configuration Tools window will pop up. On the left side go to /desktop/gnome/applications/terminal and for the key with Name=Exec modify the <strong>Value</strong> to be gnome-terminal --geometry=80x24. This command is more useful when you use shortcut keys to open the terminal window

Or you can type in a terminal the command 'gnome-terminal --geometry=80x24' (without the single quote). This command is useful when you use a launcher (i.e. button) to open the terminal window.

Use gnome-terminal --help for more information about this.

Good luck.

Xpatnat (xpatnat) said : #4

I've tried the 2nd solution :-( then the 1st one but ...

...on left side pop up window after going to /desktop/gnome/applications/terminal gives me the choice between :

   Name Value
   Exec gnome-terminal
   Exec_argu -x

No <strong>Value</strong> to modify there !
In desperation I tried to plug "gnome-terminal --geometry=80x24" on the 1st one to no avail.

So if you ...or anybody else out there... had another idea that'd be nice.
Thanks Cristi for the follow up anyway :-)

Cristi Nistor (cristi-nistor) said : #5

Yes, that was the idea, to replace gnome-terminal Value with the one you had. Also make sure you right click the value and click Set as Default or Set as Mandatory.

Trying to remove and reinstall it using Synaptic Package Manger maybe will give you the result you need.

Good luck.

Can you help with this problem?

Provide an answer of your own, or ask Xpatnat for more information if necessary.

To post a message you must log in.