Installation fail libc-bin_2.10.1-3ubuntu1_i386

Asked by lalla on 2009-11-12

Hello!
I've a problem with the installation of the library libc-bin_2.10.1-3ubuntu1_i386 on a virtual machine vmware ubuntu 8.10.
The error report by the shell is:
./libc-bin_2.10.1-3ubuntu1_i386.deb: line 1: syntax error near unexpected token `newline'
./libc-bin_2.10.1-3ubuntu1_i386.deb: line 1: `!<arch>'
how can i resolve it?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Cristi Nistor
Solved:
2009-11-13
Last query:
2009-11-13
Last reply:
2009-11-13
Cristi Nistor (cristi-nistor) said : #1

The name of the package is libc-bin_2.10.1-3ubuntu15_i386.deb. Note the 5 after ubuntu1. Type the correct name of the package you want to install and it should be fine.

Good luck.

lalla (lallac10) said : #2

Thanks but the name that i've post is the name of the file that i've download from ubuntu site...
libc-bin_2.10.1-3ubuntu15_i386.dev does not exist. Where i can find it?????

lalla (lallac10) said : #3

Thanks but the name that i've post is the name of the file that i've download from ubuntu site...
libc-bin_2.10.1-3ubuntu15_i386.dev does not exist. Where i can find it?????

Cristi Nistor (cristi-nistor) said : #4

You can find it here: http://packages.ubuntu.com/karmic/i386/libc-bin/download

You can install this package (if it isn't) going to System --> Administration --> Synaptic Package Manager And search for libc-bin and you'll find 2 packages. Both have ubuntu15 in their name. Where did you get that package? And what do you want to do with it?

lalla (lallac10) said : #5

i've to install a postgres-client and this installation need some library, and also this libc-bin_2.10.1-3ubuntu15_i386.dev .....

lalla (lallac10) said : #6

i try to install libc-bin_2.10.1-3ubuntu15_i386.deb from the site you've post.
but this is the new error....

dpkg:regarding .../libc-bin_2.10.1-3ubuntu15_i386.deb containing libc-bin:
libc-bin breaks libc6(<<2.10)
libc6(version 2.8 20080505-0ubuntu7) is present and installed.
dpkg: error processin /tmp/libc-bin_2.10.1-3ubuntu15_i386.deb(--install);
installin libc-bin would break libc6, and deconfiguration is not permitted (--auto-decongifure might help)

what i could do??

lalla (lallac10) said : #7

i try to install libc-bin_2.10.1-3ubuntu15_i386.deb from the site you've post.
but this is the new error....

dpkg:regarding .../libc-bin_2.10.1-3ubuntu15_i386.deb containing libc-bin:
libc-bin breaks libc6(<<2.10)
libc6(version 2.8 20080505-0ubuntu7) is present and installed.
dpkg: error processin /tmp/libc-bin_2.10.1-3ubuntu15_i386.deb(--install);
installin libc-bin would break libc6, and deconfiguration is not permitted (--auto-decongifure might help)

what i could do??

Cristi Nistor (cristi-nistor) said : #8

What Ubuntu version do you use?

lalla (lallac10) said : #9

8.10 on a virtual machine vmware

Cristi Nistor (cristi-nistor) said : #10

Well, this version of libc-bin is for Jaunty Jackalope (9.04 version) and up. It seems that you cannot install that postgresql-client for your version of Ubuntu. Try to install a postgres client that is suitable for your operating system. You can go to Synaptic Package Manager and look for postgresql-client.

Good luck.

lalla (lallac10) said : #11

The results of Synaptic Packege Manager is nothing!
So i couldn't installa a postgres Client?

Best Cristi Nistor (cristi-nistor) said : #12

Try to run these commands in a terminal:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install postgresql-client

Good luck.

lalla (lallac10) said : #13

Thanks Cristi Nistor, that solved my question.