sound card not working after upgrade to 9.10

Asked by krassib on 2009-11-12

krassib@krassi-ubuntu-001:~$ bash alsa-info.sh --pastebin
WARNING: All config files need .conf: /etc/modprobe.d/sound, it will be ignored in a future release.
ALSA Information Script v 0.4.58
--------------------------------

This script visits the following commands/files to collect diagnostic
information about your ALSA installation and sound related hardware.

  dmesg
  lspci
  lsmod
  aplay
  amixer
  alsactl
  /proc/asound/
  /sys/class/sound/
  ~/.asoundrc (etc.)

See 'alsa-info.sh --help' for command line options.

WARNING: All config files need .conf: /etc/modprobe.d/sound, it will be ignored in a future release.
/usr/sbin/alsactl: save_state:1502: No soundcards found...
cat: /tmp/alsa-info.SyhFpDttTh/alsactl.tmp: No such file or directory
Automatically upload ALSA information to pastebin? [y/N] : y
Uploading information to www.pastebin.ca ... Done!

Your ALSA information is located at http://pastebin.ca/1667683

Please inform the person helping you.

krassib@krassi-ubuntu-001:~$

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-11-12
Last reply:
2009-11-12
Cristi Nistor (cristi-nistor) said : #1

Driver version: 1.0.17
Library version: 1.0.21a
Utilities version: 1.0.21

You have an old version for the driver. It seems that the system does not boot with the latest kernel version 2.6.31. At start up press ESC to chose the kernel in GRUB. If is not present try to install it using Synaptic Package Manager (search for linux 2.6.31 and install the linux-image, alsa-module-2.6.31-XX-generic, linux-headers and linux-headers-generic for the latest version).

Reboot and test your system.

Good luck.

Can you help with this problem?

Provide an answer of your own, or ask krassib for more information if necessary.

To post a message you must log in.