Realtel Wired Ethernet not usable

Asked by raddy on 2007-06-29

Hello Everybody

I am using Ubuntu 7.0.4 .
Realtek RTL8168/8111 Family PCI-E Gigabit wired ethernet controller is not usable both in dhcp mode and static mode.

Seems avahi has a bug in assigning ip from dhcp, as many people suffers in avahi assigns some invalid ip address in my system too in dhcp.

When i use static ip, everything seems fine, but no internet.

the problem is easily reflected in the system logs.

"kernel: [ 205.476670] r8169: eth0: link down"
"kernel: [ 205.476704] ADDRCONF(NETDEV_UP): eth0: link is not ready"

My system connects to internet via a router.

Both XP and Vista connects to internet fine.
When i am in ubuntu an ethernet light won't even glow in my router.

Please help me, there is no other way to access internet without ethernet.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Dave Walker
Solved:
2007-07-03
Last query:
2007-07-03
Last reply:
2007-07-02
raddy (raghugs) said : #1

/etc/network/interfaces

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.1.15
netmask 255.255.255.0
gateway 192.168.1.1

auto eth1
iface eth1 inet dhcp

auto eth2
iface eth2 inet dhcp

auto ath0
iface ath0 inet dhcp

auto wlan0
iface wlan0 inet dhcp

raddy (raghugs) said : #2

Output of /sbin/ifconfig -a

eth0 Link encap:Ethernet HWaddr 00:15:F2:C2:20:9C
          inet addr:192.168.1.10 Bcast:192.168.1.255 Mask:255.255.255.0
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
          Interrupt:16 Base address:0xe000

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:26 errors:0 dropped:0 overruns:0 frame:0
          TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1604 (1.5 KiB) TX bytes:1604 (1.5 KiB)

Finally, my ethernet controller is using r8169 driver module came with ubuntu 7.0.4 kernel.

Best Dave Walker (davewalker) said : #3

Hi Raddy,

It seems others are having a similar problem when using Windows on the same machine. Can i ask you to try the following and report back?

http://ubuntuforums.org/showthread.php?p=2901884

raddy (raghugs) said : #4

Thanks Dave Walker, that solved my question.

raddy (raghugs) said : #5

Hi Dave Walker,

Even that is the exact solution,
I learn that fix by hard way, researching and found a related discussion.
Keep this solution sticky somewhere

Antonio Arauzo-Azofra (arauzo) said : #6

I think the right solution is solving bug #208012 (a wrong driver is loaded for this ethernet device)

In the meanwhile, there is a solution in the comments to bug:
 https://bugs.launchpad.net/ubuntu/+bug/208012