from recovery option how does system load

Asked by Daniel Stone on 2009-11-06

I have grub option for kernel
I choose the recovery option
this option when I choose boot normally brings a command prompt
login
I login
but the desktop does not load
is there something that I must do to get the gui to load for the regular login screen or is this a bug?
If it is a bug
what package
because system loads fine when I do not choose recover/maintenance option
only happens from that menu option Boot Normally
I can use the other options of the menu just the one option seems to have issues
I do notice in 9.10 I have no option to graphic repair/fix
so would this be upstart not loading xorg or grub not loading upstart from menu option
and should I or rather can I update grub so it is not BETA and how

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Daniel Stone
Solved:
2009-11-06
Last query:
2009-11-06
Last reply:
2009-11-06
Shashank Sahni (shredder12) said : #1

Why are you booting through recovery mode? Are you having trouble through normal booting?
When you select boot normally option after booting into recovery mode you are dropped to a shell prompt. After logging in shell have you tried restarting the gnome desktop manager?
If not try "startx" or "sudo /etc/init.d/gdm start".

You have chosen recovery mode, You have booted to a recovery console by the sounds of it. This is normal.

If you have chosen a safe mode graphical mode then the GUI should run.

Daniel Stone (danielstone) said : #3

= at actionparsnip =I do not have a safe graphic mode option avilailable from grub I think you are thinking of recovery from LiveCD
= at shredder12 =
[quote]because system loads fine when I do not choose recover/maintenance option[/quote]

I am booting through the option on the grub
this was not like this in previous builds but I will try the commands
"startx" or "sudo /etc/init.d/gdm start"

to me the seems to be link missing in the Boot Normally option choice selection in the Grub maintenance menu

Daniel Stone (danielstone) said : #4

startx seems to work but the sudo /etc/init.d/gdm start command is not found

Shashank Sahni (shredder12) said : #5

great...
i m not sure why it didn't work..
you may try "sudo /etc/init.d/gdm restart" or "service gdm start/restart"

Daniel Stone (danielstone) said : #6

I think it was me I have a bad habit of putting ect instead of etc I noticed that afterward when I looked at my notes