How to install ndiswrapper in Ubuntu 9.10

Asked by SaferDoc on 2009-11-05

On 9.10 trying to use ndiswrapper to install driver for Belkin F5D8010 wireless card.
All O.K. until performing make of ndiswrapper:

sandra@sandra-laptop:~/ndiswrapper-1.55$ sudo make
make -C driver
make[1]: Entering directory `/home/sandra/ndiswrapper-1.55/driver'
make -C /usr/src/linux-headers-2.6.31-14-generic M=/home/sandra/ndiswrapper-1.55/driver
make[2]: Entering directory `/usr/src/linux-headers-2.6.31-14-generic'
  LD /home/sandra/ndiswrapper-1.55/driver/built-in.o
  MKEXPORT /home/sandra/ndiswrapper-1.55/driver/crt_exports.h
  MKEXPORT /home/sandra/ndiswrapper-1.55/driver/hal_exports.h
  MKEXPORT /home/sandra/ndiswrapper-1.55/driver/ndis_exports.h
  MKEXPORT /home/sandra/ndiswrapper-1.55/driver/ntoskernel_exports.h
  MKEXPORT /home/sandra/ndiswrapper-1.55/driver/ntoskernel_io_exports.h
  MKEXPORT /home/sandra/ndiswrapper-1.55/driver/rtl_exports.h
  MKEXPORT /home/sandra/ndiswrapper-1.55/driver/usb_exports.h
  CC [M] /home/sandra/ndiswrapper-1.55/driver/crt.o
In file included from /home/sandra/ndiswrapper-1.55/driver/crt.c:16:
/home/sandra/ndiswrapper-1.55/driver/ntoskernel.h: In function ‘PushEntrySList’:
/home/sandra/ndiswrapper-1.55/driver/ntoskernel.h:905: error: implicit declaration of function ‘cmpxchg8b’
make[3]: *** [/home/sandra/ndiswrapper-1.55/driver/crt.o] Error 1
make[2]: *** [_module_/home/sandra/ndiswrapper-1.55/driver] Error 2
make[2]: Leaving directory `/usr/src/linux-headers-2.6.31-14-generic'
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/home/sandra/ndiswrapper-1.55/driver'
make: *** [all] Error 2
sandra@sandra-laptop:~/ndiswrapper-1.55$

It looks as though the header file ntoskernel.h is the offending entry... but I have no idea how to fix.

Suggestions?

Thanks....

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-11-05
Last reply:
2009-11-06

There is no need to compile ndiswrapper. It is available in the Ubuntu repositories.

Here is output of following command:

$ sudo aptitude search ndis
p ndisc6 - IPv6 diagnostic tools
p ndisgtk - graphical frontend for ndiswrapper (installation of Windows WiFi drivers)
p ndiswrapper-common - Common scripts required to use the utilities for ndiswrapper
v ndiswrapper-modules-1.9 -
p ndiswrapper-utils-1.9 - Userspace utilities for the ndiswrapper Linux kernel module

So you can install ndiswrapper and the graphical frontend ndisgtk by running the following 2 commands:

sudo aptitude update
sudo aptitude install ndisgtk

SaferDoc (ri-cook) said : #2

I did try to install ndisgtk & it seems to be there:

sandra@sandra-laptop:~$ sudo aptitude search ndis
p ndisc6 - IPv6 diagnostic tools
i ndisgtk - graphical frontend for ndiswrapper (instal
i ndiswrapper-common - Common scripts required to use the utiliti
v ndiswrapper-modules-1.9 -
i A ndiswrapper-utils-1.9 - Userspace utilities for the ndiswrapper Li
sandra@sandra-laptop:~$

The tool shows up in the System>Administration menu as "Windows Wireless Drivers".

But when I click on this I get the authorization dialog and after I have entered the password the driver window flashes on the screen and is gone. I've tried to start ndisgtk from a terminal window and I get:

\sandra@sandra-laptop:~$ sudo ndisgtk
[sudo] password for sandra:
Traceback (most recent call last):
  File "/usr/sbin/ndisgtk", line 364, in <module>
    NdisGTK()
  File "/usr/sbin/ndisgtk", line 122, in __init__
    self.setup_driver_list()
  File "/usr/sbin/ndisgtk", line 150, in setup_driver_list
    self.get_driver_list()
  File "/usr/sbin/ndisgtk", line 162, in get_driver_list
    output,retcode = getoutput("ndiswrapper", "-l")
  File "/usr/sbin/ndisgtk", line 34, in getoutput
    myproc = subprocess.Popen(cmd, stdout=subprocess.PIPE, stderr=subprocess.STDOUT)
  File "/usr/lib/python2.6/subprocess.py", line 621, in __init__
    errread, errwrite)
  File "/usr/lib/python2.6/subprocess.py", line 1126, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
sandra@sandra-laptop:~$

I'm as baffled as I was before...

peter b (b1pete) said : #3

I just tried installing ndiswrapper via synaptic and it works flawless; suggestion, uninstall ndisgtk then search in synaptic for ndis and install the 3 packages

ndisgtk
ndiswrapper-common
bdiswrapper-utilsXXX

I even plugged in an usb wireless dongle and loaded its win drivers via CLI not ndisgtk (installed but I just ignored it) , configured and loaded ndiswrapper module, all with no problems whatsoever. ended up with a new wifi connection choice.

btw. you can ignore installing ndisgtk if you're familiar with ndiswrapper CLI . I prefer CLI - it gives better control.

Can you help with this problem?

Provide an answer of your own, or ask SaferDoc for more information if necessary.

To post a message you must log in.