Ubuntu fiesty Wireless driver installation

Asked by bobosky

Okay I am really new here and this is all greek to me.
I have a 2003 Toshiba P3 I just installed 7.04 my first Linux install ever, and all I want is for the wireless to work.
So how do I get this ipw3945 on to my Ubuntu computer and installed?
Please don't talk in code. Can you format this in steps?

The steps I think I have done so far.
- download ipw3945 from http://bughost.org/ipw3945/ucode/ipw3945-ucode-1.14.2.tgz on another computer
- put ipw3945 on a removeable drive
- save ipw3945 on the Ubuntu 7.04 computer's desktop
- Go to Applications then Accessories thenTerminal
- type SOMETHING....?

That is about all I got Please correct me!

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Francesco Conti (madmoose) said :

Maybe you can try this:

deb http://ace-host.stuart.id.au/russell/files/debian/sarge/ipw3945-daemon/ ./
deb http://ace-host.stuart.id.au/russell/files/debian/sarge/ipw3945-ucode/ ./
sudo aptitude install ipw3945-daemon ipw3945-ucode

they're from debian sarge but they're static binaries so you should have no problem in installing on Ubuntu

Revision history for this message
bobosky (codemonkey) said :

First thanks for helping me out. I work late so I only get a few hours a night to work on this.

I went to http://ace-host.stuart.id.au/russell/files/debian/sarge/ipw3945-daemon/
And downloaded ipw3945-daemon_...i386.deb
Moved it to the Ubuntu computer and clicked on it. It opened and installed.
I restarted the computer and went to the Network Manager and did not see the wireless card.
My Linksys Wireless-G WPC54Gx4 lights up when in the Ubuntu computer but the computer does not seem to know it is there.

I went to http://ace-host.stuart.id.au/russell/files/debian/sarge/ipw3945-ucode/
And downloaded ipw3945-uncode_1.13-1_all.deb
And did the same as before. The wireless card still is not found by the computer.

I literally only have two hours a night to work on this and I am learning quickly that I can spend alot of time in these forums before I find the right answer so I am very thankful that you are taking the time to help me.


Revision history for this message
Bhavani Shankar (bhavi) said :

You have to compile the source tarballs.. Info on compiling can be found at https://help.ubuntu.com/community/CompilingSoftware and http://liquidweather.net/howto/index.php?id=82 and I think ipw945 should be automatically detected by fiesty as I am using it.. and there are no problems...
Bhavani Shankar.

Revision history for this message
Bhavani Shankar (bhavi) said :

Also do you have the hardware with you?

Revision history for this message
bobosky (codemonkey) said :

Yes, I have the 2003 Toshiba Satellite Laptop 1135-S1552 and Linksys Wireless-G WPC54GX4 right here infront of me.
The card worked with in this computer with my Airport Express when I was running XP.

Got to head to work, so I will read up on compiling at 11pm tonight. Thanks for the tips and the help.
It would be nice if this automatically detect in feisty and worked with no problems, but lucky me I get to learn something new, and find out how to get the computer to see the wireless card and then connect the internet over it!


Revision history for this message
Duncan Lithgow (duncan-lithgow) said :

Please remember to contact http://www.linksys.com and ask them. It is their hardware so they should provide a driver for it. They probably don't but it's important to keep asking so they know Linux users want drivers from hardware manufacturers.

Have you read this post, similar hw: http://ubuntuforums.org/archive/index.php/t-186319.html
Some other Forum posts you might want to look at:
* http://ubuntuforums.org/showthread.php?t=186538&highlight=wpc54g
* http://ubuntuforums.org/showthread.php?p=1105101#post1105101

Revision history for this message
bobosky (codemonkey) said :

Wow. I never really thought of myself as a quitter but none of these are getting me anywhere. It is killing me to have so little time to make this work and digging my way to dead end after dead end, is driving me nuts.

Is there anyone in the Portland Oregon area who can help me?

Revision history for this message
Duncan Lithgow (duncan-lithgow) said :

I'm sorry you're having so much trouble, I know how frustrating it can be. I got frustrated just trying to find a solution for you! One thought is that you might want to try some other live CDs just to see if one of them detects it - that would tell you that it can be done, or tell you nothing. I'd suggest Kanotix which is well known for having very good hardware support (I don't know if it's better) and of course please try a daily Live CD of Ubuntu 7.10 (Gutsy Gibbon): http://cdimage.ubuntu.com/daily-live/current/ - but even if this works, don't install it, it's unstable.

I had to laugh when I read where you live. Have a look at this link to the UbuntuLive conference, it's being held in... http://www.ubuntulive.com/

There's an Ubuntu users group in Oregon, if you think you need person to person help you can join their list and ask for help there: https://lists.ubuntu.com/mailman/listinfo/Ubuntu-us-or

Revision history for this message
bobosky (codemonkey) said :

Thank you for everyone who has been on this up and down ride through my wireless problem. I have taken a deep breath and readied myself for some more humbling learning. Thank you, Duncan Lithgow for the encouragement and the links. I would love to go the Ubuntu Live conference and I am hoping to get time off work and a pass in the door.

I am going to be camping this weekend so will be back testing Sunday night.

Thanks again.


Revision history for this message
Alan Pater (alan-pater) said :

You should not have to install anything, never mind compile anything.

   "Under Feisty, the driver for Intels ipw3945 is loaded by default, no configuration is needed."

Revision history for this message
bobosky (codemonkey) said :

Thanks Alan

I followed the directions on the link and got this message.
E: Couldn't find package net-manager-pptp

I don't know if this was clear in my first post but I don't even have a working Ethernet connection on my Ubuntu computer. I notices that some the the dead end I went down were assuming I had some form of internet connection.

Both the wireless card and the ethernet worked in XP right before I installed 7.04 so I don't think it is broken hardware.

I think I will install Kanotix and see if that works.

Revision history for this message
ChrisKelley (ckelley) said :

Yes... E: Couldn't find package net-manager-pptp

I went down the same path with my Sony SZ220... downloading and compiling this and that. (turns out I was installing network manager like I had Dapper or something!)

What this E: means is that the package you're trying to install depends on the net-manager-pptp package. I think I did this for about 3 hours one night and was all frustrated and about to give up.

Then I accidentally right clicked on the icon in the system tray with the ethernet cable plugged into the socket... it never dawned on me that the sole and lonely single "network manager" icon could control BOTH the wired and wireless adaptors! I was programmed by windblows that there would be separate icons for wired and wireless.

You really want to use network manager... I'm running Kubuntu Feisty 7.04... so in Konsole, I did this:
18:04 chris@sz:~$ which knetworkmanager
18:04 chris@sz:~$ knetworkmanager --help
Usage: knetworkmanager [Qt-options] [KDE-options]

A NetworkManager front-end for KDE

Generic options:
  --help Show help about options
  --help-qt Show Qt specific options
  --help-kde Show KDE specific options
  --help-all Show all options
  --author Show author information
  -v, --version Show version information
  --license Show license information
  -- End of options
18:05 chris@sz:~$ knetworkmanager --help-kde
Usage: knetworkmanager [Qt-options] [KDE-options]

A NetworkManager front-end for KDE

Generic options:
  --help Show help about options
  --help-qt Show Qt specific options
  --help-kde Show KDE specific options
  --help-all Show all options
  --author Show author information
  -v, --version Show version information
  --license Show license information
  -- End of options

KDE options:
  --caption <caption> Use 'caption' as name in the titlebar
  --icon <icon> Use 'icon' as the application icon
  --miniicon <icon> Use 'icon' as the icon in the titlebar
  --config <filename> Use alternative configuration file
  --dcopserver <server> Use the DCOP Server specified by 'server'
  --nocrashhandler Disable crash handler, to get core dumps
  --waitforwm Waits for a WM_NET compatible windowmanager
  --style <style> sets the application GUI style
  --geometry <geometry> sets the client geometry of the main widget - see man X for the argument format
  --nofork Don't run in the background.
18:05 chris@sz:~$

Then from the KDE run menu: knetworkmanager --nofork

That's when the 2nd network icon showed up and I learned that the exiting one already running could manage wifi. Then when you right-click on it, select options and Configure Autostart and click the Start Automatically button.

For seamless wireless operation, I have learned:
- do not assign a password to kwalletmanager, else the knetworkmanager will sometimes fail
- knetworkmanager logs the MAC addy of the access points... if you try to be clever and have the same SSID and Security at home and work, everytime you switch from one to the other, it overwrites the previous.

 work->home (new password)
 work->work (auto logon)

hopefully there is some help in here for you. :)

Can you help with this problem?

Provide an answer of your own, or ask bobosky for more information if necessary.

To post a message you must log in.