Cannot Install RPM [Xbuntu]

Asked by Art Andersons

I just installed Xbuntu on a...old machine.

And have a bit of a problem.

Everytime that I try to install anything that comes packaged as a .rpm file, I get a series of dependency issues related to glibc-2.6.

The command I've used to attempt installing the .rpm is: rpm install <name_of_the_file>

Is there a easy way to install glibc? I've tried to use apt-get glibc-2.6, but get nothing.

Thoughts, comments?

Help would be appreciated.



Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Benjamin Rubin
Last query:
Last reply:
Revision history for this message
Best Benjamin Rubin (bnrubin) said :

RPMs are not a supported package in Ubuntu. Rather, you should be installing deb packages that have been made with Ubuntu in mind. Additionally, the package you seek might be in the Ubuntu repositories.

If you can't find the deb package you need you may try to convert it using the alien utility, but this is reserved for advanced users and can break your system.

If you are looking to install glib on Feisty, the package name is libglib2.0-0

Revision history for this message
Art Andersons (expensive-wino) said :

Thanks Benjamin Rubin, that solved my question.