Ubuntu 9.10 Network: device not managed

Asked by alex_buc on 2009-11-03

Hello,
i've just upgraded my Ubuntu from version 8.04 to version 9.10. My problem now is that i cannot manage my network connections. If I click on the Network icon I get the following message: "Wired: device not managed". Apart from this, the connection is working just fine.
Please help resolve this issue.
Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
alex_buc
Solved:
2009-11-06
Last query:
2009-11-06
Last reply:
2009-11-04

Hi,

I suggest this procedure to replace NetworkManager with wicd:

First connect your network card to the wireless router using a LAN cable.

Then please follow this procedure:

Step 1: Open Terminal from "Applications->Accessories->
Terminal"

Step 2: Run the following commands (copy-paste each line below to the Terminal then hit <enter> after each line)

sudo aptitude update
sudo aptitude install wicd

Step 3: Please post results (copy/paste terminal output from each command) on this thread

You can read more about wicd here: http://en.wikipedia.org/wiki/Wicd_(Linux_Network_Manager)

Then reboot and you should then see a new wicd icon appear in the Ubuntu panel (wicd Linux network manager icon)

Regards,

Mark

Thomas Krüger (thkrueger) said : #3

Your interface4 is still configured by the old network setup system of 8.04.
You interface should be listed in /etc/network/interfaces.
If everything works fine you do not need to change anything. But if you want to have Network Manager handeling the conenction you can reduce /etc/network/interfaces to:

auto lo
iface lo inet loopback

Cristi Nistor (cristi-nistor) said : #4

In the /etc/NetworkMananger/nm-system-settings.conf should be managed=true under [ifupdown]. What is the content of your local file?

zvacet (ivicakolic) said : #5

If it is not broken don't fix it.And +1 to Thomas Krüger

alex_buc (alex-mitrea) said : #6

@Mark Rijckenberg - thank you, but i don't like wicd and my problem doesn't involve wireless
@Thomas Krüger and @Cristi Nistor - i've tried both your suggestions, it didn't changed anything unfortunately

So i've just gived up, it's working fine for the moment .

Thank you all for the answers.

Cristi Nistor (cristi-nistor) said : #7

I have the same issue for my DSL connection. After pon dsl-provider command the connection is up, even the network manager shows that is disconnected. If I connect it directly to the Internet it shows correctly the status. But, I think I'll live with it as it is.

h3X (lennart-nilsen) said : #8

I also have this problem, both on wired and wireless. No connection on either.