Ubuntu 9.1 Master Volume defaults to mute

Asked by Vick

After upgrading from Ubuntu 9.04 to 9.1 I found that there is no sound. Opening System>preferences>sound I found the output volume to be set at 3 and the mute box ticked. Changing that resolved the issue. This how-ever was only till the next reboot. After each reboot I have to go and set the volume and take mute off.

Is there a fix that does not involve all sorts of command-line entries as I'm not familiar with Linux yet.



Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Richard Seguin (sectech) said :

Thank you for your question. I think we need a little more information about how the kernel is finding your sound card to resolve this one. The default behaviour that I have experienced is that the mute checkbox wasn't ticked.

1. Does this still occur after you have updated the system and rebooted?

If so... could you provide some information about what kind of sound card that you have? Make/model. I'll do some research to see if others with your card are having problems and how they resolved it.

If this is completely unique I can convert your message to a bug and take it from there.


Richard Seguin

Revision history for this message
Sam_ (and-sam) said :

I can confirm that sound was muted after installation of Karmic(beta).
But there is a sound applet in 'notification area' and I just unchecked muted and that was it.
Maybe it has something to do with upgrading and ALSA isn't correctly initialized during boot.

In case to reconfigure ALSA you may try:
sudo dpkg-reconfigure alsa-base

I know 'no CLI', but most of the time things can be fixed easily this way.
You may also install gnome-alsamixer (GUI) to adjust what ever you like.


Revision history for this message
actionparsnip (andrew-woodhead666) said :

I used to have this:

The solution was comment out line 372 in /etc/init.d/alsa-utils. The line in question was

mute_and_zero_levels “$TARGET_CARD” || EXITSTATUS=1

Just this small change has solved the issue for me.

Here is a code snippet, the last line is the commented line:

case "$1" in
        case "$TARGET_CARD" in
          ""|all) TARGET_CARD=all ; log_action_begin_msg "Setting up ALSA" ;;
        if ! card_OK "$TARGET_CARD"; then
                [ "$TARGET_CARD" = "all" ] && log_action_end_msg "$( [ ! "$2" ] ; echo $? ; )" "none loaded"
                exit $?
        preinit_levels "$TARGET_CARD" || EXITSTATUS=1
        if ! restore_levels "$TARGET_CARD" ; then
                sanify_levels "$TARGET_CARD" || EXITSTATUS=1
                restore_levels "$TARGET_CARD" >/dev/null 2>&1 || :
        [ "$TARGET_CARD" = "all" ] && log_action_end_msg_and_exit "$EXITSTATUS"
        exit $EXITSTATUS
        case "$TARGET_CARD" in
          ""|all) TARGET_CARD=all ; log_action_begin_msg "Shutting down ALSA" ;;
          *) log_action_begin_msg "Shutting down ALSA card ${TARGET_CARD}" ;;
        card_OK "$TARGET_CARD" || log_action_end_msg_and_exit "$( [ ! "$2" ] ; echo $? ; )" "none loaded"
        store_levels "$TARGET_CARD" || EXITSTATUS=1
# mute_and_zero_levels "$TARGET_CARD" || EXITSTATUS=1

Simply add the # character, save the file and reboot, solved :D

Revision history for this message
Vick (vick-vickma) said :

Hi all!

This morning my sound was fine. Rebooted the system a couple of times just to make sure, everytime changing the master volume level and after each reboot it was still the way I had it set.

The only explanation that I can think of is this:

I had Kaffeine installed as an audio player for its equalizer. After upgrading from 9.04 to 9.1 Ubuntu, Kaffeine was "stuffed" It open the audio files but did not play it. Clicking on the play button result in nothing. So, last night I decided to remove Kaffeine completely from the system. Switching the PC on this morning was the first boot after removing Kaffeine. I therfore think that Kaffeine had something to do with my sound issue.

Actionparsnip, I had a look at the alsa-utils file and the line you refer to is still without the # sign and sound is working fine now.

I think in my case it was Kaffeine.

Thanks all

Revision history for this message
gary (grg1gary) said :

seems that alpha-base is not installed in this upgrade. says to check the files. i have no idea what this target card stuff is that is one of the responses.. if it works when its set and throughout the use it doesnt make sense that it would reset itself to zero after reboot. isnt there just a save settings procedure that is required?? thanks