White Noise Problem Ubuntu 9.1 .. Running Msi 1223

Asked by plc1127 on 2009-10-31

Hi Everyone,

I am having problems with Ubuntu 9.1.. since the upgrade, I get this white noise through my laptop speakers. It goes away when I play music or video, but it comes back about 30 sec. after the music stops.. I have tried everything I know and all options in sound preference including just turning the hardware off, and it doesnt work... its quite annoying. Please help

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
plc1127
Solved:
2009-11-01
Last query:
2009-11-01
Last reply:
2009-10-31
Colin Ian King (colin-king) said : #1

This is most probably the audio power saving mode kicking in and causing clicks/pops when the audio hardware is transitioning to a low power mode.

To disable the power saving mode using snd-hda-intel edit /etc/modprobe.d/modprobe.conf (e.g. use sudo gedit to edit this file) and add the following line:

options snd-hda-intel power_save=0

reboot and see if this solves the problem

Colin Ian King (colin-king) said : #2

Add the line to alsa-base.conf You may find that "options snd-hda-intel power_save" is already present in alsa-base, but it's set =10. Set it =0 instead.

plc1127 (plc1127) said : #3

what program do I use to add the lines to the files?? sorry I am a bit of a newbie to Ubuntu. can you do a step by step? thanks

plc1127 (plc1127) said : #4

Never Mind. I figured out how to use gedit to get it done and it seems to have worked. Thank you so much for the help Colin.