upgrade ubuntu 9.04 to 9.10 unable to mount

Asked by lottemoller on 2009-10-31

Just upgraded from within 9.04 to 9.10, but when system boots up I get message

mountall:/proc: unable to mount: Device or resource busy
mountall:/proc/self/mountinfo: No such file or directory
mountall: root filesystem isn't mounted

When I enter the root shell, I can see that all fileystems are read-only, so I am unable to change anything.

Any advice?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
lottemoller
Solved:
2009-11-02
Last query:
2009-11-02
Last reply:
2009-11-02
Cristi Nistor (cristi-nistor) said : #1

In recovery mode you can run the command:

sudo mount -o rw,remount /

or

sudo mount -o rw,remount /dev/sda (or whichever device is)

and then

sudo update-grub

Good luck

ChrisC (ccurrier99) said : #2

I had the same message, and recovery was not the issue (didn't help me). If you dual boot, the update does not seem to update the configuration files used. I updated easyBCD (boot loader) following these directions: http://apcmag.com/how_to_dualboot_vista_with_linux_vista_installed_first.htm?page=4
This worked for me - hope it helps....

lottemoller (lars-ottemoller) said : #3

I was able to change the menu.lst in /boot/grub to include the 9.10 version, so it looks like in my case this file was not updated properly.

Thanks.

Parag Joshi (pmj005) said : #4

The reason is that during upgrade, although new linux kernel may have been installed, grub boot loader was not updated to use the new kernel.
9.10 karmic uses kernel version 2.6.31-22. So, edit /boot/grub/menu.lst and add an entry (copy previous kernel entry) and change kernel and initrd entries to use the new 2.6.31-22 kernel.
After that it should work perfectly!