Jaunty -> Karmic upgrade: Cannot log in any more

Asked by Xenophon


  I have an ASUS motherboard which thus far has been running Kubuntu Intrepid and Jaunty fine with no issues. I upgraded to Karmic yesterday and suddenly found that I cannot log into my system any longer. I enter my username and password and try to log in. KDE attempts to start loading and gets to the "loading" screen with the five icons. The HDD icon lights up and then the screen flickers and I'm back at the login screen. Sometimes, it progresses past this stage and then kicks me back to the login screen.

  I can log in fine via a terminal (with ctrl + alt + f1). I have updated all my packages with apt.

  Things that I have tried so far (and did not work):

* Renamed my .kde directory to .kde.bak and tried logging in. This fails, but I do see a .kde directory being created.
* This board has a VIA chipset and requires unichrome drivers. I'm pretty certain that I was using the openchrome drivers and had things working with Jaunty. I tried reinstalling these via apt.
* I've tried using xorg -configure to create a template xorg.conf file and used it.
* With the above xorg.conf file, I've tried specifying vesa as the driver. X complained about vesa not supporting 24 bit and crashed.
* I've also tried removing xserver-xorg-video-openchrome and restarting. X does not start.

I'll attach log files shortly.

I'm happy to stick around and get this solved completely. But in the interim, could somebody suggest a way to get my display back with VESA? I don't mind 640x480 resolution etc. while I try to find a solution.


Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Xenophon (email-xenophon) said :

I don't seem to be able to attach files. I've used pastebin for the logs:

dmesg | tail - http://pastebin.com/f3737a630
lspci -vnnn - http://pastebin.com/f1a438a34
lspci -vvv - http://pastebin.com/f573061bb
Xorg.0.log - http://pastebin.com/f681ec29f

Revision history for this message
Xenophon (email-xenophon) said :

Sorry for the spam. But I'd like to note that the above log files are for the standard install without any of my attempted workarounds. So, there is no xorg.conf file and my .kde directory is intact.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Can you provide the output of:

ls -la /home/$USER


Revision history for this message
Xenophon (email-xenophon) said :

Thanks for the reply. What exactly are you looking for? My home directory is intact and files that were previously there still are. The .kde directory is present and appears to be intact and healthy at ~60MB.


Revision history for this message
actionparsnip (andrew-woodhead666) said :

thats not what I'm after, you need to check you are the owner of ALL files in your home folder. Thats why I asked for the output.

Revision history for this message
Xenophon (email-xenophon) said :

Yes, I own all the files and directories in my home directory when I list them via "ls -la".

Revision history for this message
ajmal_82 (ajmal-82) said :

hey i think something got messed esp keyring thing........so i suggest you to do clean install of 10.4

Can you help with this problem?

Provide an answer of your own, or ask Xenophon for more information if necessary.

To post a message you must log in.