Extraño sonido en cornetas con Ubuntu 9.10 que en el 9.04 no hacia!

Asked by eros10509 on 2009-10-30

Hola saludos nuevamente! :)

Tengo un problema con el sonido de mi laptop que no tenia al usar Ubuntu 9.04, ahora tengo el 9.10 por medio de "Actualizacion"

Puedo escuchar un pequeño "Click" o mas bien como un "trick" :) en las cornetas de mi equipo desde que lo actualice a la version 9.10 es bastante desagradable sobre todo cuando uso audifonos o cuando lo conecto a equipos para exposiciones en la universidad. Le he tomado el tiempo al al mal bañado sonido este y suena cada 10 segundos exactamente.

He visto en otras preguntas que esta version ha dado problemas con el sonido en otros equipos, pero ninguno con un "tirck" como este.. =S. Es esto normal? (Obviamente no, pero uds me entienden =P) o debo actualizar mis drivers o algo??

Tengo una laptop Alienware® Area-51 m5550 que cundo compre las caracteristicas decian:

Audio: Intel® 7.1 High-Definition Audio

Aunque yo no le veo las conexiones ni para las 7 ni para el .1 jeje solo la entrada para los audifonos y yap.. =S
pero bueno eso es lo que dice.. Espero que con esta informacion me puedan ayudar a resovler los del malvado "Trick" -,-
Gracias!! :)

Question information

Language:
Spanish Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Xtiancr
Solved:
2009-11-02
Last query:
2009-11-02
Last reply:
2009-11-02
Jorge Suárez de Lis (ys) said : #1

Intenta seguir los pasos descritos en este post: http://drowninginbugs.blogspot.com/2009/10/caveats-for-audio-in-910.html

Hazlos uno a uno, para ver si puedes identificar el paso que resolvió tu problema. Si tienes problemas siguiéndolos o necesitas una traducción, avisa.

FaPrO (fabro-pro) said : #2

Me pasaba lo mismo, lo solucioné parcialmente "jugando" con la instalación de ALSA, con los drivers para mi targeta de sonido integrada (ALC888, nForce MP61).

salida de aplay -l
**** Lista de PLAYBACK Dispositivos Hardware ****
tarjeta 0: NVidia [HDA NVidia], dispositivo 0: ALC888 Analog [ALC888 Analog]
  Subdispositivos: 0/1
  Subdispositivo #0: subdevice #0
tarjeta 0: NVidia [HDA NVidia], dispositivo 1: ALC888 Digital [ALC888 Digital]
  Subdispositivos: 1/1
  Subdispositivo #0: subdevice #0

salida de cat /proc/asound/cards
 0 [NVidia ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xdfef8000 irq 21

ahora me sucede lo mismo que me sucedió en el paso de ubuntu 8.04 -> 8.10, fue que el sonido "se va" cuando otro programa pide usarlo.
Saludos

eros10509 (sistemascisco) said : #3

FaPrO Gracias por tu respuesta.. me ayudo por lo menos a saber como obtener informacion sobre mi tarjeta de sonido..! Gracias!!

Jorge, que tal saludos.. Emm je.. =S digamos que si necesito ayuda con la traduccion de esos pasos qu me enviaste.. =S bueno en ingles entendi lo que "dice" pero me puedes ayudar a entender un poco mejor "lo que debo hacer" =S quiza en español pueda verlo un poco mejor: mientras le hare la traduccion a alguien que sepa de Ubuntu a ver si me puede explicar de que hablan alli.. Si puedes ayudarme con eso seria perfecto y te estaria muy agradecido.. Gracias de todas formas! :P (y)

hasta pronto y saludos!

Jorge Suárez de Lis (ys) said : #4

Estos pasos están pensados para solucionar problemas de sonido en karmic. Por favor, si estás accediendo a ellos desde una pregunta en Launchpad, dinos qué número solucionó tu problema, o cuéntanos si tu problema persiste. Este documento está basado en http://drowninginbugs.blogspot.com/2009/10/caveats-for-audio-in-910.html

[1] Asegúrate que estás utilizando el kernel de Karmic y no el viejo. Ejecuta "uname -r". Debería decirte 2.6.31-14-generic o uno mayor. Si te sale una versión anterior, es posible que estés utilizando un kernel más viejo. Pregunta por tu caso particular.

[2] Asegúrate que slmodemd no se está ejecutando. Ejecuta "pgrep slmodemd". No debería devolverte nada. Si te devuelve algo, pregunta por tu caso particular.

[3] Instala linux-backports-modules-alsa-karmic-generic.
    sudo apt-get install linux-backports-modules-alsa-karmic-generic
Entonces reinicia, y comprueba si el sonido ya funciona mejor. Si te dice que ese paquete no existe, vete a Sistema » Administración » Orígenes de software. En la pestaña Actualizaciones activa "Actualizaciones no soportadas (karmic-backports)". Pulsa cerrar y cuando te pregunte si quieres recargar la información de paquetes dile que sí. Entonces vuelve a intentar instalarlo.

[4] Añade el PPA del Ubuntu Audio Development Team y actualiza.
    sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
    sudo apt-get update
    sudo apt-get dist-upgrade
Deberían actualizarse los paquetes de alsa y pulseaudio. entonces reinicia y comprueba si se ha solucionado tu problema.

[5] Obtén un log de PulseAudio con estas instrucciones. https://wiki.ubuntu.com/PulseAudio/Log
Pega el log en http://paste.ubuntu.com/ y pasa la dirección a una pregunta o adjunta el log resultante como un archivo.
Si el problema es que al introducir unos auriculares no suenan y sigue sonando el altavoz normal, o un problema similar, sigue estas instrucciones https://wiki.ubuntu.com/ALSA/JackSense
Pega el log resultante también en http://paste.ubuntu.com/ y pasa la dirección a la pregunta o adjunta también el log resultante como un archivo.
FAQ #781: “Solucionar problemas de sonido en Ubuntu 9.10 Karmic Koala”.

Jorge Suárez de Lis (ys) said : #5

He creado un FAQ y me he equivocado al ponerlo. Por eso la respuesta suena tan impersonal :)
Bueno, el FAQ queda aquí https://answers.launchpad.net/ubuntu/+faq/781

eros10509 (sistemascisco) said : #6

Jorge nuevamente saludos!

Segui los pasos uno a uno sin problemas reiniciando cada vez que debia y lamentablemente ninguno de ellos ha resuelto mi problema. :(

Intente grabar un archivo de sonido con el mismo "Grabador de sonido" que trae Ubuntu pero me he fijado que al solo abrirlo ya el sonido no esta.. =S y y al cerrarlo regresa... obviamente asi no lo pude grabar.. (kiza esta info sirva de algo)

por otra parte aca dejo el log que me dices suba en las instrucciones que me pasaste..

Gracias una vez mas por el tiempo puedas dedicar y espero esto pueda ayudar a mejorar estas versiones de Ubuntu..Saludos! :P

log: http://paste.ubuntu.com/306423/

Jorge Suárez de Lis (ys) said : #7

Vale, siento pedirte más cosas, pero sigo sin enterarme de lo que ocurre. El log parece estar bien... ejecuta esto en consola

wget "http://git.alsa-project.org/?p=alsa-driver.git;a=blob_plain;f=utils/alsa-info.sh" -O - | bash

Te escribirá un archivo en /tmp... también lo adjuntas aquí.

Alberto Cruz (lacasadelpirata) said : #8

Yo tengo un problema parecido, un sonido continuo que molesta un monton, pero en vez de cada diez segundos lo tengo en todo momento. Me he dado cuenta de que cuando subo el volumen poco a poco hay un momento en el que el ruido no lo hace para nada. Cuando trato de ejecutar un archivo HD entonces tengo ese sonidito que dice el cada 10 segundos mas o menos y nunca he encontrado la razon, pero ha sido existente tambien en 8.10 y 9.04.

No hice upgrade, sino una instalacion totalmente nueva. Ademas de este sonido super molestoso tambien he notado que mi subwoofer no recibe nada de data y esta configurado como 5.1. Utilizo peliculas que se que tienen data para el subwoofer pero no recibo nada (estoy usando las conexiones analogas por cierto), y en 8.10 y 9.04 funcionaba perfectamente.

Segui estos pasos: https://answers.launchpad.net/ubuntu/+faq/781

-El kernel es el correcto.
-pgrep slmodemd reporto nada.
-Instale lo de los backports y reinicie pero el sonido continua.
-anadi el PPA repository pero me dice "public key not available" por tanto no puedo hacer los otros pasos.
-El ultimo paso no lo he hecho aun pero el problema que se detalla no es el que tengo.

Uso esta computadora para mi sistema de audio/video en casa (home theather pc) y este sonido extrano es super irritante, y molesta tener un subwoofer grande y no poder usarlo :(

Alberto Cruz

Jorge Suárez de Lis (ys) said : #9

Alberto, vuelve a probar el paso 4, puede que los servidores de claves estuvieran algo saturados y que por eso no funcionase correctamente.

Best Xtiancr (xtiancr) said : #10

hola... yo pude solucionar el molesto "trick" de cada 10 segundos...
les dejo el link
http://www.kubuntu-es.org/foro/200910/problemas-sonido-kubuntu-910-beta

es de esta forma
sudo gedit /etc/modprobe.d/alsa-base.conf

buscar la linea que dice
options snd-hda-intel power_save=10

y la comentas,
#options snd-hda-intel power_save=10

y reinicias...

LISTO..

Gracias por la ayuda!

Desafortunadamente tengo el problema aun. Hice el paso 4 y como me indicastes, Jorge, esta vez el public key lo encontro, cuando termino el dist-upgrade reinicie el sistema pero el problema continua. Tambien con el tick cada 10 segundos mas o menos, permanece, pero siendo que este ocurria aun en 8.10 y 9.04 no me preocupa tanto, aunque molesta.

Sin embargo, el chirrido ese.. es mas continuo. Por momentos suena mejor si cambio de 5.1 a 5.0 pero una vez ajusto el volumen, el chirrido continua. Ademas de esto, que el subwoofer no reciba nada de data tambien me preocupa. Es una pena, me gusta mucho como se siente esta nueva version pero el sonido es extremadamente importante en este sistema :(

Alguna otra idea que pueda tratar antes de regresar a 8.10?

Alberto

eros10509 (sistemascisco) said : #12

Xtiancr Gracias por tu respuesta! mi proxima pregunta era: Que hace esa linea? pero en el link que me pasaste esta bien especifico, aunque bueno, las instrucciones que me pasaste me quedaron mejor por el kernel que uso o bueno no se jeje pero me solucionaron el problema perfectamente esos 2 pasos... Gracias una vez mas!

Por cierto, para los que tambien han tenido este problema y dudan sobre estos pasos por alguna diferencia, en el documento que hay que modificar no me aparecen esa linea exactamente igual, me aparece de la siguiente manera:

# Power down HDA controllers after 10 idle seconds
options snd-hda-intel power_save=10 power_save_controller=N

no se que valores tomara "N" pero imagino que eso deshabilita los controladores de eses dispositivo HDA, en todo caso como dice el comentario sobre esa linea; es todo una misma cosa! xD y realmente no le veo sentido a deshabilitar la tarjeta de sonido cada 10 segundos si esta inactiva -,- y mucho menos a que se active ahi mismo!!! -,- eso que suena debe ser un condensador o algo asi y como he trabajado con algo de electronica la idea de estos dispositivos no es precisamente apagarlos y encenderlos asi de rapido y menos cada 10 segundos =S

Jorge, Alberto, Gracias de verdad por su ayuda y su tiempo..!!!
Saludos!! :)

eros10509 (sistemascisco) said : #13

Thanks Xtiancr, that solved my question.

Jorge Suárez de Lis (ys) said : #14

Alberto, abre otra pregunta para tu caso por favor.

aberth gable (gomezlaguna) said : #15

Jorge, gracias,
mis problemas de sonido despues de actualizar a 9.10 han desaparecido con el paso (3).
muchas gracias..

FaPrO (fabro-pro) said : #16

he creado una guía en mi blog con dos posibles soluciones...la segunda me arregló el problema
http://www.planetageek.com/2009/11/solucion-problemas-de-sonido-ubuntu-9-10-karmic-koala/
saludos...espero les sirva =)