pase de ubuntu 9.04 a 9.10 y no funciona el sonido

Asked by Jean on 2009-10-30

Hola,

Hace unas horas hice el upgrade de ubuntu 9.04 a 9.10
Por alguna razon no hay mas sonido, a penas instale la nueva version el icono figuraba como "mute", subi el volumen para activarlo pero no escucho nada. Tambien no puedo jugar a un juego (Urban Terror) ya que el mouse se vuelve loco cuando lo abro (vuelve instantaneamente al rincon izquierdo inferior de la pantalla).
Si alguien me puede ayudar se lo agradezco mucho.

Question information

Language:
Spanish Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-11-01
Last reply:
2012-02-19
DanielFCaicedoT (dfcaicedo) said : #1

mira vuelve a instalar el alsa desde la pagina

sudo apt-get remove alsa-base
sudo apt-get install build-essentials
wget ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.21.tar.bz2
tar jxvf alsa-driver1.0.21.tar.bz2
cd alsa...
./configure
make
sudo make install
sudo reboot

Jean (worship007) said : #2

Hola!
hasta el wget ftp.... estuvo todo bien, bajo el driver
cuando pongo el siguiente codigo "tar jxvf..." la terminal me dice "no such file or directory"
hice algo mal?

DanielFCaicedoT (dfcaicedo) said : #3

eso para por que no encontro el archivo usa tabulador para completar, es que puse puntos suspensivos para no escribir todo

Jean (worship007) said : #4

Perdon pero solo tengo ubuntu hace unos meses y no estoy muy familiarizado con todo esto.

con el "tar jxvf alsa-driver1.0.21.tar.bz2" dice "tar: cannot open; no such file or directory.
                                                                          tar: error is not recoverable: exiting now
                                                                          tar: child returned status 2
                                                                          tar: exiting with failure status due previous errors"
si uso el tab me figura "display all 2500 posibilities"
resumen, hasta bajar el driver bien, despues ya no

DanielFCaicedoT (dfcaicedo) said : #5

Probablemente el driver no descargo bien, espera y te pongo otra ruta
wget http://alsa.cybermirror.org/driver/alsa-driver-1.0.21.tar.bz2

Jean (worship007) said : #6

instalo el driver desde la nueva ruta, pongo "tar jxvf alsa-driver1.0.21.tar.bz2" y figura el mismo error que antes...
no se si volver a ubuntu 9.04...no tenia problemas como ahora...
no se cual puede ser el problema...

Jorge Suárez de Lis (ys) said : #7

Yo te aconsejo que vuelvas a instalar karmic-base y que hagas caso de lo que dice en este post: http://drowninginbugs.blogspot.com/2009/10/caveats-for-audio-in-910.html

Jorge Suárez de Lis (ys) said : #8

Perdona, quería decir alsa-base...

DanielFCaicedoT (dfcaicedo) said : #9

Entra a la pagina de alsa y descarga el paquete del alsa-driver, y la descomprimes desde nautilus, el alsa-base del karmic es la version .20, es mejor la .21

Jean (worship007) said : #10

gracias por responderme!
encontre http://packages.debian.org/source/sid/alsa-driver
pero no se cual bajar...
que es nautilus?

DanielFCaicedoT (dfcaicedo) said : #11

El alsa lo encuentras en esta pagina
http://alsa.cybermirror.org/driver/

y el nautilus es el explorador

Jean (worship007) said : #12

baje el driver (alsa-driver-1.0.21)
ahora que hago?
perdon por mi incultura informatica...no se usar nautilus

DanielFCaicedoT (dfcaicedo) said : #13

Listo, entras a lugares y le das en carpeta personal,

luego buscas en donde el firefox descargo el paquete, por lo general lo deja en el escritorio por lo que puedes entrar a /home/usuario/{desktop o escritorio}
cuando veas el paquete click derecho y descomprimir

luego en consola vas a la carpeta donde se descomprimio

puede queda
cd /home/usuario/desktop/alsa...
y sigues los pasos que puse en el primer post despues del tar

Jean (worship007) said : #14

no se ir a la carpeta donde se descomprimio usando la terminal xq no se usar la terminal

DanielFCaicedoT (dfcaicedo) said : #15

Vas a Accesorios/terminal

digitas el cd del post anterior

cd /home/susuario/Desktop/alsa(aca oprime el tab, para que le auto complete)
y sigues con los pasos del primer post

Jean (worship007) said : #16

bueno segui todos los pasos, instale todo lo necesario pero desgraciadamente sigo sin escuchar nada....
hay alguna posibilidad de milagro?

DanielFCaicedoT (dfcaicedo) said : #17

Entra en la consola accesorios / terminal y digita lspci y publicas el resultado para saber que hardware tienes

Jean (worship007) said : #18

jean@Teahupoo:~$ lspci
00:00.0 Host bridge: nVidia Corporation MCP73 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation nForce 630i memory controller (rev a2)
00:01.0 RAM memory: nVidia Corporation nForce 630i memory controller (rev a1)
00:01.1 RAM memory: nVidia Corporation nForce 630i memory controller (rev a1)
00:01.2 RAM memory: nVidia Corporation nForce 630i memory controller (rev a1)
00:01.3 RAM memory: nVidia Corporation nForce 630i memory controller (rev a1)
00:01.4 RAM memory: nVidia Corporation nForce 630i memory controller (rev a1)
00:01.5 RAM memory: nVidia Corporation nForce 630i memory controller (rev a1)
00:01.6 RAM memory: nVidia Corporation nForce 630i memory controller (rev a1)
00:02.0 RAM memory: nVidia Corporation nForce 630i memory controller (rev a1)
00:03.0 ISA bridge: nVidia Corporation MCP73 LPC Bridge (rev a2)
00:03.1 SMBus: nVidia Corporation MCP73 SMBus (rev a1)
00:03.2 RAM memory: nVidia Corporation MCP73 Memory Controller (rev a1)
00:03.4 RAM memory: nVidia Corporation MCP73 Memory Controller (rev a1)
00:04.0 USB Controller: nVidia Corporation GeForce 7100/nForce 630i USB (rev a1)
00:04.1 USB Controller: nVidia Corporation MCP73 [nForce 630i] USB 2.0 Controller (EHCI) (rev a1)
00:08.0 IDE interface: nVidia Corporation MCP73 IDE (rev a1)
00:09.0 Audio device: nVidia Corporation MCP73 High Definition Audio (rev a1)
00:0a.0 PCI bridge: nVidia Corporation MCP73 PCI Express bridge (rev a1)
00:0b.0 PCI bridge: nVidia Corporation MCP73 PCI Express bridge (rev a1)
00:0c.0 PCI bridge: nVidia Corporation MCP73 PCI Express bridge (rev a1)
00:0d.0 PCI bridge: nVidia Corporation MCP73 PCI Express bridge (rev a1)
00:0e.0 IDE interface: nVidia Corporation MCP73 IDE (rev a2)
00:0f.0 Ethernet controller: nVidia Corporation MCP73 Ethernet (rev a2)
00:10.0 VGA compatible controller: nVidia Corporation C73 [GeForce 7100 / nForce 630i] (rev a2)

Jorge Suárez de Lis (ys) said : #19

Jorge Suárez de Lis suggests this article as an answer to your question:
FAQ #781: “Solucionar problemas de sonido en Ubuntu 9.10 Karmic Koala”.

Jean (worship007) said : #20

el sonido sigue sin funcionar : S

Jorge Suárez de Lis (ys) said : #21

¿Has seguido las indicaciones del FAQ?

Jean (worship007) said : #22

todas, y no tengo sonido...ya no se q hacer

Jorge Suárez de Lis (ys) said : #23

Si te lo has leído, ¿por qué no haces caso del punto 5?

Jean (worship007) said : #24

no entiendo muy bien lo q me piden hacer

Jean (worship007) said : #25

un amigo me dijo q vaya a "System-Preferences-Sound" y q de ahi cambie unas cosas...pero voy y me aparece una ventana q me dice "waiting for sound system to respond"...y queda todo ahi...no puede ser muy buena señal...
tal vez da algun indicio de cual puede ser el problema no?

leviatan89 (leviatan-89) said : #26

Tienes una placa base Asus? Me ha pasado en dos ordenadores. Solo hace falta instalar el paquete "gnome-alsamixer" desde synaptic, aplicaciones-sonido-Mezclador ALSA de Gnome y subir el volumen del Master F, creo que era. No lo pongas a tope! Que si no distorisona ;), con dejarlo a poca distancia del tope sobra!

Jean (worship007) said : #27

ya lo tenia instalado, lo reinstale pero todo sigue igual
gracias de todas formas por el post : )

merlin (maguilar) said : #28

Funciona!!

Despues de hacer lo que nuestro amigo DanielFCaicedoT sugiere segui al pie de la letra el FAQ #781: “Solucionar problemas de sonido en Ubuntu 9.10 Karmic Koala”.
y listo!!
Funciona perfecto

Suerte a todos!!

francesc (gralle) said : #29

Hola,

A mi me pasa lo mismo. Al actualizar el ubunto de 9.04 a 9.10 la tarjeta de sonido, SB XFi, dejó de sonar. He probado las soluciones propuestas de actualizaciones por el terminal y nada de nada. Esta mañana, tocando preferencias de sonido, las he dejado en salida analógico mono output y analógico estéreo input y al rato se ha puesto a funcionar el sonido sin que hiciera nada. Después de escuchar música un buen rato, ha dejado de funcionar a media canción y así sigo ¿¿¿???

francesc (gralle) said : #30

Pués sí, siguiendo las indicaciones del FAQ #781 y dejando las preferéncias de sonido como Analógico estéreo duplex ya funciona.

Grácias

Hay veces que sin saber que es lo que hacemos exactamente, nos cargamos el audio del sistema, no se que narices pasa, pero por mas instalaciones y reinstalaciones que se hagan no hay forma de que nuestro UBUNTU nos vuelba a hablar.

Pues bien, he aquí la solución. Lo que hacemos es reinstalar los drivers dejandolos tal y como estavan cuando se instalo el sistema operativo.

    sudo aptitude install module-assistant build-essential

    sudo module-assistant prepare,update

    sudo module-assistant build,install alsa

    sudo depmod

Ya solo nos queda reiniciar y voila, sonido perfectamente instalado.

Can you help with this problem?

Provide an answer of your own, or ask Jean for more information if necessary.

To post a message you must log in.