how to get permission to install a file

Asked by Chuck

I am trying to install yamipod on t23 and ubuntu and I B A newbie. I will paste the Yamipod instructions:
Installation is really simple:

    * make sure you've used iTunes at least once (under Windows or Mac OS X)
    * have at least one song on iPod
    * copy the libfmodex audio library to /usr/lib (root priviledges needed). You'll find this file in the package you've downloaded
    * mount your iPod somewhere inside /mnt or /media with read/write access
    * make sure you have the df command installed, which is usually part of any standard

I have extracted libfmodex and the yamipod. I guess the yamipod goes on the ipod. I tried to copy the libfmodex but get a message that says I don't have permission. Agravating. Can you tell me how to install, especially if I need to "sudo"

How do I do the "mount your iPod somewhere inside the media folder??? with read/write access.

If I need a password other than what I boot up with I'm sol.

Thank you for your help. I remain really impressed, but am not at all knowlegable about most of what I try to do.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Duncan Lithgow (duncan-lithgow) said :

To copy libfmodex to /usr/lib you need to give the move command (mv) as the root user, or sudo user. Since it's probably you who installed Ubuntu on your machine you will be a sudo user. This means it should work if libmodex is on the desktop and you open a terminal and type:

$ sudo mv Desktop/libmodex /usr/lib/libmodex

It will ask for your password, which is the same as you use to login.

Your iPod should be automatically mounted when you plug it in. You can check if it is by opening the /media folder (go all the way to the top of the folder tree, and then down into /media.

HTH Duncan

Revision history for this message
Best Chuck (chux-industryinet) said :

Thanx, I think I solved the problem with your help. The ipod mounts and the large file of songs loads but yamipod is not playing. If ya have any ideas I'll welcome any help. I have another question but with your previous help I may be able to solve it. Problem solved, thanx again.