Install of 9.10 RC hangs after boot menu selection

Asked by Chris Phillips on 2009-10-25

I am attempting to install the 9.10 release candidate from CD -- when I boot from the CD, I select a language, and then either the live boot or install options, I just get stuck at a black screen with a blinking white cursor at the top. From this point, I can't do anything except press the power button to shutdown and reboot.

I've tried the various noacpi, acpi=off, removing the "quiet" and "splash" flags, using the "safe" display mode, but I can never get anything after that initial menu.

I'm using the iso from the http://releases.ubuntu.com/releases/9.10/ubuntu-9.10-rc-desktop-amd64.iso.torrent download. I've checked that the ISO and disk have the correct MD5 hash.

I have a Dell XPS with:
 * Intel Core 2 Quad (Q9450) - 2.66Ghz
 * 4 Gb RAM

I've installed Ubuntu to several other machines in the past, but I've never just not been able to get the installer to load properly. I'm not quite sure what else to try... even just to get more info. Any ideas?

Question information

Language:
English Edit question
Status:
Needs information
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-10-31
Last reply:
2010-02-25

Try some boot optipns under the F6 menu to disabl;e stuff like ACPI and APIC. You may also want to enter BIOS to disable fancy hardware like sound cards, network devces and USB (unless your keyboard / mouse is USB) just make the system as basic as you can. This will help the installer

Chris Phillips (chphilli) said : #2

Like I mentioned in the original question, I've tried the various options under the F6 menu.

As for disabling sound cards, network devices, and USB, really? The computer is relatively modern, but not so esoteric as all that.

Yes weird hardware can cause issues. USB is fairly good at screwing IRQs up for such a basic system (the installer isn't incredibly smart) so this can help. Obviously if your input devices are USB then these will need to be left enabled. but disabling hardware can help.

Chris Phillips (chphilli) said : #4

Sorry it took me a few days to get back to this.

Unfortunately, after I disabled the onboard LAN and sound devices in BIOS (I needed to keep USB for a keyboard), I still haven't had any luck getting a 9.10 installer to run.

Now that 9.10 has been released, I've also tried the amd64 desktop and amd64 alternate distributions.

Any other ideas out there? I'd love to start using 9.10, but I can't get it installed!

Chris Phillips (chphilli) said : #5

Just an update to indicate that this problem still hasn't been resolved, and it seems to be the same as bug# 459198 (linked).

This is really unfortunate, as it seems to be that there are a fair number of machines out there that just can't get 9.10 installed -- that is, users that can't even try to use it, even if they want to!

LittleMouse87 (littlemouse87) said : #6

Any luck with that problem, Chris? I have exactly the same issue, and nothing seems to work to fix it. What's annoying me is that no-one is acknowledging the problem (you'll find the status of the bug you linked to is STILL "new" - i.e. not yet confirmed). I think the problem is that even if someone managed to fix the bug, it wouldn't help, since we need to get as far as the LiveCD environment (i.e. the desktop) to run Synaptic and get the update. Unfortunately, the Ubuntu ISOs are never updated, after the final release, and so we're stuck with the problem until the release of 10.04.

From what I remember of my first attempts back in November, it installed fine the first time, but then it wouldn't boot after the Grub selection menu. Upon attempted reinstallation, I landed myself with this problem. Maybe it was all just a buggy release - all I can hope is that 10.04 will work.

I'm writing this from a perfectly working installation of the 8.04 LTS. It's not got all the latest features, but at least it boots ;-).

By the way, my PC is an HP HDX9440EA laptop. It's 64 bit, the drive is Blueray, processor is Centrino Duo and it has 3GB of RAM. Regarding the hardware that actionparsnip was blaming, I have a fingerprint reader and a infrared remote port. How does your computer compare? Do you have any similar hardware, to help identify the problem?

Let's hope this eventually gets resolved...

Chris Phillips (chphilli) said : #7

Unfortunately, no. I never did get 9.10 to boot on that machine. After spending way too many hours trying to get it to boot at all, I had to give up and go with an OpenSuSE install on that machine. I'm hoping that 10.04 will fix the problem and let me boot Ubuntu on this machine.

As far as comparing to your machine, the only thing I see in common there is that mine is also 64-bit with a somewhat large amount of RAM (4Gb). But Ubuntu is known to work with both of those, so I don't see what the problem there is.

Good luck!

Can you help with this problem?

Provide an answer of your own, or ask Chris Phillips for more information if necessary.

To post a message you must log in.