Propietary commercial compilers both Fortran and C++, Licensed software how to install and run

Asked by Tor's Bear on 2009-10-15

I have several commercial compilers both Fortran and C++. I have tried to execute the Fortran Compiler ver.11.1 by Intel, but I got an error
message telling me that Ubuntu Linux could not verify that I had a non-commercial license for the compiler. The property descriptions of the fortran file, ifort and other files, show that the files are Executable (Application/x-executable), and I have not any defitiom of x-executable. Are there restrictions on using licensed software in Buntu Linux 9.04? Intel has tested this version of Ubuntu Linux.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Thomas Krüger
Solved:
2009-10-15
Last query:
2009-10-15
Last reply:
2009-10-15
Cristi Nistor (cristi-nistor) said : #1

I don't understand well your issue. Do you have problems running the executable files? Have you set the right file permissions for those files?

If the compilers are commercial then you may need a special license file someplace in your ~/.wine/drive_c

Ubuntu has a very professional compiler (g++) which is used by most of the large teams (mozilla, firefox, apache for example) which is freely available to you in the repos.

I am unsure of the licensing issues you may have due to lack of information as well as no knowledge of how either product works. You could try contacting support to see what is required and apply it to your Linux system(s)

Best Thomas Krüger (thkrueger) said : #3

There are no technical restriction in Ubuntu to run proprietary or even unlicensed software.
But many commercial software comes with built-in restrictions like DRM, key files, dongles, registration keys.

Unluckily the Ubuntu community can offer very limited support on licensing issues. You may have to contact the Intel support.

Tor's Bear (tbrun) said : #4

Thank you for your promt response. You answer my question. I have installed the Intel software using my registration key, and the compilers were installed with no problem. The .sh files, installation, uninstallation , varios configuration files can all be executed. The files I have trouble with are executable files with no .xxx like .exe. These files are descibed as Executable (Application/x-executable), and I have not yet found a definition of x-executable. Tor' Bear