how to disable system beep on Karmic 9.10

Asked by Uri Shabtay on 2009-10-15

due to the changed within the sound properties scheme, i would really like to know how to disable the annoying system beep sound..

thanks in advance..

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
wojox
Solved:
2009-10-19
Last query:
2009-10-19
Last reply:
2009-10-19
Thomas Kr├╝ger (thkrueger) said : #1

I did not test this, but "rmmod -v pcspkr" should help.
To prevent the module from being loaded on start-up add it to /etc/modprobe.d/blacklist.conf.

Cristi Nistor (cristi-nistor) said : #2

In System --> Preferences -->Sound you have the option, on Sounds tab, to enable or disable Alerts and Sounds Effects.

Good luck.

wojox (wojox) said : #3

Open the terminal:

gksudo gedit /etc/modprobe.d/blacklist.conf

Add to the bottom:

blacklist pcspkr

Reboot

jj (ubuntu-podewall) said : #4

I have the same problem, and both solutions don't work...

rmmod -v pcspkr
ERROR: Module pcspkr does not exist in /proc/modules

There is also a part in the blacklist.conf to disable pcspkr:

# ugly and loud noise, getting on everyone's nerves; this should be done by a
# nice pulseaudio bing (Ubuntu: #77010)
blacklist pcspkr

To disable or change the volume of alerts in preferences -> sound cause no changes

Uri Shabtay (uri.shabtay) said : #5

tried all the answers -- none helped. same issues as @jj.

Cristi Nistor (cristi-nistor) said : #6

When exactly you hear the beep? Before or after the OS is loaded?

Uri Shabtay (uri.shabtay) said : #7

the beep is heard when pressing backspace in the beginning of the line in the terminal (any sort of illegal action.. that also "causes" Compiz's 'wobbly windows' to shiver (if enabled).

the beep is also heard in empathy, when, for example, i press any key in the menu of my friends that has no action.
and lastly, you can't miss it when restarting/shutting down, etc. :)

Cristi Nistor (cristi-nistor) said : #8

In System --> Preferences -->Sound have you unchecked the "Play alert sounds" box?

In a terminal please type:

sudo gconf-editor

and look for /apps/metacity/general/audible_bell and remove the check.

For gnome terminal you go to gnome-terminal -->Edit -->CurrentProfile -->General --> and uncheck "Terminal bell".

I think the beeps for shutdown and start up should remain.

Uri Shabtay (uri.shabtay) said : #9

The terminal bell cancellation also cancelled the 'shiver' effect for compiz..
The gconf editing didn't help.

As I said -- I'm using Karmic Beta's new sound scheme:

4 images showing the Sound Preferences menu:

http://img96.imageshack.us/img96/540/screenshoty.png

(image shack decided on dying for a while.. :) )

http://i34.tinypic.com/4fuzuq.png
http://i35.tinypic.com/2d0nyph.png
http://i37.tinypic.com/nxmc0h.png
http://i36.tinypic.com/2lazevd.png

with all due respect -- for the END user (such as myself) this is wrong.
Either the system bell be disabled by default, or may the dev. add the option in the new scheme..

Cristi Nistor (cristi-nistor) said : #10

And what is happening if you mute the Alert volume? Or play with the volume control?

Uri Shabtay (uri.shabtay) said : #11

muting or entirely lowering the volume doesn't help -- a system beep is, undoubtedly, a system beep

jj (ubuntu-podewall) said : #12

Yes it's all the same for me... I don't have the problem while startup or shutdown, but I have big problems using the earphones, because of getting sick of the beep. Evolution causes the systembeep, also Pidgin or other software. After changing something I'm using the tool beep at the terminal to check for effect... but whatever i tried, it makes a very loudly tone which isn't influenced by any volume control or if i mute something... the beep is still playing... now I'm scared about getting a tinnitus... it's very dangerous!!!

jj (ubuntu-podewall) said : #13

Ok, I found a solution... start alsamixer at the terminal... if the cardtype is Pulseaudio start it with alsamixer -c 0...

now I have Card: HDA Intel and Chip: Sigmatel STA9228

Go to PC Beep and mute it with Key "m" ... changing the volume takes no effect

...but I think, that it should be possible to use a normal gui way to do this...

jj (ubuntu-podewall) said : #14

It's stupid, that I have to change it after each reboot... ideas? Ok, it's easier to do it in my case with this line:
amixer -c 0 set "PC Beep" mute

But I'm thinking, this is a bug, so somebody should find a normal solution!

Best wojox (wojox) said : #15

Step 1

Open up a Terminal and type:

sudo alsamixer

Now using your left/right arrow keys navigate over to PC Beep and press M on your keyboard, you'll see MM appear under the volume bar, this basically means it's been muted now press Esc to exit.

Step 2

Now run the command:

sudo alsactl store

This will basically save the changes you made.

Uri Shabtay (uri.shabtay) said : #16

Thanks wojox, that solved my question.

Uri Shabtay (uri.shabtay) said : #17

bug reported:
https://bugs.launchpad.net/ubuntu/+bug/455692

thanks alot everyone