Display Resolution Problem

Asked by Dr Denise M Noha

Please i have been having problems loading unbuntu to my laptop. the ubuntu version is 6.06. The screen tends to split into three and i do noticde three mouse indicators.The laptop is Dell Latitude C800.
Can anyone help please.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Dr Denise M Noha
Last query:
Last reply:

This question was reopened

Revision history for this message
Lars Friedrichs (l-friedrichs) said :

Hi there,

you may set (in a non graphical way...) the standard screen resolution directly in X's config file. Do the following in a terminal window:
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
sudo gedit /etc/X11/xorg.conf

Move on to a section called "Screen"
You will see an option like this
 DefaultDepth 24
so 24-bit is where we will do our changes. Look for a subsection like this in the Screen section:
 SubSection "Display"
  Depth 24
  Modes "1024x768" "800x600" "640x480"

All it takes (should take I must say) is adding the desired resolution as the first in the Modes line. Use the same syntax as the other resolutions have.
Save the file and restart X. You can do that by logging out and pressing Ctrl-Alt-Backspace when the login screen is presented.
X should now use your resolution as the standard.
If your X does not start at all, reboot once, look if it starts now. If it still does not start we can go back to the old settings by Pressing Ctrl-Alt-F1 to switch to the first text console and logging in. Then type this command

sudo cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf

which will restore out backup we made in the beginning. Afterwards reboot by pressing Ctrl-Alt-Del or type sudo reboot .

Hope this helps,

Revision history for this message
Dr Denise M Noha (denise-noha) said :

Hi Lars

Thanks for your help but it does just not display properly with 1440 by 900. The window is too big for the screen - I haev to set it to 1280 X 1024 to look right - even though this is not the best resolution for m screen.

Revision history for this message
Lars Friedrichs (l-friedrichs) said :

Hi again,

maybe you could keep an eye on this bug:

which seems at least related to your problem.


Revision history for this message
Lars Friedrichs (l-friedrichs) said :

Another one:
this page http://rowi.standardleitweg.de/categories/19-Ubuntu (yes, it is german) quotes how to give the xserver hints on giving the right settings for 1440x900 resolution. There is a so called modline which comes from the old days (x-configuration was hell then) and gives exact timing information for the timing chips of the graphics card.
Try to add the same lines into the corresponding section:

Section "Monitor"
VertRefresh 60
modeline "1440x900" 106.5 1440 1520 1672 1904 900 903 909 934 +hsync +vsync

This COULD work, but maybe it's not suitable for your monitor so do the "create a backup"-trick first :-)


Revision history for this message
Sitsofe Wheeler (sitsofe) said :

Denise M Noha:
For nvidia-settings to be able to make permanent changes that last across X restarts it needs to be launched as root (e.g. from a terminal
sudo nvidia-settings

Revision history for this message
Dr Denise M Noha (denise-noha) said :

Hello Lars and Sitsofe,

Sitsofe - Thanks for your help. I was running nvidia-settings from a terminal - but it would still not save my settings.

Lars - Thanks for your help. I'll look into bug 93156 soon - it looks promising.


Revision history for this message
Sitsofe Wheeler (sitsofe) said :

Denise M Noha:
Were you running it using sudo?

Revision history for this message
Dr Denise M Noha (denise-noha) said :


Revision history for this message
Dr Denise M Noha (denise-noha) said :

Ok so I have been messing with this resolution problem again:

1. If I use sudo dpkg-reconfigure xserver-xorg as in problem 93156 I can configure my resolution to be 1440 x 900 and the driver to be 'nv'. Remove nvidia binary driver completely. The screen resolution looks great all works fine.
2. However, I want to run a dual monitor and thus I need to have the nvidia driver installed. Installing the Nvidia driver messes up my display. The resolution stays set at 1440 x 900 but the Ubuntu window is not visible at the bottom. It seems to load a display size that is just too big.

I have spent ages trying to resolve this. Have you guys any idea how to set up dual monitor without instralling the nvidia driver - that does not work properly? Or any other ideas?

Revision history for this message
Dennis Dirdjaja (dcd-ditsch) said :

Did you have a look on the Xinerama HowTo: https://help.ubuntu.com/community/XineramaHowTo and https://help.ubuntu.com/community/NvidiaMultiMonitors
Maybe this will be helpful for you.

Revision history for this message
Dr Denise M Noha (denise-noha) said :

Dear Dennis

Thanks for the links. The problem is that I all the advice here includes installing Nvidia binary driver to enable twin view. It is the nvidia binary driver that is messing up my resolution - I am sure of this.

Revision history for this message
Best Dr Denise M Noha (denise-noha) said :

All, here is the solution:

1. Remove nvidia binary driver if already installed.
2. Run in terminal 'sudo dpkg-reconfigure xserver-xorg' choose autodetect where possible, choose nv driver, choose defaults except for screen resolution - set to 1440x900
3. Reboot ctrl-alt-backspace.
4. Install nvidia binary driver - DO NOT REBOOT YET! Nvidia settings will not run properly at this stage.
5. Go into superuser mode by typing sudo-s in terminal. Enter password.
6. In terminal type gksudo edit and open /etc/x11/xorg.conf.
7. Make one change - In Section "Device" change "nv" to "nvidia". Save file.
8. Reboot ctrl-alt-backspace.
9. In terminal type "sudo nvidia-settings"
10. Set up dual monitor
11. Reboot ctrl-alt-backspace.
12. Bug #58232 will now prevent terminal running. Open Konsole and type "sudo nvidia-xconfig --add-argb-glx-visuals".
13. Reboot - terminal will now work correctly and resolution is correct.

This is the the correction reported in bug #93156 but in more detail.