Cannot install php5 nor phpmyadmin

Asked by Sue on 2009-10-13

I was able to install apache2 and mysql without problem, but when it came to php5 and phpmyadmin, the install just hangs:

sue@Suebuntu:~$ sudo apt-get install phpmyadmin
[sudo] password for sue:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libclucene0ldbl libphonon4
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  apache2-mpm-prefork dbconfig-common libapache2-mod-php5 libdbd-mysql-perl libdbi-perl libgd2-xpm libmcrypt4 libnet-daemon-perl libplrpc-perl libt1-5
  mysql-client mysql-client-5.0 php5-common php5-gd php5-mcrypt php5-mysql
Suggested packages:
  php-pear dbishell libgd-tools libmcrypt-dev mcrypt mysql-doc-5.0 mysql-server
The following packages will be REMOVED
  apache2-mpm-worker libgd2-noxpm
The following NEW packages will be installed
  apache2-mpm-prefork dbconfig-common libapache2-mod-php5 libdbd-mysql-perl libdbi-perl libgd2-xpm libmcrypt4 libnet-daemon-perl libplrpc-perl libt1-5
  mysql-client mysql-client-5.0 php5-common php5-gd php5-mcrypt php5-mysql phpmyadmin
0 upgraded, 17 newly installed, 2 to remove and 0 not upgraded.
Need to get 372kB/17.3MB of archives.
After this operation, 46.9MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
0% [Waiting for headers]
Err http://gb.archive.ubuntu.com jaunty-updates/main php5-common 5.2.6.dfsg.1-3ubuntu4.2
  Connection failed

The install waits at the "Waiting for headers" point for 20 minutes or so then fails. I checked the file it was trying to access and it appears to exist OK.

All of the repositories in my repository list are ticked except the backports one, and the /etc/apt/sources.list confirms this - all sources are uncommented except backports.

I have tried this install over many days and at different times of the day. It does not appear to be a problem with my internet connection as I am working continually online without a problem. Can anyone help? Thanks Sue

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Cristi Nistor
Solved:
2009-10-13
Last query:
2009-10-13
Last reply:
2009-10-13
Cristi Nistor (cristi-nistor) said : #1

You can choose another server by going to System --> Administration --> Software Sources and on Ubuntu Software tab in Download from: Server for (your country) chose another server. Maybe it will fix your problem.

Another way to install phpmyadmin is from System --> Administration --> Synaptic Package Manager and look for phpmyadmin package.

Good luck.

Sue (sue-daws) said : #2

Thank you for your prompt reply Cristi. I tried another server in UK but it did not contain the packages I required. So I reverted to the main UK server and tried using Synaptic instead. I found and selected the packages I wanted, and it downloaded some files, but then I got the message:
W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/pool/main/p/php5/php5-common_5.2.6.dfsg.1-3ubuntu4.2_amd64.deb
  Connection failed
Since this is presumably the common library, I can't get any further.

Sue (sue-daws) said : #3

I tried again using the Oxford University Mirror site as source and this appeared to be working as it fetched more packages, but again I received the error:
W: Failed to fetch http://mirror.ox.ac.uk/sites/archive.ubuntu.com/ubuntu/pool/main/p/php5/php5-common_5.2.6.dfsg.1-3ubuntu4.2_amd64.deb
  Connection failed

Same file fails from more than one site - I am wondering if I already have the file downloaded from one of my failed attempts and this is preventing further attempts to download/install - is this feasible?

Cristi Nistor (cristi-nistor) said : #4

Sue, are you behind a proxy server? In Synaptic Package Manager: Settings --> Preferences --> Network - Checked "direct connection to the internet" or set up your proxy settings. I was able to use the links above to download the package (in a web browser).

Sue (sue-daws) said : #5

Cristi, No I am direct to internet as you suggested. I also tried to download them in a web browser and failed on the same file. Curioser and curioser.

Cristi Nistor (cristi-nistor) said : #6

Yes, the configuration is set to connect directly to internet, but you are sure you are not behind a proxy?

Sue (sue-daws) said : #7

Cristi, absolutely sure. I have been using Ubuntu for a couple of months and have installed lots of packages using Synaptic - although I am still very much a beginner! This is the first package I have had any sort of trouble with. I am trying again to download it from the browser and although it found the package name OK it has been saying "starting" for the last 15 minutes and not actually doing anything. Looking at the directory on the server I note that the particular package I am trying to download, http://mirror.ox.ac.uk/sites/archive.ubuntu.com/ubuntu/pool/main/p/php5/php5-common_5.2.6.dfsg.1-3ubuntu4.2_amd64.deb, has a date of 24 Aug 2009 just over 6 weeks ago. I wondered if anyone else has had a problem with this particular package, could it be damaged in some way?

Best Cristi Nistor (cristi-nistor) said : #8

http://lostresort.biz/downloads/php5-common_5.2.6.dfsg.1-3ubuntu4.2_amd64.tar

this another link that has nothing to do with Ubuntu repositories. It is an archive of the deb file. Please try to download, unpack and install it.

you may need to run:

sudo apt-get update

first to refresh the config of apt for the server.

Sue (sue-daws) said : #10

Thanks Cristi Nistor, that solved my question.