Terminal not loading

Asked by Dr Denise M Noha on 2007-06-21

My terminal has stopped loading after setting up dual monitors. The Gnome-terminal loader from the applications menu just starts the program. The task bar says it is starting the program, but after about 30 seconds, nothing happens and the taskbar message just disappears. I used Xterm to report the output:

The program 'gnome-terminal' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 105 error_code 2 request_code 78 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function

Please help me fix it - I don't know how to use --sync.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Markus Thielmann
Solved:
2007-06-22
Last query:
2007-06-22
Last reply:
2007-06-21
Best Markus Thielmann (thielmann) said : #1

Thanks for your question.

You hit Bug #58232.

In short: It's a bug in the nvidia driver, so there's no fix available (since the driver is closed source). To enable a workaround, you might want to add

Option "AddARGBGLXVisuals" "True"

to section "Screen" in /etc/X11/xorg.conf.

You may instead also want to run the following command in terminal (Applications->Accessories)

1) sudo nvidia-xconfig --add-argb-glx-visuals

which will do all necessary changes to xorg.conf for you.

Markus Thielmann (thielmann) said : #2

Sorry, quite dumb to describe where to find the terminal when you in fact had a problem with the terminal. It's just that I'm so used to describe it :-)

Dr Denise M Noha (denise-noha) said : #3

Thanks Markus Thielmann, that solved my question.

Dr Denise M Noha (denise-noha) said : #4

Need to reboot after following instructions and now terminal is back up and running thank you.