Modifier keys across input devices ignored for first (modified) keystroke

Asked by deadguy on 2009-10-04

A number of people have seen this problem on the forums: http://ubuntuforums.org/showthread.php?t=1231551

We have USB foot pedals for modifier keys (ctl, alt, shift, etc). After the modifier is held down, it is ignored for the first keystroke of what should be the modified input. For example, holding down shift and pressing the "a" key repeatedly yields "aAAAAA" instead of "AAAAAA".

There is an xev dump on the forum that shows that the modifier event is seen before the first modified keypress.

I've done a number of tests:
1) The error is seen regardless of window manager /desktop environment (tried gnome, xmonad, and none -- just an xterm)
2) The error is NOT seen in a virtual terminal (ctl-alt-f1). Leads me to believe it is a bug in X
3) The error is NOT seen at all in hardy. I also have a jaunty install with X pinned to hardy's version, and the error is not seen there either.
4) The error is seen with any two keyboards. I tested on a karmic laptop between the laptop keyboard and a usb keyboard.

This leads me to believe it is a regression somewhere in X.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-10-04
Last reply:
markus haider (markus.haider) said : #1

I experience exactly the same problem

deadguy (deadguysfrom) said : #2

markus: the xorg-xi2 ppa solved the problem for me. you'll need to make sure it has the video driver for you card before you install.

https://launchpad.net/~thjaeger/+archive/xorg-xi2

markus haider (markus.haider) said : #3

@deadguy: Installing xorg-xi2 ppa also solved the problem for me.

I ran into problems with the video driver (nvidia card), but could fix it by installing the driver from the command line. Perhaps we should mark the question as solved now?

Can you help with this problem?

Provide an answer of your own, or ask deadguy for more information if necessary.

To post a message you must log in.