Ubuntu 9.04. NIC Recognized, Cannot Connect (WIRED)

Asked by Greg W on 2009-09-30

Hello Everyone,

I'm a noob Ubuntu 9.04 user. I've been struggling to get my network up for several days. I've got a Dell Dimension 8200. Install worked fine, except for the NIC. I have a Windows machine on the network and it connects fine (which is how I'm posting this).

Steps I've taken.
1) Messed with old NIC, (it was installed and recognized, but unable to connect). Gave up after several hours, bought new NIC (generic Encore ENGLA-1320 with a Realtek chipset). It appeared to be recognized correctly, but just to be safe, I wiped the disk and re-installed Ubuntu again -- seems to be right:
>>lspci | grep Ether
>>02.0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)

>> lsmod (*highlights)
   r8169 40836 0
   mii 13312 r8169

>> sudo ethtool eth0* (*highlights only)
   advertised link modes, 10, 100, 1000
   auto-negotiate: yes
   speed: 100
   duplex: full
   port: MII
   PHYAD: 0
   Transceiver: internal
   Auto-negotiate: on
   Supports wkae-on: pumbg
   Wake-on: g
   Current message level: (51)
   Link detected: yes

I can also provide a lshw output, but it takes a long time to type from pictures on a camera. ;)

2) Reset LinkSys router to factory settings (DHCP server) (Cannot ping 192.168.1.1, "Host Unreachable")
>>sudo dhclient (*highlights)
    listening (and sending) on LPF/pan0/da:cc:b6:f3:e8:ac
    listening (and sending) on LPF/eth0/00:08:54:a8:49:4d
    sending on socket/fallback
    (it then attempts to handshake a DHCP server on pan0 and eth0 to: 255.255.255.255 port 67 (various intervals))
>> No DHCPOFFERS received.
>> No working leases in persistent database - sleeping.

ok, so:
>> ifconfig -a
(summary)
eth0 UP BROADCAST RUNNING MULTICAST MTU:1500
eth0:avahi UP BROADCAST RUNNING MULTICAST MTU:1500
lo UP LOOPBACK RUNNING MTU:16436
pan0 UP BROADCAST RUNNING MULTICAST MTU:1500
pan0:avahi UP BROADCAST RUNNING MULTICAST MTU:1500

3) Switched to static IP assignment: (Still, cannot ping 192.168.1.1, "Host Unreachable")
4) Moved NIC to another open PCI slot (no change)
5) Took cat5 cable and plugged to different computer to verify it was a good cable (confirmed works)

At this point though, I am lost. Does anyone have any ideas?

To summarize: the system finds the NIC, seems to be using the correct module, but the NIC cannot even ping the router. I'd be happy just to get it on my network -- ecstatic to get on thE "internets." lawl lawl

Thanks very much for your help -- please let me know what else I can provide to troubleshoot...

Greg

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-10-01
Last reply:
2009-10-02
Cristi Nistor (cristi-nistor) said : #1

Please edit and paste the output of /etc/network/interfaces configuration file.

Greg W (greg-opaedo) said : #2

Hi Cristy. Thank you! Here is the output from /etc/network/interfaces
>>
auto lo
iface lo inet loopback

------Original Message------
From: Cristi Nistor
Sender: <email address hidden>
To: Greg Williams
ReplyTo: <email address hidden>
Subject: Re: [Question #84288]: Ubuntu 9.04. NIC Recognized,Cannot Connect (WIRED)
Sent: Sep 30, 2009 3:31 AM

Your question #84288 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/84288

    Status: Open => Answered

Cristi Nistor proposed the following answer:
Please edit and paste the output of /etc/network/interfaces
configuration file.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+question/84288/+confirm?answer_id=0

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+question/84288

You received this question notification because you are a direct
subscriber of the question.

Greg W (greg-opaedo) said : #3

Cristi -- sorry!
------Original Message------
From: Cristi Nistor
Sender: <email address hidden>
To: Greg Williams
ReplyTo: <email address hidden>
Subject: Re: [Question #84288]: Ubuntu 9.04. NIC Recognized,Cannot Connect (WIRED)
Sent: Sep 30, 2009 3:31 AM

Your question #84288 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/84288

    Status: Open => Answered

Cristi Nistor proposed the following answer:
Please edit and paste the output of /etc/network/interfaces
configuration file.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+question/84288/+confirm?answer_id=0

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+question/84288

You received this question notification because you are a direct
subscriber of the question.

Cristi Nistor (cristi-nistor) said : #4

Using ifconfig command will show you the interfaces (eth0 etc)
if you want to give static IP to your Ethernet card you should add the following lines to your /etc/network/interfaces file:

auto eth0 #assuming that this is your network card
iface eth0 inet static

address 10.1.1.2 # your machine IP
netmask 255.255.255.0
network 10.1.1.0/24
broadcast 10.1.1.255 #optional
gateway 10.1.1.1 #the address of your router or the address given by your ISP.

fF the address is assigned by the DHCP pool (by router or DHCP server) you should write:

auto eth0 #assuming that this is your network card
iface eth0 inet dhcp

after this restart network:

/etc/init.d/networking restart

Good luck.

Greg W (greg-opaedo) said : #5

Ok, I'm finally home to work on this again. I added the eth0 references with dhcp option to my interfaces file. Unfortunately, after doing this I still had no networking, and the eth0 interface was no longer listed in my top right Network status area (in gui)...

So, still no network. :(

------Original Message------
From: Cristi Nistor
Sender: <email address hidden>
To: Greg Williams
ReplyTo: <email address hidden>
Subject: Re: [Question #84288]: Ubuntu 9.04. NIC Recognized,Cannot Connect (WIRED)
Sent: Sep 30, 2009 9:16 AM

Your question #84288 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/84288

    Status: Open => Answered

Cristi Nistor proposed the following answer:
Using ifconfig command will show you the interfaces (eth0 etc)
if you want to give static IP to your Ethernet card you should add the following lines to your /etc/network/interfaces file:

auto eth0 #assuming that this is your network card
iface eth0 inet static

address 10.1.1.2 # your machine IP
netmask 255.255.255.0
network 10.1.1.0/24
broadcast 10.1.1.255 #optional
gateway 10.1.1.1 #the address of your router or the address given by your ISP.

fF the address is assigned by the DHCP pool (by router or DHCP server)
you should write:

auto eth0 #assuming that this is your network card
iface eth0 inet dhcp

after this restart network:

/etc/init.d/networking restart

Good luck.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+question/84288/+confirm?answer_id=3

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+question/84288

You received this question notification because you are a direct
subscriber of the question.

Greg W (greg-opaedo) said : #6

Doing some more looking into the logs, I see what appears to be 2 interfaces
using IRQ19 -- one of which is the nic. Is it possible to have an IRQ
conflict in Ubuntu?

I'm reading mixed reviews that LinkSys WRT54G might have issue handshaking
with the linux DHCP client. The Router is up-to-date with latest firmware.
Is there some way to get more detail when the handshake is happening? (How
can I tell if this is the issue?)
 Anyone have any ideas? This is giving me a headache. 10 hours banging my
head against the wall is not fun. :(

On Wed, Sep 30, 2009 at 8:49 PM, Greg W <email address hidden> wrote:

> Ok, I'm finally home to work on this again. I added the eth0 references
> with dhcp option to my interfaces file. Unfortunately, after doing this I
> still had no networking, and the eth0 interface was no longer listed in my
> top right Network status area (in gui)...
>
> So, still no network. :(
>
> ------Original Message------
> From: Cristi Nistor
> Sender: <email address hidden>
> To: Greg Williams
> ReplyTo: <email address hidden>
> Subject: Re: [Question #84288]: Ubuntu 9.04. NIC Recognized,Cannot Connect
> (WIRED)
> Sent: Sep 30, 2009 9:16 AM
>
> Your question #84288 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/84288
>
> Status: Open => Answered
>
> Cristi Nistor proposed the following answer:
> Using ifconfig command will show you the interfaces (eth0 etc)
> if you want to give static IP to your Ethernet card you should add the
> following lines to your /etc/network/interfaces file:
>
> auto eth0 #assuming that this is your network card
> iface eth0 inet static
>
> address 10.1.1.2 # your machine IP
> netmask 255.255.255.0
> network 10.1.1.0/24
> broadcast 10.1.1.255 #optional
> gateway 10.1.1.1 #the address of your router or the address given by your
> ISP.
>
> fF the address is assigned by the DHCP pool (by router or DHCP server)
> you should write:
>
> auto eth0 #assuming that this is your network card
> iface eth0 inet dhcp
>
> after this restart network:
>
> /etc/init.d/networking restart
>
>
> Good luck.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/84288/+confirm?answer_id=3
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/84288
>
> You received this question notification because you are a direct
> subscriber of the question.
>
>

Cristi Nistor (cristi-nistor) said : #7

Greg,

What are the logs show? (command dmesg | grep eth0)
Also the command lshw -C network will give some information about your NIC. What is the output of ifup eth0 command?

You can acquire an IP from DHCP pool using dhclient eth0 command on a terminal.

It seems that the NIC is not managed by Network Manager if is not listed on System --> Preferences --> Network Connections.

http://ubuntuforums.org/showthread.php?t=1028541 shows to enable it.

As a last resort you my switch to wicd (http://sourceforge.net/projects/wicd/files/ version 1.5.9 save .deb package and install it on Ubuntu) after you remove the NM.

Greg W (greg-opaedo) said : #8

Hi Cristi -- we must be in very different timezones. :)

If you do a ls -l in your /etc/network folder, what permissions are listed for "interfaces" file?

------Original Message------
From: Cristi Nistor
Sender: <email address hidden>
To: Greg Williams
ReplyTo: <email address hidden>
Subject: Re: [Question #84288]: Ubuntu 9.04. NIC Recognized,Cannot Connect (WIRED)
Sent: Oct 1, 2009 2:28 AM

Your question #84288 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/84288

    Status: Open => Answered

Cristi Nistor proposed the following answer:
Greg,

What are the logs show? (command dmesg | grep eth0)
Also the command lshw -C network will give some information about your NIC. What is the output of ifup eth0 command?

You can acquire an IP from DHCP pool using dhclient eth0 command on a
terminal.

It seems that the NIC is not managed by Network Manager if is not listed
on System --> Preferences --> Network Connections.

http://ubuntuforums.org/showthread.php?t=1028541 shows to enable it.

As a last resort you my switch to wicd
(http://sourceforge.net/projects/wicd/files/ version 1.5.9 save .deb
package and install it on Ubuntu) after you remove the NM.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+question/84288/+confirm?answer_id=6

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+question/84288

You received this question notification because you are a direct
subscriber of the question.

Greg W (greg-opaedo) said : #9

Also, "dhclient" and "networking restart" both report that the DHCP server did not respond to broadcast request and so the client goes to sleep.

I'll output log and hardware config when I can find a jump drive...
------Original Message------
From: Cristi Nistor
Sender: <email address hidden>
To: Greg Williams
ReplyTo: <email address hidden>
Subject: Re: [Question #84288]: Ubuntu 9.04. NIC Recognized,Cannot Connect (WIRED)
Sent: Oct 1, 2009 2:28 AM

Your question #84288 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/84288

    Status: Open => Answered

Cristi Nistor proposed the following answer:
Greg,

What are the logs show? (command dmesg | grep eth0)
Also the command lshw -C network will give some information about your NIC. What is the output of ifup eth0 command?

You can acquire an IP from DHCP pool using dhclient eth0 command on a
terminal.

It seems that the NIC is not managed by Network Manager if is not listed
on System --> Preferences --> Network Connections.

http://ubuntuforums.org/showthread.php?t=1028541 shows to enable it.

As a last resort you my switch to wicd
(http://sourceforge.net/projects/wicd/files/ version 1.5.9 save .deb
package and install it on Ubuntu) after you remove the NM.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+question/84288/+confirm?answer_id=6

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+question/84288

You received this question notification because you are a direct
subscriber of the question.

Greg W (greg-opaedo) said : #10

Hey Cristi -- what if this is actually the wrong mod (r8169) (going by memory there, might have messed up the numbers). How would I override the mod assignment so I can experiment with different ones? I don't want to give up yet. Ubuntu looks cool.

And no offense, but where is everyone else? Our community is only 2minds strong!! lol!!
------Original Message------
From: Cristi Nistor
Sender: <email address hidden>
To: Greg Williams
ReplyTo: <email address hidden>
Subject: Re: [Question #84288]: Ubuntu 9.04. NIC Recognized,Cannot Connect (WIRED)
Sent: Oct 1, 2009 2:28 AM

Your question #84288 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/84288

    Status: Open => Answered

Cristi Nistor proposed the following answer:
Greg,

What are the logs show? (command dmesg | grep eth0)
Also the command lshw -C network will give some information about your NIC. What is the output of ifup eth0 command?

You can acquire an IP from DHCP pool using dhclient eth0 command on a
terminal.

It seems that the NIC is not managed by Network Manager if is not listed
on System --> Preferences --> Network Connections.

http://ubuntuforums.org/showthread.php?t=1028541 shows to enable it.

As a last resort you my switch to wicd
(http://sourceforge.net/projects/wicd/files/ version 1.5.9 save .deb
package and install it on Ubuntu) after you remove the NM.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+question/84288/+confirm?answer_id=6

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+question/84288

You received this question notification because you are a direct
subscriber of the question.

Cristi Nistor (cristi-nistor) said : #11

Hello Greg. It seems that we are in different time zones :). Right now is 8 AM in mu location.

Anyway.

You don;t have to alter the permissions given to the /etc/network files. On my laptop the interfaces file has - rw- r-- r-- 1 root root permissions and user/group affiliation. You can save the modifications made to this file only if you are root.

So, if you are able, paste here the output of the logs. It should be something there ;)

Can you help with this problem?

Provide an answer of your own, or ask Greg W for more information if necessary.

To post a message you must log in.