Wireless driver installed but not working

Asked by OddLink on 2009-09-27

Hi, I'm a new user of ubuntu (8.04), I need it for my university studies & with the start of the new schoolyear help is urgent!
I have little experience using linux, so bear with me.
I want my wireless to work ofcourse, but I would also want to know what I'm doing & learn so I can help someone else if I get the chance!

Some history of things done:
I wanted to use WG111v2 usb stick to connect to my WEP secured home network.
After installing ubuntu 8.04, I noticed their were no drivers present for my WG111v2.
On xp I would have inserted the disk, installed the drivers, configuration software => ready.
The problem I had was the cd could not be autoran (because it was not linux supported)
So I searched the net and found their was a way to use windows xp drivers using
NDISWRAPPER, I also installed the GUI NDISGTK.
I picked up the .inf, .sys,.cat driver files located C/program files/Netgear/drivers/...
& put them on a usb stick. (I ended up only using the .inf file)
And installed it with NDISGTK (same thing as using "ndiswrapper -i netwg111.inf" command I assume)
If I now check SYSTEM|ADMINITRATION|WINDOWS WIRELESS DRIVERS
It shows me the driver installed & hardware present.
same thing using "ndiswrapper -l" in the terminal:
net111v2 : driver installed
device (0846:6A00) present (alternate driver: rtl8187)

this looks ok so far to me.

The problem is that the blue light on the stick should be flashing after the driver is succesfully installed which did not happen!
same thing using the "modprobe ndiswrapper" command no blue light (no idea what this modprobe is?)

I also did uninstall network-manager & installed wicd.
But wicd shows no wireless networks.
also if if I access SYSTEM|ADMINITRATION|WINDOWS WIRELESS DRIVER again and press the configure network button I get the error message:
Could not find a network configuration tool. (I guess this is because I uninstalled network manager;)

So that quite sums it up, if you want more information please ask.

some additional informational outputs I don't get but hopefully you do get...

command ifconfig:
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:278 errors:0 dropped:0 overruns:0 frame:0
TX packets:278 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:17792 (17.7 KB) TX bytes:17792 (17.7 KB)
command iwconfig:
lo no wireless extensions.
eth0 no wireless extensions.
pan0 no wireless extensions.
wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s Tx-Power:20 dBm Sensitivity=0/3
RTS thr:off Fragment thr:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

This last output confuses me because the wlan0 seems to be my home wireless network (right bit rate ect), shouldn't this show up in wicd?

To end my informational post, I will give you some network details found in xp's netgear software:

SSID: cpwbs15431EDE9
channel 13 (no idea what this is)
WEP 128 bit secured
access point (no idea what this means but I thought it might be relavant because of the "Access Point: Not-Associated" in de iwconfig output)

Thanks for reading through my question, I hope you can help me out!

Thanks in advance,

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-09-28
Last reply:
2009-09-28
Delan Azabani (azabani) said : #1

Have you tried removing the Windows wireless driver and the ndiswrapper software, then using the standard ath5k/madwifi drivers to run your hardware? By the way, you shouldn't be using WEP 40/128bit encryption, you should be at least using WPA or WPA2 because it has been shown that WEP can be cracked in under five minutes using freely available software from the Internet.

OddLink (wombad2) said : #2

first thanks for your reply,
also thank you for your advice concerning the security of my wireless network.
I will take it in serious consideration,

I never tried madwifi drivers, but this source makes me believe this would not really work:
http://ubuntuforums.org/archive/index.php/t-329384.html

I reread my above post and I find this rule strange:
device (0846:6A00) present (alternate driver: rtl8187)

rtl8187 is this the right driver or some native driver trying to interfere with ndiswrapper?
http://www.ubuntuforums.org/showthread.php?t=329299&highlight=WG111v2
in above thread they blacklist this driver,
should I try doing te same?

thanks already

Duane Hinnen (duanedesign) said : #3

the native rtl8187 driver should work.
I did find a bug report on that driver. Have you tried the rtl8187 with Wicd?
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/225851
https://bugs.launchpad.net/ubuntu/+bug/231662
I have read that in Ubuntu it will work without the light coming on.

Since you have already installed the windows driver and ndiswrapper I would first start by trying to blacklist the native driver.

sudo gedit /etc/modprobe.d/blacklist.conf

add these and save

#wg111v2 conflicting drivers
blacklist islsm_pci
blacklist islsm
blacklist islsm_usb
blacklist prism2_usb
blacklist rtl8187
blacklist r8187b
blacklist r8187

also you can unload the module with

sudo rmmod rtl8187

restart the wireless network

ifconfig wlan0 down
ifconfig wlan0 up

If that does not work I would give the native driver another go. You will have to remove the changes you made to /etc/modprobe.d/blacklist.conf. Also you will have to remove ndiswrapper and 'modprobe rtl8187' to reload that module. Also updating to a newer kernel might help.
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.30.5/

OddLink (wombad2) said : #4

first thanks alot for the 'ready to try' well advised/explained answer.

As adviced I tried the blacklist approach first:

opened the terminal:
sudo gedit /etc/modprobe.d/blacklist.conf
and an empty file opened.
I pasted:
#wg111v2 conflicting drivers
blacklist islsm_pci
blacklist islsm
blacklist islsm_usb
blacklist prism2_usb
blacklist rtl8187
blacklist r8187b
blacklist r8187
and saved & closed

following errormessages showed up in terminal:
** (gedit:5688): WARNING **: Could not write gedit state file:
Failed to create file '/root/.gnome2/gedit-2.M7VU0U': No such file or directory

I/O error : No such file or directory
I/O error : No such file or directory

the command ndiswrapper -l still gives aternate driver rtl8187
a bit dissapointed I tried to unload the module:
sudo rmmod rtl8187
answered by an error: ERROR: Module rtl8187 does not exist in /proc/modules
well seriously troubled I tried to restart my wireless network
ifconfig wlan0 down
ifconfig wlan0 up
both again answered with an errormessage: SIOCSIFFLAGS: Permission denied

Hope you can help me out here,
thanks already

peter b (b1pete) said : #5

OddLink,

if ndiswrapper -l still shows the hwre and driver present then pls do the following

- first, uninstall wicd via synaptic
- also via synaptic do a search for ndis and check if both ndiswrapper packages show as installed
- thirdly, the network-manager and network-manager-gnome must be installed - pls check it also via synaptic

if all above satisfied pls go to system-->admin-->network and highlight the wireless icon then select edit and in the new window opened and on the three tabs shown below pls enter

- for essid

cpwbs15431EDE9

- then for wep pls select 128 strength and enter the key that presumably you've got
- then make sure that dhcp is selected

close window and you'll see sa bullet running; let it finish running; hopefully you'll end up with an active conn'n.

sure you can do in a terminal

sudo iwlist wlan0 scan

or

sudo iwconfig

tell us how things go; we'll try to help you.

OddLink (wombad2) said : #6

I would like to try to uninstall wicd & reinstall networkmanager.
(both utils & common (ndiswrapper) show installed)

uninstalling wicd is just uninstall package wicd i guess

but I completely removed the network-manager package so it isn't in my list to reinstall!
The network-manager-gnome is still in the list.

Where to get the network-manager package, or how to get it back in the list?

thanks already!

peter b (b1pete) said : #7

yes, just remove/uninstall wicd first. - use completely remove option. then in a terminal pls do

sudo apt-get update
sudo apt-get install network-manager network-manager-gnome

keep us posted.

Can you help with this problem?

Provide an answer of your own, or ask OddLink for more information if necessary.

To post a message you must log in.