How do you configure Real Tek WLAN 8191 (b/g/n PCI Mini) to work with Ubuntu 9.04

Asked by 11gWorld on 2009-09-26

I have a Thinkpad T400 that is equipped with a Real Tek Wireless LAN 802.11 b/g/n PCI Mini wireless adapter. It works with Windows, but I am having problems getting it to work with Ubuntu 9.04. Any ideas will be greatly appreciated. Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
11gWorld
Solved:
2009-09-28
Last query:
2009-09-28
Last reply:
2009-09-27

Please try this solution:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/401126/comments/5

It requires using ndiswrapper using the windows 2000 driver for the Realtek WLAN 8191

More details here:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/401126

Hope it helps.

Mark, I downloaded and untarred the tar file and then executed the install. I went into network manager and added all the necessary wifi configuration details. I then restarted my laptop. I don't see wireless option in network manager. What am I missing ? Please forgive my ignorance....I am new to Linux/Unix..... :-)

Mark, I think I know what the problem was. It appears that the solution that you presented does not seem to work for 64-bit Ubuntu 9.04. I implemented your solution on a 32bit Ubuntu 9.04 installation and it worked. Please let me know if you have similar solution for a 64-bit version of Ubuntu. Thank you for the help......:-)

It will not work on the 64-bit version of Ubuntu, because ndiswrapper needs 32-bit Windows XP or Windows 2000 drivers to enable wireless cards to work. These 32-bit wireless drivers are incompatible with 64-bit Ubuntu kernels.

In your case, I would suggest overwriting the 64-bit Ubuntu install with a 32-bit Ubuntu install.

See the remarks here:

http://www.thinkwiki.org/wiki/How_to_install_ndiswrapper_for_the_ThinkPad_11a/b/g/n_Wireless_LAN_Mini_Express_Adapter

" Adding the windows driver

    * Download the Windows driver. Note that this is a 32 bit driver and unless a 64 bit XP driver is released (unlikely) or ndiswrapper adds support for vista drivers (has to happen eventually), this will not work with 64 bit kernels. You will get as far as probing the module, at which point you will get kernel messages like

ndiswrapper version 1.51 loaded (smp=yes, preempt=no)
ndiswrapper (check_nt_hdr:150): kernel is 64-bit, but Windows driver is not 64-bit;bad magic: 010B
ndiswrapper (load_sys_files:216): couldn't prepare driver 'net5416'
ndiswrapper (load_wrap_driver:118): couldn't load driver net5416; check system log for messages from 'loadndisdriver"

Thanks Mark. It works very well in 32-bit Ubuntu. Thanks for your help.