Rhythmbox fails to download podcast

Asked by Justin Dugger on 2009-09-26

For some reason, since the 15th, Rhythmbox fails to download podcasts from "60 second science":
http://rss.sciam.com/sciam/60secsciencepodcast

I've dug out a url from today (sept 25th) and wget downloads the podcast fine. Is there a way to get better debugging info out of rhythmbox?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-09-26
Last reply:
2009-09-27

This question was reopened

wojox (wojox) said : #1

rhythmbox-dbg is in the repos. I tried your link and it worked for me. Have you uninstalled anything recently that would have removed any codecs? You may want to try reinstalling it from the repo's. If you click on rythombox > properties you'll see a list of dependencies.

Justin Dugger (jldugger) said : #2

It's not codecs, that's silly. The download fails, not playback. I'm surprised it worked for you -- it fails on both my 9.04 desktop and 9.10 laptop.

Justin Dugger (jldugger) said : #3

Odd, launchpad claims this is solved?

wojox (wojox) said : #4

Maybe you could Click new add the url again and try.

Matthew Woerly (nattgew) said : #5

I've tried adding it twice, and all of the episodes fail to download. Running "rhythmbox -d" gave me this:

(19:07:02) [0xf96040] [rb_podcast_manager_next_file] rb-podcast-manager.c:653: looking for something to download
(19:07:02) [0xf96040] [rb_podcast_manager_next_file] rb-podcast-manager.c:679: processing http://www.pheedo.com/e/74e28d20cc2f526d69d84655b2b17be2/podcast.mp3?e_id=E9A8F927-04B7-FC3B-1D5C7AEDA824B572&ref=p_itune
(19:07:03) [0xf96040] [download_file_info_cb] rb-podcast-manager.c:724: got file info results for http://www.pheedo.com/e/74e28d20cc2f526d69d84655b2b17be2/podcast.mp3?e_id=E9A8F927-04B7-FC3B-1D5C7AEDA824B572&ref=p_itune
(19:07:03) [0xf96040] [download_file_info_cb] rb-podcast-manager.c:735: file info query failed: HTTP Client Error: Forbidden

Can you help with this problem?

Provide an answer of your own, or ask Justin Dugger for more information if necessary.

To post a message you must log in.