Problem Regarding Installing Softwares In ubuntu with ./configure,make,make install commands..

Asked by manu on 2009-09-25

Hello friends i am trying to install tar.gz software source code and i m successfull in extracting tar files but when i use ./configure command then i got a error message thet says "No Such Files Or Directory Found" please help me and tell me where ai m wrong..........

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-09-27
Last reply:
2009-09-27
arochester (arochester) said : #1

You do not say what you are trying to install.

Your first choice should always be to install something through the Package Manager. Your last choice should be to compile from a .tar.

Look at "How to install ANYTHING in Ubuntu!" on http://amitech.50webs.com/installing/index.php.html
and "Installing Software in Ubuntu" on http://www.psychocats.net/ubuntu/installingsoftware

Larry Jordan (larryjor) said : #2

     In addition to advice from arochester provided, and more directly responding to your question, are you in the right directory? You don't have any info about yourself in your profile page, so I can't gauge my response based on your experience level. Once you extract the tar file, you have to "cd" to the directory (the './' portion of the 'configure' command tells it to look in the current directory). If you ARE in the right directory, is there a file called 'configure' in the directory (check using the 'ls' command if you don't already know that).

      Last, to reiterate what arochester has pointed out, the safest way to install is through the Package Manager in Ubuntu if the software you are installing is available there.

manu (mandeepjindal7) said : #3

yes i m in directory of extracted software and when i run ./configure i get the error message as i said above..
and please tell me what should i do if there is no any configure file in the directory???

Sam_ (and-sam) said : #4

Quote arochester:
You do not say what you are trying to install.

manu,
in order to help the requested information is essential.
Compiling isn't trivial, hence you should trust the source and know exactly what you're doing.
Usually packages include a README file and a MAKEFILE.

https://help.ubuntu.com/community/CompilingSoftware
https://help.ubuntu.com/community/CheckInstall

Larry Jordan (larryjor) said : #5

     If there is no configure in that directory, the package may not offer one. Normally in a source code package, there are files titled "README" and "INSTALL" (frequently in capital letters). The latter is the one that should have instructions on installing. I have compiled packages that only include a makefile before, in which case you just go to the 'make'.

manu (mandeepjindal7) said : #6

yes there is a INSTALL file there and it suggest that i should use make install command to install that package but when i run this command i get error message that there is no make file exits.....

arochester (arochester) said : #7

If you have Read "How to install ANYTHING in Ubuntu!" you will have seen:
"To proceed you must have the compiler tools installed. They all come with the package build-essential, available in Synaptic. When you're sure you have the compiler tools installed, you fire up the terminal and change directory to the one you've just extracted (if you're not sure how to do that see: Navigating the terminal. "

Have you got "build-essentials" installed?

zvacet (ivicakolic) said : #8

All info you need to compile is in links arochester provided.But make one example.You downloaded something (let name it Package.tar.gz) and with right click>extract here you get folder named Package.You need to be inside of that folder to be able to compile.Now,only difference is where you downloaded your package.If it is in your home directory then type in terminal

cd Package

and you are in desired folder and you can start with compiling.If you downloaded on Desktop then

cd Desktop

and after that

cd Package

Install file will tell you compile procedure.

P.S. Before you start anything be sure that you have build-essential package installed.

sudo apt-get install build-essential

Can you help with this problem?

Provide an answer of your own, or ask manu for more information if necessary.

To post a message you must log in.