Nvidia driver installs and runs OK, fails on reboot

Asked by JohnEverest on 2007-06-17

I installed NVIDIA-Linux-100.14.09 by closing Xwindows then from a new terminal login I killed gdm and installed the Nvidia driver.
All OK! Enter "startx" command. Everything works fine -- until the system is rebooted.
     It boots to a terminal, apparently unable to find the Nvidia driver. The same thing happens if i use the restricted driver manager to install it.
I have checked the driver modules and links without finding the problem. Using the cooking "nv" driver for the time being.
Kind regards

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
JohnEverest
Solved:
2007-06-26
Last query:
2007-06-26
Last reply:
2007-06-21
Fuzzy Logic (djordje) said : #1

Uninstall the driver you downloaded from the NVidia site and type in the terminal: apt-get install nvidia-glx-new. Or use Synaptic to install nvidia-glx-new.

It solved the problem for me ;)

Jason Sandlin (crane) said : #2

Also make sure you have the restricted modules for the kernel you are running. One other thing, if you have and older card you may need to install nvidia-glx-legecy driver.
Check nvidia's site or I believe if you highlight the driver in synaptic it will tell you which ones it's for as well.

JohnEverest (john-everest) said : #3

No joy so far, same thing
Log file primary errors:
 Failed to load ~/libglx.so.
 I checked the file and the path seems OK

 Failed to load module "glx" ( loader failed, 7)
module OK and where it should be

Seems odd that it loads and run OK on install as I originally said, but fails on reboot
The card is 6 months old and ran OK last week with Nvidia drivers on Fedora 7 ( which I scrapped and went back to Ubuntu - too many other problems but not video)

Javier Jardón (jjardon) said : #4
JohnEverest (john-everest) said : #5

Hello Javier Jardon
                               I have done as you suggested and followed the advice on that guide. Still the same problem. I think that installing the latest Nvidia driver directly from a root terminal was a mistake. The simplest, and probable best, action for me now is a clean re-install of Ubuntu.

My thanks to you and all others who have tried to help

Best JohnEverest (john-everest) said : #6

Conclusion

I reinstalled Ubuntu 7.04 and loaded all updates. I tried again to install The latest Nvidia driver , 10.14.11 - same problem. Worked OK from a "startx" but failed on reboot. One difference though, the error was unable to load kernel module.
I downloaded Alberto Milone's ENVY, followed the instructions and the problem is now solved.