apt-get is not existing as command

Asked by Roger

Hello everybody,

So I want to make from my old Packerd Bell EasyNote E5145 a little server whit apache on it. I've installed Ubuntu Server 8.04 LTS cause 9.0x is to heavy for it. But now, when i reboot it said:

"The kernel requires the following features not present on the CPU 0:6
Unable to boot - please use a kernel appropriate for your CPU".

So I searched for some answers to resolve the problem. And I found them here:
https://answers.launchpad.net/ubuntu/+question/23343

But if a come at the shell part it said:

"~ # apt-get install linux-generic
/bin/sh: apt-get: not found"

I don't see what the problem is. I hope someone can help me.

Greets Roger

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
DarkJavi
Solved:
Last query:
Last reply:
Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#1

Reading the https://answers.launchpad.net/ubuntu/+question/23343

"I find that the fix of bug 151942 works here too. You have to boot the server install CD and choose "Rescue a broken system". When you get the prompt, run "apt-get install linux-generic" to install the generic kernel. Reboot and choose the new kernel in GRUB."

Are you booting your pc entirely using the server install CD...?

Thank you

Revision history for this message
Roger (q-administrator-terven-be) said :
#2

Yes, i follow all the steps. Now i must go but over 3-4 hours i will post a photo of it.
It won't take apt-get or aptitude like a found in other topics.

Revision history for this message
Roger (q-administrator-terven-be) said :
#3

So i'm back. I took some photo's here they are, is there something I do wrong, something that is not good installed?

Photo's:

www.terven.be/a.jpg
www.terven.be/b.jpg
www.terven.be/c.jpg
www.terven.be/d.jpg

Revision history for this message
Best DarkJavi (darkjavi) said :
#4

have you tried "chroot /target" before apt-get ??
On c.jpg It tells you that your disk is mounted on /target so if you wanna make changes on your actual instalation you have to switch your root "/" to / target, that is issued by chroot /target

Revision history for this message
Roger (q-administrator-terven-be) said :
#5

Thanks DarkJavi, that solved my question.