File Manager starting on login

Asked by John Rose on 2009-09-17

On login (on Jaunty). file manager starts automatically. Any ideas as to why?
PS I've looked at gconf-editor settings without success.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-09-22
Last reply:
2009-09-22

system>preferences>startup applications
Everything at startup is there. Look for something mentioning "nautilus".

Hope that helps
Shane

John Rose (johnaaronrose) said : #2

Shane,

Sorry, I already tried that: I should have mentioned that I did!

Gabe Gorelick (gabegorelick) said : #3

The list of startup applications you mention is a list of applications that are not critical to gnome, and therefore do not need to launch at startup. But things like Nautilus and X, for example, are such integral parts of gnome that they have to start at startup to give you the graphical interface that you know and love. Nautilus is so integrated with gnome, that disabling it will cause a lot of undesirable behavior. This thread should give you more info: http://ubuntuforums.org/archive/index.php/t-105517.html

John Rose (johnaaronrose) said : #4

Gabe,

I don't want to disable Nautilus. The window (normally activated by the menu item Home Places) displays on login. I want to stop this display happening.

Gabe Gorelick (gabegorelick) said : #5

Sorry about that, I think I understand you now. This seems to be caused by a bug in Nautilus (as documented in this Debian bug report http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=532799). There is already a fix upstream filed in June which should be already included in the Karmic version. If it isn't, then you may want to file a bug report to make sure someone takes a look at it again.

John Rose (johnaaronrose) said : #6

I've looked at the Debian bug report. It appears to say that (from messages #30, #35, #40 & #45) that it will only be rectified by removing the "5,RestartCommand=nautilus" line from .gnome2/session. However, I have no .gnome2/session file. Please clarify.

Gabe Gorelick (gabegorelick) said : #7

If that doesn't fix it for you, then you may want to open a new bug report.

Can you help with this problem?

Provide an answer of your own, or ask John Rose for more information if necessary.

To post a message you must log in.