Lost connection when loading update 22.04

Asked by Eebie

Lost connection during loading packages for upgrade from 20.04 to 22.04.
The same error messages occurred during several attempts yesterday and today during several attemps
All went well during the upgrade process until the 3th or 4th step: downloading the new packages until package 376 of about 1219.
I got the following error:

Ign http://mirror.unix-solutions.be/ubuntu jammy/universe amd64 localepurge all 0.7.3.10
Err http://mirror.unix-solutions.be/ubuntu jammy/main amd64 lockfile-progs amd64 0.1.19build1
  Unable to connect to mirror.unix-solutions.be:http:

Err http://mirror.unix-solutions.be/ubuntu jammy-updates/main amd64 libruby3.0 amd64 3.0.2-7ubuntu2.7
  Could not connect to mirror.unix-solutions.be:80 (2a04:6480:101::131), connection timed out Could not connect to mirror.unix-solutions.be:80 (185.111.204.131), connection timed out
Unable to connect to mirror.unix-solutions.be:http:

And instead of a succesfull upgrade it ends with:
   Restoring original system state

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
Last query:
Last reply:
Revision history for this message
Best Manfred Hampl (m-hampl) said :
#1

You could try changing the repository server to a different one in your vicinity, see https://launchpad.net/ubuntu/+archivemirrors for a list of potential mirrors.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#2

Repo is up. Can you ping the hostname and get an IP back ?

Revision history for this message
Eebie (ebe-050) said :
#3

I changed to another one of the 3 Belgian repository servers .
The initial problem was with http://mirror.unix-solutions.be/ubuntu (185.111.204.131). It stopped during downloading packages to upgrade to 22.04.
First I changed to https://mirrors-ubuntu.behostings.com/ubuntu/ and there the download stopped even after less packages.
Changing to http://ftp.belnet.be/ubuntu/ enabled a successful upgrade to 22.04.

Thanks for the helpful advice.

Revision history for this message
Bert Van de Poel (bhack) said :
#4

I work at Unix-Solutions so we had a look at your issue just now. We don't really see anything going wrong on our side. Do you maybe have upgrader/installer logs so we can see why exactly the downloads stopped? The fact you had this happen on 2 different mirrors makes it seem like an ISP issue on your end, but we'd still like to investigate if more details are available.

Revision history for this message
Eebie (ebe-050) said :
#5

I have no logs saved. Meanwhile the upgrade from http://ftp.belnet.be/ubuntu/ was done without problems.