SATAII disk is defined as IDE channel 3-slave and my IDE disk is not to be found.

Asked by Gunnar Tryggvason on 2009-08-30

I installed Ubuntu on a Gigabyte motherboard m68sm-s2l. It has an IDE connector which to I connected DVD-player and an old Hard disk. It also has a 4xSATAII connectors where I connected SATAII hard disk. I haven't installed RAID driver.
UBUNTU don't find my old IDE disk and the BIOS settings are following:

IDE channel 0 Master DVD-drive
                     0 Slave
                    2 master
                    2 slave
                    3 master
                    3 slave My SATAII disk.

Can anyone help on this one?
Tanks GT.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2009-08-31
Last query:
2009-08-31
Last reply:
2009-08-31

Al drives ae IDE. The IDE is the little piece of PCB on the drive. Old drives did not have this and relied solely on the controller for intelligence. New drives (Since late 80s) have an IDE to give cache as well as perform SMART capabilities. SCSI has IDE, SATA has IDE. When people say IDE they really mean PATA or parrallel ATA, new technologies ave arived and iven the invention of SATA or serial ATA.

If you check the jumpers on the PATA drives, make sure one is a master and one is a slave. Their is no universal advice for this as it varys from device to device. The PATA controller can handle 2 devices but if they are set to the same identifier (both slave or both master) they will conflict and not get detected. If they are on seperate controllers then this is not an issue and either device can be a master or slave (ALthough some BIOS' prefer them to both be Masters)

Can you also provide the output of:

sudo fdisk -l

Thanks

maria@maria-borg:~$ sudo fdisk -l
[sudo] password for maria:

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x156d156d

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 60073 482536341 83 Linux
/dev/sda2 60074 60801 5847660 5 Extended
/dev/sda5 60074 60801 5847628+ 82 Linux swap / Solaris
maria@maria-borg:~$

I have to get help to open my daughters pc as I just came home from the Hospital after braking my other leg rather badly. I was running Windows-xp and connected the dvd and the old hard-disk to the "IDE" connector and the new SATAII disk to one of 4 connectors for SATAII disks. I don't remember how I fixed the jumpers, but both disks are probably set as SLAVES. If I change one of the disks this will fix the problem? As I will spend next weeks mostly in horizontal possition I need recomandations for a good book and/or internet path, two lern the UNIX(Linux) command set.

Thank you very much.

Regards GT

Its not really an ubuntu issue. Its maing sure you use correct jumper settings ont he drives so that they are both detected in the BIOS. Once they are visible there the OS will take the control and do what it needs to do.

THe is no real advised book/site just websearch around and see what you can find

Peace

Thanks actionparsnip, that solved my question.