sudo: /etc/sudoers is mode 0470, should be 0440

Asked by charan

This is my first time using linux ubuntu 7.04 by wubi install and not sure what i did about chmod command
So when i use sudo command ...
this is reply from ubuntu..
sudo: /etc/sudoers is mode 0470, should be 0440
So when i want to do something as root i use su and typing root password to do job
but can't use some program like change users and group and etc..
Help me please !!

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Dennis Dirdjaja
Last query:
Last reply:
Revision history for this message
Best Dennis Dirdjaja (dcd-ditsch) said :

Hello charan,

you have to adjust the rights for that file with the chmod command. Switch to the root account with su and then execute »chmod 0440 /etc/sudoers«. That command sets the rights for that config file correctly.

Hope this helps,

Revision history for this message
charan (charan-rspg) said :

Thanks Dennis Dirdjaja, that solved my question.