Desktop moves simply by click and drag!

Asked by Da CalebMan

Binary package hint: gnome

By accident/human error, I accidentally clicked and dragged the desktop into 'my videos' folder!
No matter what I do I cannot drag it back. Upon reboot, any deletable files on the desktop screen are permanently deleted. (Please Help!)

Clicking and redragging it to Home/User does not work. Moving the file by Sudo/Sudo Nautilus doesn't work either,
What do I do!


Ubuntu 9.04 , Gnome 2.26.2, HP D330 DT Bussiness Desktop.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:

This question was originally filed as bug #409170.

This question was reopened

Revision history for this message
Chris Coulson (chrisccoulson) said :

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at if you are uncertain if they are bugs. For help on reporting bugs, see .

Revision history for this message
actionparsnip (andrew-woodhead666) said :

do NOT run nautilus with sudo. Use gksudo as this is used to run GUI apps. sudo is ONLY for command line commands and you will ruin your file ownerships by using sudo with GUI apps. I have a link stored to hightlight exactly what will happen as I had to help some other poor sap who screwed his files this way:

Education over, on with a fix

Ok so you say you dragged your desktop into you music folder. Do you mean that you moved ~/Desktop to ~/Music (or similar)?

Just want to clarify exactly what folders have gone where.


Revision history for this message
Tom (tom6) said :

Hi. Please let us know what went where if you can.

I think you can just open a normal nautilus file-browser, i don't think you need to sudo it - even get it from the "Places" menu. Just open the folder that contains "Desktop". Go up to the "View" menu in nautilus and get it to show a "side pane". At the top of the side-pane is a grey title "Places" with an arrow beside it pointing down. Click on the down arrow and from the drop-down list click on "Tree". Now drag the "Desktop" folder from the folder it's in and drop it the side-pane on "Home Folder".

Remember slow is smooth, so be cool and slow - don't hastily jab at things for doing this.
Good luck and regards from
Tom :)

Revision history for this message
Da CalebMan (caleb-trevatt) said :

Thanks for the reply,

I dragged my Desktop into '/home/*user*/Media/Animation'
(I like to make animations) While I was re-categorizing my files.

I took your advice and stopped using 'Sudo nautilus' I use this very often and it would've been a disaster to mess it all up. I tried 'gksudo' to do reposition it, but Nautilus will NOT let me delete the original file. Mess up my system or not, I should be able to modify my files, but using a special command to do it, I can understand.


Revision history for this message
Da CalebMan (caleb-trevatt) said :


Revision history for this message
Steve (stupendoussteve-deactivatedaccount) said :

This is why a gui is sometimes a bad thing.

Open a terminal and try mv ~/Media/Animation/Desktop ~

Revision history for this message
Da CalebMan (caleb-trevatt) said :

OK new news,

I'm such a klutz! I 'accidentally' renamed the Desktop 'dgtj' don't ask me how.
Now the dekstop is tied to the folder name: Home>*user*>Media>Animation>dgtj.

Well at least this tells us one thing. That whatever you do to the Desktop, happens to a folder, and if you could tie the Desktop, to a different folder and managed to delete all the others, everything could be back to normal. Is there a configuration file that controls this?

Either that or I system restore to 2 days ago. CTRL+ALT+BACKSPACE does not work for me.

Please help!

Revision history for this message
Da CalebMan (caleb-trevatt) said :

!!!!! Sorry, I keep pressing this problem is solved button!!!!!

Revision history for this message
Da CalebMan (caleb-trevatt) said :

I suppose more specifically put,

There is probably a configuration file that controls the link between the Desktop, and the Desktop folder. If I could change where it links to, then the problem would be fixed!

But I don't know; If that is, what it is, and where it is...


Revision history for this message
Da CalebMan (caleb-trevatt) said :

I'm too used to one button.

Revision history for this message
Steve (stupendoussteve-deactivatedaccount) said :

Maybe you could restate the exact problem you are having now... Is
there a ~/Desktop folder? Does it have everything in it that you want
and is the Desktop functional? Is the issue that you can't delete the
(now renamed) duplicate folder in your Animations directory?

Revision history for this message
actionparsnip (andrew-woodhead666) said :

if you run (in terminal)

file ~/Desktop

what is the output?

Revision history for this message
Da CalebMan (caleb-trevatt) said :

I typed the command and got this:
'/home/caleb/Desktop: ERROR: cannot open `/home/caleb/Desktop' (No such file or directory)'

As far as I know, there is a Desktop folder, but the Desktop is no longer synchronizing with it. Instead it's synchronizing with, filename: /home/*user*/Media/Animation/dgtj.

I CAN easily delete 'dgtj' but, the Desktop won't allow me to move or make new files in a non-existent directory. I CAN'T delete the Original Desktop which is sitting in the same directory as 'dgtj.'

I tried what Steve said (5th post from the top) and what happens is, the Desktop folder is copied and placed in Home. It has a folder icon instead of a Desktop icon, and can be cut, copied, pasted, or deleted.

I tried moving the Desktop a lower subfolder, and it makes a copy, but switches to synchronize with it. The Desktop is now synchronizing with: Ya no what, I'll give you my username.


Revision history for this message
komputes (komputes) said :

'/home/caleb/Desktop: ERROR: cannot open `/home/caleb/Desktop' (No such file or directory)'

This is the output you should be getting:
$ file ~/Desktop/
/home/caleb/Desktop/: directory

If your desktop is no longer ~/Desktop, take a look at the following file:

In this file you should have one line saying:

If not, your desktop folder will be disconnected (that is to say ~/Desktop will not be your Desktop)

Revision history for this message
Tom (tom6) said :

Caleb please don't follow this plan yet until other people have commented on it or tweaked it because i haven't a clue if this might work.

Hey everyone, how does this sound for a way of fixing this?

1. Create a new folder in /home/caleb and call it "Desktop"
2. use komputes answer by editing
to include the line
shouldn't that be "$HOME/caleb/Desktop"?

Good luck and regards to all from
Tom :)

Revision history for this message
Da CalebMan (caleb-trevatt) said :

Thanks for the help guys,

I found a temporary solution, but after some time it didn't work:

I dragged the folder 'Desktop' (home/caleb/Media/Animation) to a subfolder in the animation directory (home/caleb/Media/Animation/Animations) now, the Desktop is linked to this new folder in:


But 'Root' doesn't like my change and somehow changed the link back to the original, undeletable, unmoveable, Desktop folder (home/caleb/Media/Animation)

Well at least that's a step forward,

Oh, and Tom, Can I copy and quote your suggestion on 'Linux forums' for comments?

Revision history for this message
Tom (tom6) said :

HI, yes for comments. If it works then feel free to just use the answer anywhere. No need to quote you got the answer from me
Thanks and regards from
Tom :)

Revision history for this message
Tom (tom6) said :

If you edit the "user-dirs.dirs" then you'll need to sudo it because it's a system file. I would do something like this

cd /home/caleb/.config
sudo cp user-dirs.dirs user-dirs.dirs.080809
sudo gedit user-dirs.dirs

Note the "ls" is a lower-case "LS" and shows a LiSt of what's in the folder. the "sudo" command will ask for your normal user password, not your SuperUser/Root one even tho it gives SuperUser privileges to the command that follows. The 2nd sudo command wont ask you for a password because the 1st time gives you a 10minute window for doing moree sudo commands. The "cp" command makes a backup CoPy of the file "user-dirs.dirs" and calls it "user-dirs.dirs.080809", i find it handy to have a date-stamp on backup copies in case i get muddled about which one is which if i actually need the backup ;). Gedit is quite a neat text-editor but we all have different favourite ones; vi, vim, nano, scite and others are good.

Anyway sudoing the gedit command allows you to save the system-file and makes sure the normal user is kept out of being able to edit it at whim ;)

Good luck and regards from
Tom :)

Can you help with this problem?

Provide an answer of your own, or ask Da CalebMan for more information if necessary.

To post a message you must log in.