DVD will not mount with some DVDs inserted

Asked by Ted Baker

I am using version 9.04 which would not at first run any DVD only CDs. I followed your instructions on getting the DVD drive to work and installed VLC Player. I thought everything was fine until I tried to run some workout videos. The system says it cannot find the media to mount. I have tried 4 DVDs that all work fine and the two that will not mount, work fine in my desktop using WINDOWS 7. So where do I go from here?
Ted Baker

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
komputes (komputes) said :

There are many restricted formats that can not be included with the distribution for legal reasons.

The following guide will walk you though getting the Video DVD library:

If you are unable to mount DVDs they may just be hidden in the Places menu, or they may be written on a filesystem which is not supported. Do you get any errors when inserting these DVDs?

Revision history for this message
Larry Jordan (larryjor) said :

     Do you have libdvdcss installed? Which DVD's don't play and which do? Most of the DVD's you buy in the store (movies & so on) are copy-protected and will only play in Linux if you have libdvdcss installed.

Can you help with this problem?

Provide an answer of your own, or ask Ted Baker for more information if necessary.

To post a message you must log in.