no way to determine DNS or change DNS

Asked by parker on 2009-08-03

Using new install Jaunty 9.04 There is no way to determine what DNS servers it is using and no way to change DNS servers.
This was easy in Gutsy using system settings/network settings. No such options in Jaunty!

In Windows just do cmd /ipconfig/all and it's all there! This is definitely a serious bug and needs to be corrected in future releases.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
parker
Solved:
2009-08-07
Last query:
2009-08-07
Last reply:
2009-08-05

This question was originally filed as bug #408468.

Philip Muškovac (yofel) said : #1

This functionality was moved in Network Manager from 'Network settings' to System->Settings->'Network connections'. You can also right click the NetworkManager Icon in your notification area to get the connection details and settings.

parker (paco) said : #2

Right click the sys tray icon or System Settings/Network connections
brings up the same 'Manage Network Connections' dialog box.
It only shows 'Wired' and VPN' 'Wired' cannot be edited and there is no
other information. VPN does not work and I think there has been a bug
report about that. I use KVpnc for my VPN.

Previously in Gutsy the System Settings/Network connections brought up a
dialog box that allowed setting static IP or DHCP, routing info and
setting DNS as I said in my bug report I find no way to do this in
Jaunty. I have edited /etc/resolve.conf to add the open DNS servers and
remove the DNS servers supplied by my Chinese ISP. On reboot the open
DNS servers are still there, but so are the Chinese DNS. I would like to
know which one is actually being used and also be able to turn off DHCP
which is how I handled this problem in Gutsy.

The reason that this is important is that many URL's and Google searches
get routed to Chinese web sites! There are work arounds for this, but I
shouldn't have to do that.

Thanks for any help.

Philip Muskovac wrote:
> This functionality was moved in Network Manager from 'Network settings'
> to System->Settings->'Network connections'. You can also right click the
> NetworkManager Icon in your notification area to get the connection
> details and settings.
>
> ** Changed in: ubuntu
> Status: New => Invalid
>
>

Philip Muškovac (yofel) said : #3

I'll convert this into a question since you still need help and it's not a bug.

parker (paco) said : #5

This did help! It answers the first part of my question as to how to find the DNS I am using. Although it is a bit strange in that it (the GUI) reports back 208.67.219.14 which is an OpenDNS server. That's fine, but my /etc/resolve.conf looks like this:
# Generated by NetworkManager
domain domain_not_set.invalid
search domain_not_set.invalid
nameserver 208.67.222.222
nameserver 208.67.220.220
nameserver 192.168.1.1

The second part of my question is how to change from DHCP to static IP in Jaunty? Again this was simple in Gutsy. When I setup my TTPT VPN I found a recommendation to ditch KNetwork manager and install the Gnome Network manager. When I check Synaptic it appears both are currently installed and if I try to remove either it wants to remove both!
As it stands my Network Manager provides no useful functionality or configuration for my wired connection and the VPN doesn't work at all. I resolved the VPN problem by installing KPvnc so maybe there is another utility out there for managing my wired connection?

I would think that other users are having similar problems with Jaunty's Network manager?

Thanks

Sam_ (and-sam) said : #6

Little search brought up this.

About Jaunty KUbuntu 9.04 with KDE 4.2
recommendation was installing plasma-widget-network-manager and removing network-manager-kde.
#Not tested here.

About network-manager-gnome
http://live.gnome.org/NetworkManager

For Intrepid, Jaunty
https://help.ubuntu.com/community/NetworkManager0.7

##They changed something in Jaunty
VPN and e.g. LAN at the same time needs an option in IPv4 settings, something like use resources only from this network. Otherwise VPN works but e.g. normal LAN not.

http://bugzilla.gnome.org/show_bug.cgi?id=504763

About static IP
CLI
http://www.ubuntugeek.com/ubuntu-networking-configuration-using-command-line.html

https://bugs.launchpad.net/ubuntu/+source/gnome-system-tools/+bug/409475

parker (paco) said : #7

I can't say it solved my problem, but I do appreciate the help. I can accomplish what I want to do by using the command line and editing the files that control networking. I kept network-manager-kde and removed the plasma-widget-network-manager because it was useless.

System settings/ Network Settings in Jaunty lacks the functionality that was there in Gutsy. This is the real problem and why I originally filed this as a bug report. I only hope that the developers might consider restoring this in future releases. Also addressing the VPN issue. After some 'tweaking' I have KVpnc working and am quite satisfied with that.
Thanks again.