no sound anymore in dapper beta

Asked by Philippe Joyez on 2006-04-22

In Dapper beta have no sound on my dell desktop (dimension 9100). This is a live CD, but I had the same problem with a fresh install of the daily 18-4. It used to work in Dapper Flight 6 and Breezy.

I have been checking for all I could (muted output...). I also tried to figure out what was wrong by running an ALSA debug script, but I don't see any obious problem. Here is the out put of the script:

ubuntu@ubuntu:~$ ./aadebug
ALSA Audio Debug v0.1.0 - samedi 22 avril 2006, 06:57:58 (UTC+0000)
http://alsa.opensrc.org/index.php?page=aadebug
http://www.gnu.org/licenses/gpl.txt

Kernel ----------------------------------------------------
Linux ubuntu 2.6.15-20-386 #1 PREEMPT Tue Apr 4 17:48:51 UTC 2006 i686 GNU/Linux

Loaded Modules --------------------------------------------
snd_hda_intel 18964 1
snd_hda_codec 139824 1 snd_hda_intel
snd_pcm_oss 53664 0
snd_mixer_oss 18688 1 snd_pcm_oss
snd_pcm 89736 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_timer 25220 1 snd_pcm
snd 55268 8 snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
snd_page_alloc 10632 2 snd_hda_intel,snd_pcm

Modprobe Conf ---------------------------------------------
Warning: module config file does not exist
This means any kernel modules will not be auto loaded
See your linux distro docs on how to create this file

Proc Asound -----------------------------------------------
Advanced Linux Sound Architecture Driver Version 1.0.10rc3 (Mon Nov 07 13:30:21 2005 UTC).
0 [Intel ]: HDA-Intel - HDA Intel
                     HDA Intel at 0xefffc000 irq 169
 16: [0- 0]: digital audio playback
 24: [0- 0]: digital audio capture
  0: [0- 0]: ctl
 33: : timer
cat: /proc/asound/hwdep: Aucun fichier ou répertoire de ce type
00-00: STAC92xx Analog : STAC92xx Analog : playback 1 : capture 2
cat: /proc/asound/seq/clients: Aucun fichier ou répertoire de ce type

Dev Snd ---------------------------------------------------
controlC0 pcmC0D0c pcmC0D0p timer

CPU -------------------------------------------------------
model name : Intel(R) Pentium(R) 4 CPU 3.00GHz
cpu MHz : 2993.010

RAM -------------------------------------------------------
MemTotal: 1034680 kB
SwapTotal: 4941748 kB

Hardware --------------------------------------------------
0000:00:00.0 Host bridge: Intel Corporation 945G/P Memory Controller Hub

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Philippe Joyez
Solved:
2006-04-23
Last query:
2006-04-23
Last reply:
2006-06-07

OK, I figured out what was wrong, I have sound now. Going to the volume control panel, in the preferences I choose to display all controls (It initially had only "PCM" and "line in as output" ticked). Then I saw that "sourround", "center" and "LFE" were muted. It turned out that unmuting surround gave me sound back!
I guess the main sound channel should be "front" (which was not muted). So it seems there is a little error in configuration for this particular sound chip.

Barleyman (john-eberly) said : #2

Same problem for me when upgrading to Dapper. For me it was the surround that is controlling my volume.