Enabling 4GB of RAM in 64-bit Feisty

Asked by Britlion on 2007-06-09

I have an ASUS P5B Premium motherboard, with 4GB of RAM on board. If I enable the option of "Remap Memory" in the bios, the bios screen shows 4GB of RAM, and ubuntu doesn't work at all. The live CD won't run, and an installed OS won't run either. It either spontaneously reboots somewhere in the boot process, or freezes up with a blank screen.

If I turn this option off, the live CD works, but the BIOS (and the installed operating system) only show 3008Mb of memory.

Is there a way to get Ubuntu to work with the extra memory?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Britlion
Solved:
2007-06-10
Last query:
2007-06-10
Last reply:
2007-06-09
Cesare Tirabassi (norsetto) said : #1

First of all, you must enable the Remap Memory option to make the 4Gb available.
The freeze is most probably a module associated with an AGP or PCI card requiring a Memory Mapped I/O address space.

To identify the module you could:

disable memory remapping
boot
check with an lsmod all loaded modules
blacklist one by one each suspect module and try booting with with Remap Memory enabled.

I would check in particular modules associated with agp and network cards. Perhaps also reducing the agp aperture could help. A good hint may come from /proc/iomem

Quite long and tedious I know, but I don't know any better.

Best Britlion (britlion) said : #2

Unfortunately, being a complete linux newbie, I really don't have the skills to do any of that. I don't even know what most of it mean.

So my solution for now is to drop to 32 bit ubuntu, and leave it turned off.

This system is PCI Express. Does AGP relate to that at all? It also has no PCI cards in the system. It must be a device on the motherboard causing these issues.

I much appreciate your reply though. I was also having a problem with a GeForce 8800 GRS graphics card, which is a known bug in ubuntu. My best hope is that the next version of ubuntu will be more able to cope with my system, I think. That or I will have learned enough about linux to be able to debug this sort of problem!

Fabián Rodríguez (magicfab) said : #3

Fabián Rodríguez suggests this article as an answer to your question:
FAQ #669: “I have 4GB or more of RAM but can't see it in Ubuntu. How can I enable support for all my RAM ?”.