Nvidia driver enabled: Black screen

Asked by Britlion

I'm pretty much an ubuntu neophyte. I found a solution to the "ubuntu doesn't like vista" problem, for example by brute force - physically swapping hard drives in order to dual boot.

So, with a clean ubuntu hard drive in place I install ubuntu. I let it do its updates off the web, I go to the restricted drivers and activate the nvidia driver and...

black screen.


ctrl-alt-f1 doesn't get me a console - it's as though the whole thing just freezes.

The only way I can get linux running is from grub's recovery console.

I reinstalled, did the updates and downloaded the latest driver direct from nvidia's website. Same result.

Is there a fix for this? I don't even know how to get back to the 60Hz flickery screen of death I had without wiping and reinstalling!

Thanks in advance.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Dennis Dirdjaja
Last query:
Last reply:
Revision history for this message
Britlion (britlion) said :

Oh: I ought to list some hardware; can't copy and paste, since I can only access the net from another machine!

It's a dual core intel machine, running feisty 64-bit, and the graphics is an Nvidia 8800GTS.

Revision history for this message
Dennis Dirdjaja (dcd-ditsch) said :

Hello Britlion,

thanks for your question. You can invoke sudo dpkg-reconfigure xserver-xorg from the recovery console to get back reasonable settings. There you can switch back to the free nv driver instead of the restricted nvidia driver. To resolve your problems with the restricted driver, you should give us your /etc/X11/xorg.conf and the error messages in /var/log/Xorg.0.log when activating the restricted driver.

Hope this helps,

Revision history for this message
Britlion (britlion) said :

Thankyou, Dennis. That got me graphics back at least.

I should swap some monitors around, so the 60Hz problem doesn't give me eyestrain ;)

Now I know how to get it back, I'll re-enable the restricted driver and get some data that might help.

Revision history for this message
Britlion (britlion) said :

Actually, I had to do dpkg-reconfigure -phigh xserver-xorg which seems to guess most answers correctly. I couldn't work out half the answers to the questions it showed me without phigh.

Anyway, here's the conf and log files. This time I got the driver direct from nvidia's website, but it seems to work the same way (ie not at all).

The error in the log file seems to be:

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0): that the NVIDIA device files have been created properly.
(EE) NVIDIA(0): Please consult the NVIDIA README for details.
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "ramdac"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

On screen it complained about some kind of kernel mis match. Is this binary driver (and I'm learning why people hate them) insisting on the 2newest kernel (I note that there's a newer one at kernel.org)? How can I check?

Here's the conf file:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder26) Sat May 26 01:03:50 PDT 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen" 0 0
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    InputDevice "stylus" "SendCoreEvents"
    InputDevice "cursor" "SendCoreEvents"
    InputDevice "eraser" "SendCoreEvents"

Section "Files"

 # path to defoma fonts
    FontPath "/usr/share/fonts/X11/misc"
    FontPath "/usr/share/fonts/X11/cyrillic"
    FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/Type1"
    FontPath "/usr/share/fonts/X11/100dpi"
    FontPath "/usr/share/fonts/X11/75dpi"
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "vbe"

Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"

Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"

Section "InputDevice"
    Identifier "stylus"
    Driver "wacom"
    Option "Device" "/dev/input/wacom"
    Option "Type" "stylus"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY

Section "InputDevice"
    Identifier "eraser"
    Driver "wacom"
    Option "Device" "/dev/input/wacom"
    Option "Type" "eraser"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY

Section "InputDevice"
    Identifier "cursor"
    Driver "wacom"
    Option "Device" "/dev/input/wacom"
    Option "Type" "cursor"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY

Section "Monitor"
    Identifier "Generic Monitor"
    HorizSync 28.0 - 57.0
    VertRefresh 43.0 - 60.0
    Option "DPMS"

Section "Device"
    Identifier "Generic Video Card"
    Driver "nvidia"

Section "Screen"
    Identifier "Default Screen"
    Device "Generic Video Card"
    Monitor "Generic Monitor"
    DefaultDepth 24
    SubSection "Display"
        Depth 1
        Modes "1152x864" "1024x768" "800x600" "640x480"
    SubSection "Display"
        Depth 4
        Modes "1152x864" "1024x768" "800x600" "640x480"
    SubSection "Display"
        Depth 8
        Modes "1152x864" "1024x768" "800x600" "640x480"
    SubSection "Display"
        Depth 15
        Modes "1152x864" "1024x768" "800x600" "640x480"
    SubSection "Display"
        Depth 16
        Modes "1152x864" "1024x768" "800x600" "640x480"
    SubSection "Display"
        Depth 24
        Modes "1152x864" "1024x768" "800x600" "640x480"

Revision history for this message
Britlion (britlion) said :

Latest: I installed envy. That was a nice find, and I had high hopes. However, the stable version of the package got me a blue screen of X server won't start, and the unstable version, which still appeared to want to install an older driver than the latest at nvidia.com got me a black screen of nothingness.

Ho hum.

Back to the drawing board. Until I can get a solid driver working, I'm unable to use ubuntu for things like wine and cedega, which are key to persuading people they might want to go linux over vista!


Revision history for this message
Dennis Dirdjaja (dcd-ditsch) said :

Does the installation script go through without errors? The kernel module for the nvidia driver is built during the installation and has to match with the rest of the X driver. You have to install the package build-essential in order to build the kernel module successfully.

In your system, there seems to be a problem with the kernel module version, perhaps because of different approaches trying to install the driver. If you have nvidia-glx or nvidia-glx-new installed but want to use the latest driver from Nvidia, please remove them. You should decide which version to use and then remove all other attempts prior to install the desired version.

Revision history for this message
Britlion (britlion) said :

This machine was only installed yesterday. The first thing I did was let it do any updates it wanted to. Then I downloaded and tried to install the nvidia driver from nvidia.com.

This didn't work. So I formatted and reinstalled ubuntu, and after getting the current updates, I tried to use nvidia-glx. This didn't work. So I tried to use nvidia-glx-new. This didn't work so I tried to use envy. This didn't work in either incarnation. I tried to use envy to uninstall the driver. This produced pages of error messages.

Should I format and reinstall and try a different method? If so, which one?

How should I attempt to remove the drivers otherwise?

Revision history for this message
Dennis Dirdjaja (dcd-ditsch) said :

If I remember correctly, there is a uninstall script delivered with the
nvidia driver.

The easiest way out of a fresh install is using nvidia-glx-new however.
You also need to install the restricted-modules matching your kernel
then (apt does that automatically).

Revision history for this message
Britlion (britlion) said :

I think one big problem is that Linux is all new to me.

I did, at one point, try:

Install ubuntu.
Allow it to update.
Go to restricted drivers and check the box for nvidia to enable it.

This got me the black screen.

How /should/ I be doing this specifically? (remember, I'm a complete noob)

Revision history for this message
Best Dennis Dirdjaja (dcd-ditsch) said :

I did some more research and it seems the restricted driver manager fails due to this bug with your graphics card series: https://launchpad.net/ubuntu/+source/linux-restricted-modules-2.6.20/+bug/98641

So, in your case it would be the best to install the driver manually or through envy. Ensure that the module from the linux-restricted-modules package doesn't interfere with the manual kernel module.

Revision history for this message
Britlion (britlion) said :

Thanks Dennis Dirdjaja, that solved my question.

Revision history for this message
Britlion (britlion) said :


I eventually got a working system by abandoning 64 bit for the moment, and dropping back to 32 bit ubuntu, then manually installing the nvidia driver downloaded from nvidia.

Thanks for the research on that, Dennis. That was very helpful - what it means is that the listed bug will probably be cleared for the next issue of ubuntu (and my graphics card will be old enough for stable drivers too). So, a few months and I can go 64 bit safely and securely. I hope :)