Adept manager root

Asked by Sbn on 2007-06-08

When I open adept manager it says that "You will not be able to change your system settings in any way (install, remove or upgrade software), because this application needs special administrator (root) privileges. Please run it as root or through kdesu or sudo programs to be able to perform these actions"
I am totally green with linux (ubuntu 7.04) so where do I go from here?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Sbn
Solved:
2007-06-08
Last query:
2007-06-08
Last reply:
2007-06-08
Massimo Forti (slackwarelife) said : #1

Thanks for your question. The update manager need administrator privileges. Can I ask exactly what are you doing. I want to understand the procedure you are donig. Thanks many

Hanusz leszek (leszek-skynet) said : #2

Hello,

Why do you want to run Adept manager ?
Adept Manager is a package manager for the KDE environment (installed with Kubuntu).

If you installed Ubuntu 7.04 then you can use the synaptic package manager (package manager for the GNOME environment / installed with Ubuntu):
"System" > "Administration" > "Synaptic Package Manager"

If you really want to run Adept manager with Ubuntu then type this in a terminal:
gksudo adept_manager

Best Sbn (esbenvinsnes) said : #3

Hanusz, you're right.
I realized that just a few minutes ago. No more adept man for me; pointless...
Thank you.

Shabakthanai (stevenvollom) said : #4

Referring to question 7871. I am using Feisty 7.04 and Adept Manager.

I had the same problem, I believe. I was given the following to solve the problem:

I have tried: ps -ewf| grep adept|grep -v grep|awk '{print $2}'

to list the processes using Adept. then,

sudo kill -9 <+the numbers for the processes>

It worked for a while then the problem reappeared. I used the same solution; and everything worked for a while, then the problem reappeared one more time.

This time, after I removed the offending process, I opened the Adept program. Rather than open, it timed out, so I tried opening it again. When Adept opened, it still would not allow changes and a new window appeared, as follows:

Could not commit changes - Adept Manager

There was an error committing changes. Possibly there was a problem downloading some packages or the commit would break packages.

Using the KDEforum, I got the follwing instruction:

sudo dpkg --configure -a

it did not work, then

sudo apt-get -f install

Changes were made, and I don't get the warning anymore, however, when I click to activate the changes, I get the Could not commit changes - Adept Manager window. Anytime I attempt to add or remove anything I get that window now.

I am locked out with no ideas.

Shabakthanai (stevenvollom) said : #5

I appologize, and I do not know how to edit the above comment, so here is the edit.

After 'tried opening it again. in line 9' I went back to the terminal and found an application operating in the background. This happened after I had removed all background operations and before I had successfully used Adept again. Apparently when Adept timed out, another process began, so I removed it. Again Adept timed out and would not perform. Each time Adept timed out, I went back and found a new application operating in the background; each time the number of the offending application increased by 12.

It was at that point I got the instruction from the KDEforum to try sudo dpkg --configure -a and sudo apt-get -f install, which brought the window 'Could not commit changes - Adept Manager'.

Sorry and thanks for your patience. I am old with memory problems, however, this now is an accurate description of the 'Bug' or 'problem' or whatever it is.
'

jimbudler (jimbudler) said : #6

I happen to like adept_manager better than synaptic.

I have Ubuntu with kde and xfce4 added.

To use adept_manager under gnome:

% cd /usr/share/applications/kde
Edit adept_installer.desktop: Change Exec=adept_installer to Exec=kdesu adept_installer
The same for adept_manager.desktop and adept_updater.desktop

The file adept_notifier.desktop does not need the change.

Jim
[