How to install swf player in ubuntu 7.10

Asked by benny on 2009-07-27

is it possible?
benny@b3nY:~$ sudo apt-get install flashplugin-nonfree
[sudo] password for benny:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package flashplugin-nonfree
benny@b3nY:~$ sudo apt-get purge adobe-flashplugin
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package adobe-flashplugin
benny@b3nY:~$ sudo apt-get install adobe-flashplugin
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package adobe-flashplugin

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-07-27
Last reply:
2009-07-29
benny (b3ny) said : #1

benny@b3nY:~$ sudo apt-get install flashplugin-nonfree
[sudo] password for benny:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package flashplugin-nonfree
benny@b3nY:~$ sudo apt-get purge adobe-flashplugin
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package adobe-flashplugin
benny@b3nY:~$ sudo apt-get install adobe-flashplugin
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package adobe-flashplugin
benny@b3nY:~$

benny (b3ny) said : #2

what purge word mean in benny@b3nY:~$ sudo apt-get purge adobe-flashplugin?

purge means remove config outside of /home/$USER

try:

sudo apt-get update; sudo apt-get --purge remove flashplugin-nonfree; sudo apt-get install flashplugin-nonfree

benny (b3ny) said : #4

benny@b3nY:~$ sudo apt-get update; sudo apt-get --purge remove flashplugin-nonfree; sudo apt-get install flashplugin-nonfree
Get:1 http://archive.ubuntu.com hardy Release.gpg [189B]
Ign http://archive.ubuntu.com hardy/main Translation-en_US
Hit http://archive.ubuntu.com hardy Release
Hit http://archive.ubuntu.com hardy/main Packages
Fetched 1B in 2s (0B/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package flashplugin-nonfree
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package flashplugin-nonfree

You really need to not log the same question twice

benny (b3ny) said : #6

I will restart
may be it work, i go paste here for note while restart
benny@b3nY:~$ sudo apt-get install flashplugin-nonfree
[sudo] password for benny:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting adobe-flashplugin instead of flashplugin-nonfree
adobe-flashplugin is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  adobe-flashplugin: Depends: libcurl3 but it is not going to be installed
                     Depends: libnss3-1d but it is not going to be installed
                     Depends: libpango1.0-0 (>= 1.20.5) but 1.20.1-1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
benny@b3nY:~$ sudo apt-get -f install flashplugin-nonfree
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting adobe-flashplugin instead of flashplugin-nonfree
adobe-flashplugin is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  adobe-flashplugin: Depends: libcurl3 but it is not going to be installed
                     Depends: libnss3-1d but it is not going to be installed
                     Depends: libpango1.0-0 (>= 1.20.5) but 1.20.1-1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
benny@b3nY:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libcurl3 libldap-2.4-2 libnss3-1d
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libcurl3 libgnutls13 libkrb53 libldap-2.4-2 libnss3-1d libopencdk10 libssl0.9.8
Suggested packages:
  gnutls-bin krb5-doc krb5-user
The following packages will be REMOVED:
  adobe-flashplugin
The following NEW packages will be installed:
  libcurl3 libldap-2.4-2 libnss3-1d libopencdk10
The following packages will be upgraded:
  libgnutls13 libkrb53 libssl0.9.8
3 upgraded, 4 newly installed, 1 to remove and 803 not upgraded.
1 not fully installed or removed.
Need to get 5070kB of archives.
After unpacking 6447kB disk space will be freed.
Do you want to continue [Y/n]? y
Get:1 http://archive.ubuntu.com hardy/main libopencdk10 0.6.6-1ubuntu1 [82.6kB]
Get:2 http://archive.ubuntu.com hardy/main libgnutls13 2.0.4-1ubuntu2 [306kB]
Get:3 http://archive.ubuntu.com hardy/main libkrb53 1.6.dfsg.3~beta1-2ubuntu1 [460kB]
Get:4 http://archive.ubuntu.com hardy/main libldap-2.4-2 2.4.7-6ubuntu3 [181kB]
Get:5 http://archive.ubuntu.com hardy/main libssl0.9.8 0.9.8g-4ubuntu3 [2828kB]
Get:6 http://archive.ubuntu.com hardy/main libcurl3 7.18.0-1ubuntu2 [206kB]
Get:7 http://archive.ubuntu.com hardy/main libnss3-1d 3.12.0~beta3-0ubuntu1 [1007kB]
99% [7 libnss3-1d 969107/1007kB 96%] 23.7kB/s 1s^99% [7 libnss3-1d 973451/1007kB 96%] 23.7kB/s 1s^99% [7 libnss3-1d 977795/1007kB 97%] 23.7kB/s 1s^99% [7 libnss3-1d 987931/1007kB 98%] 23.7kB/s 0s^Fetched 5070kB in 4m30s (18.8kB/s)
Preconfiguring packages ...
(Reading database ... 88990 files and directories currently installed.)
Removing adobe-flashplugin ...
Selecting previously deselected package libopencdk10.
(Reading database ... 88979 files and directories currently installed.)
Unpacking libopencdk10 (from .../libopencdk10_0.6.6-1ubuntu1_i386.deb) ...
Preparing to replace libgnutls13 1.6.3-1build1 (using .../libgnutls13_2.0.4-1ubuntu2_i386.deb) ...
Unpacking replacement libgnutls13 ...
Preparing to replace libkrb53 1.6.dfsg.1-7build1 (using .../libkrb53_1.6.dfsg.3~beta1-2ubuntu1_i386.deb) ...
Unpacking replacement libkrb53 ...
Selecting previously deselected package libldap-2.4-2.
Unpacking libldap-2.4-2 (from .../libldap-2.4-2_2.4.7-6ubuntu3_i386.deb) ...
Replacing files in old package libldap2 ...
Preparing to replace libssl0.9.8 0.9.8e-5ubuntu3 (using .../libssl0.9.8_0.9.8g-4ubuntu3_i386.deb) ...
Unpacking replacement libssl0.9.8 ...
Selecting previously deselected package libcurl3.
Unpacking libcurl3 (from .../libcurl3_7.18.0-1ubuntu2_i386.deb) ...
Selecting previously deselected package libnss3-1d.
Unpacking libnss3-1d (from .../libnss3-1d_3.12.0~beta3-0ubuntu1_i386.deb) ...
Replacing files in old package libnss3-0d ...
Setting up libopencdk10 (0.6.6-1ubuntu1) ...

Setting up libgnutls13 (2.0.4-1ubuntu2) ...

Setting up libkrb53 (1.6.dfsg.3~beta1-2ubuntu1) ...

Setting up libldap-2.4-2 (2.4.7-6ubuntu3) ...
Installing new version of config file /etc/ldap/ldap.conf ...

Setting up libssl0.9.8 (0.9.8g-4ubuntu3) ...
Checking for services that may need to be restarted...done.
Checking init scripts...
Nothing to restart.

Setting up libcurl3 (7.18.0-1ubuntu2) ...

Setting up libnss3-1d (3.12.0~beta3-0ubuntu1) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place

benny (b3ny) said : #7

No
Is it possible to play swf files under ubuntu 7.10?
If can not, this one what different with 8.04 hard no install swf player like 123 as non-free componet
what 7.10 has but not for 8.04 icon log off?

benny (b3ny) said : #8

Yes I do reinstall twice for this red cd in this month and first that was received on 2007, I lost my totally data inside 80GB
In the name of zero, this stuff pretty nice to leave olala. missing... can not remove with broken files :-)

Shang Wu (shangwu) said : #9

7.10 is no longer being supported. You should upgrade your system to 8.04+ for the system to work properly.

gadolinio (gadolinio) said : #10

I agree with Shang Wu: you should upgrade your version.
I use Swfdec on Ubuntu 8.10, and it works perfectly. Go to system-->administration-->synaptic package manager. There search for "swfdec" and install it. The program can be accessed from applications-->sound and video. You can also make .swf giles to be always opened with swfdec by right-clicking one of them, choosing properties, and then adding Swfdec in the "open with" tab.
Hope you find this useful...

VLC and mplayer play .swf out of the box. No need for an extra app.

Can you help with this problem?

Provide an answer of your own, or ask benny for more information if necessary.

To post a message you must log in.