VX 1000 recognizes /dev/audio1 and /dev/video0 but doesn't work.

Asked by chhonker on 2009-07-27

I am new to unbuntu shifting from XP. Install latest 9.0.4 release and then updated kernel to 2.6.30.3 as follows:
1 installed headers ......all_deb
2.install header ........i386.****
3.install linux kernel image.....386.**** from repository 2.6.30.3 which is updated on yesterday only.

When I do plug my VX 1000 life cam, linux recognizes audio and video directories i.e. ls /dev/audio* star show audio0 and audio1 and ls /dev/video* shows video0. but when I try to use skype it doesn't work , and during skpye video test(under options) it show green-blue screen and under audio setting it is not recognizing mic of VX 1000.

My laptop in HP nx7010.

So in brief: VX1000 Mic : not working, Webcam : video show green-blue screen , under kernel 2.6.30.3 kernel

Can anyone tell how do I get it working? tried everything like restarting machine as well.

Question information

Arnaudus (a-lerouzic) said : #2

Hi,

Your problem seems very close to bug #359765. Unfortunately, anything really useful there.

Arnaudus (a-lerouzic) said : #3

Edit: a bit more info in another bug, bug #280657 . It seems that the cam used to work in earlier versions of Ubuntu.

chhonker (chhonker) said : #4

I just tried, and bang...

$ sudo gstreamer-properties

its shows my video by selecting Video for Linux 2 (vl4 2) without audio. Although I have /dev/v4l dir only.

Doesn't work in skpye any idea?
 no video in skpye ....

baltho (baltho) said : #5

G'day!

I followed the steps at http://ubuntuforums.org/showthread.php?t=1333343 and the webcam now works perfectly. There's a bit in there about changing
CONFIG_DVB_FIREDTV=m
to
CONFIG_DVB_FIREDTV=n
in the .config file, and I found I needed to change one more (might have been 2, can't quite remember) from "m" to "n".
They're all kernel modules (and there's a lot of them! digital tv cards are covered as well as analog webcam devices...) and a couple wouldn't compile: the error message gives you the source file which bombed, and you look for something with the same name in .config and disable it with the "n", thus skipping it and avoiding the problem. There were also quite a few warning messages which I studiously ignored.

Don't forget the little command-line wrapper at the end to set an environment variable before you start Skype.

I've still not got the sound to work in skype (the little green light won't come on unless I'm actually making a call is the problem, I suspect) so watch this space....

Can you help with this problem?

Provide an answer of your own, or ask chhonker for more information if necessary.

To post a message you must log in.