8.4 live cd will not boot

Asked by mcmorj on 2009-07-19

I am hoping I can save my ancient PC315 Pentium Proo 200 server from the scrap heap!
The plan was to install Linux on this trusty little machine.
Frustratingly, WinXP will install and load no problem (surprisingly fast too) but any Linux install I try falls over at the first hurdle.
I have SCSI Disk and CD ROM - the installer announces it is starting and - thats it. Nothing more happens. The PC has not frozen, the keyboard (say I press Caps Lock) responds. It just sits there with loading ISOLINUX...
I have tried removing all cards except graphic and SCSI. I have moved the cards about the slots. I have changed graphic cards. I havd done all the usual things, disabled CPU cache, changed CPU, changed CD ROM. The problem remains, SCSI notices XP install CD and works absolutely fine, but WILL NOT commence the install of ANY Linux CD, not just UBUNTU (my preferred install).
Any help appreciated. I have gone through all the basics like disabling all the tat in the BIOS, ROM shadow etc.
I cannot see it being hardware as an XP CD, instant Zing, anything Linux - no dice !
I was also able to install Windows2000 but it would BSOD when trying to boot the actual OS.
I Also had Linux on this PC315 before so mystified as to why it won't install anymore.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-07-22
Last reply:
2009-07-22
Tom (tom6) said : #1

Ubuntu (and possibly all the other distros you have also tried) is aimed at top-end machines to compete favourably with Win7, Vista and such. For machines being rescued from the scrap heap there are many other distros that would be much better.

To give us a better chance of picking 'the best distro for this machine' (or at least a good range of options for you) please let us know the machines cpu speed, ram size and amount of hard-drive space available. Given that Xp will work i would recommend trying sliTaz and Wolvix,
http://distrowatch.com/table.php?distribution=slitaz
http://distrowatch.com/table.php?distribution=wolvix

Preferably Wolvix Hunter 1.1.0 - which brings us to the other crucial question - what do you want this machine to do? If you simply want internet surfing, emailing and a few light games then that opens it up a bit. Wolvix Hunter also has the full OpenOffice already on it's LiveCd and is also usually pretty good at picking up on any wiifi hardware it finds during install (or when booting the LiveCd) but you'll need to go through it's Control Panel to really get that kinda stuff working - should be fairly easy though.

Of course it's best to try out any distro as a LiveCd on a machine before installing it - just to see if it will work easily. With most distros just boot up with the distros cd in the cd/dvd-drive and that should get you to a splash screen, if not this guide might help
https://help.ubuntu.com/community/BootFromCD
just pressing enter should get you to a working desktop which we call a "LiveCd session" if it works. A very few distros don't have this option, almost all of them do offer it. Ubuntu and some others have a fancy menu instead of a splash screen. Ubuntu calls the option "Try Ubuntu without making changes to this machine" but that's irrelevant because the machine can't handle the bloat of Ubuntu anyway.

So please let us know the 3 basic specs for the machine and also let us know whether you want this machine as a server, office desktop, games machine, simple web stuff or what and then we'll hopefully be able to guide you to an appropriate distro to do that ;)

Good luck and regards from
Tom :)

Do you MD5 check the ISOs you download? Do the CDs pass verification check? Have you tested your RAM? Have you tried some boot options from the F6 menu?

mcmorj (mcmorj-gmail) said : #3

Hi,

I have tested the RAM (it is ECC Error checking) 256MB
The CD does pass MD5 checksum (and installs quite happily on other machines)
The processor is a Pentium Pro 200 mhz (1995)
I know I had SUSE 9 on it a while ago and don't know what has changed to prevent other installs working.

Please note, this seems to be a problem with the loader that initially starts on the CD, so I do not even get to the stage of deciding whether to use LIVE CD or install mode.

Is appears to hang on the very first 'boot loader' instruction.

I could try another more appropriate Linux variant, aimed as older spec machines as you say - but I think the problem I have will mean these versions do not work either. I tried Various versions of Ubuntu and Suse and all the same. I did get an attempt (just once) to the point of the splash screen, and the install proceeded - but for whatever reason, did not finish with a workable version.

I suggest you use the alternate installer, the installer is text based and much better suited to low-end hardware.

mcmorj (mcmorj-gmail) said : #5

The full spec is :

PC Server PC315 (IBM)
Custom IBM motherboard single socket 8 Pentium Pro
Natoma Chipset (Intel)
USB (!) Just one Port
4 PC66 ECC Slots populated with EDO PC66 ECC 4 x 64MB [256MB]
Adaptec SCSI AHA2940UW adapter PCI
SCSI 4.3 GB IBM Hard Disk
SCSI 80GB Seagate HD
SCSI CDROM (3 different types tried)
SCSI 20/40GB SONY DAT
Graphics card (1MB / 2MB / 4MB / 12MB) PCI [different types tried - seems to only work in 1st PCI slot)
DLINK 100mbit Ethernet PCI [also various tried and no network card at all]

By the way what is the alternate installer - I do not get ANY OPTION - it does not boot the CD at all.....

Campbell (campbell-hennessy) said : #6

The alternate installer is an option when you download. It can be found at http://www.ubuntu.com/getubuntu/downloadmirrors#alternate. If you want to use it for a server the Ubuntu server edition also uses a text based installer.

Campbell (campbell-hennessy) said : #7

The alternate installer is an option when you download. It can be found at http://www.ubuntu.com/getubuntu/downloadmirrors#alternate. If you want to use it for a server the Ubuntu server edition also uses a text based installer.

Larry Jordan (larryjor) said : #8

     My first thought was maybe the text-based installer would be better as well, but looking at the required specifications for Ubuntu 8.04:

500 MHz x86 processor
192 MB of system memory (RAM)
8 GB of disk space
Graphics card capable of 1024x768 resolution
Sound card
A network or Internet connection

(see https://answers.launchpad.net/ubuntu/+question/35251 for discussion on this)

it seems to me you have enough memory; other postings say 256MB recommended. I'm not sure, but I wonder if the Live CD you have is bad? Did you get it from a magazine? (Can it be replaced?)

Tom (tom6) said : #9

200MHz cpu is below openSUSE min.spec as well i think. Even tho ram is higher than required for Xubuntu i found even Xubuntu distressingly slow on a 350MHz machine. Ubuntu 9.04 needs 700MHz cpu and 512Mb ram so even if you do get 8.04 working then you'll have to stick with that, although many people are sticking with 8.04 because it's an LTS release which means it gets bug-fixes first, before 9.04 and is fully supported until late 2010 or something :) So maybe Xubuntu 8.04 might be ideal for this machine :)
http://www.xubuntu.org/get#hardy

However, i would really aim at a much lighter distro that will be less sluggish. Debian itself is often excellent and is kinda head of the family that Ubuntu is in. Wolvix Hunter 1.1.0 would be good, one of their recent beta versions might also be excellent. Forget sliTaz, that's for very tiny & low spec machines - it would make your machine fly but i think you can cope with something a lot heftier. Vector & Zenwalk, like Wolvix are also in the slackware family so they tend to be quite light and fast, but also like Wolvix in having a good range of apps already included and plenty in their repos.
http://distrowatch.com/table.php?distribution=wolvix
http://distrowatch.com/table.php?distribution=vector
http://distrowatch.com/table.php?distribution=debian

You might want to compare these against the Ubuntu pages at DistroWatch
http://distrowatch.com/table.php?distribution=ubuntu
http://distrowatch.com/table.php?distribution=xubuntu

Also the home-page at DistroWatch might be worth looking through but you'll need to make sure the min.spec. required by each distro is less than your machine - that still leaves the way open for a lot of distros but just not the big names; RedHat, Mandriva, Fedora, openSUSE

Good luck and regards from
Tom :)

Tom (tom6) said : #10

It's generally better to avoid old versions of distros because of the lack of support and also the repos might well have closed completely so it's difficult to install anything. However, most distros have a "stable" version and then also a "development" version. I guess that 8.04 is Ubuntu's very stable version and 9.04 is kinda the development version.

Tom (tom6) said : #11

Hmmm, something else worth noting is that "lower spec" does not mean "older". For example netbooks are lower spec. In many cases an ultra top-end machine of a few years ago will have a higher spec than a much newer machine. My own machine is a real mix of old and new, the cd-drive is possibly 'only' ten years old but is a real faithful work-horse. In the Windows world the only OS's they have that works on lower-spec machines are 'old' versions but in linux we have ultra new releases of all distros right across the range from top-end desktops, servers, netbooks, hand-helds, phones, dedicated routers and even some watches. Try getting Win98 using wiifi devices or wireless networks or bluetooth and it's going to be tough to find drivers and stuff yet many linux distros are much smaller, work on much lower spec machines and have ultra-new features built in.

Or simply install xubuntu and then install lxde or flwm. Both are super light DEs

mcmorj (mcmorj-gmail) said : #13

Thanks for the comments, it does not really get me any further on, why any dist I try, the installer hangs at the very first instruction..... starting the CD image.

Campbell (campbell-hennessy) said : #14

Have you tried a different CD drive?

Try disconnecting the power to the drives you do not need access to. This may help

mcmorj (mcmorj-gmail) said : #16

<< Have you tried a different CD drive?
...you will see in my earlier posts I have tried 3

<< Try disconnecting the power to the drives you do not need access to. This may help

... a good idea but alas already tried, also the SCSI disks have a boot sequence as well (delayed start) to they do not all try spinning up at once. Power (or lack of it) does not seem to be the problem.

May as well state again that ANY OTHER BOOTABLE CD I TRY WORKS ABSOLUTELY FINE ! It is ONLY LINUX CDs that will not boot (and I have tried many, and before anyone suggests, the same CDs install no problem on other PCs) - the ISOLINUX boot loader does not even start, just comes back with loading..... but the PC has NOT frozen !!!

Tom (tom6) said : #17

It's clear that you've tried heavy linux distros that need a higher spec machine but it's not clear whether you've tried a lighter one that's has a chance of working on your machine. It's also unclear whether you've tried different hardware combinations as that could also be an issue <shrugs> if you want to try to fix the problem or troubleshoot it then that's possible but if you're more determined to just prove that linux doesn't work by not trying any of our suggestions then that's fine too.

Good luck and regards from
Tom :)

mcmorj (mcmorj-gmail) said : #18

Hi there, I think you are focusing on the wrong part of the Story.

I have already mentioned that I have tried many different hardware combinations, VGA cards, bare minimum, CDROMS (three) etc. I am not trying to prove linux does not work, I am merely saying that the ISOLINUX loader seems to fail regardless of the distro - for whatever reason.

I have also considered all the suggestions, most of which I have previously tried anyway.

The fact for my situation remains that PC that will boot Win98, WinXp, W2K, Bootable CDs (like Hirons) quite happily, will not load Linux. And more galling is that this PC certainly did have linux on it in the past, and nothing has materially changed with the hardware.

I am an adovcate of Linux, I would love to have older hardware living on in some usable way - not thrown in the scrap like so many PCs I see at the Dump (we are talking P4s here).

I have also tried other install methods like network install - but no success. I don't like to see this little server ends it's days waiting for the crusher - thats all !

mcmorj (mcmorj-gmail) said : #19

Ok The only other thing that springs to mind is that there might be something in the way I am burning these CDs that is an issue? That seems to be one difference.

I am also downloading one of the 'lightweight' linux packages mentioned and seeing what happens.

I also have a Paid for SUSE 9.2 box set that I am going to dig out and try (though I am sure I tried this before).

Tom (tom6) said : #20

Ok, SliTaz is very tiny but has a very recent release and Wolvix Hunter 1.1.0 is from another different family of gnu&linux
http://distrowatch.com/table.php?distribution=wolvix
http://distrowatch.com/table.php?distribution=slitaz

One of these should work and might help us see if you have a hardware incompatibility issue with the whole of linux or just certain families. Knoppix also usually has extremely good hardware detection and support

http://distrowatch.com/table.php?distribution=knoppix

openSUSE is too heavy i think :( Sorry, but try very very light first (sliTaz) and then something a bit heftier afterwards
Good luck with this!
Regards from
Tom :)

Can you help with this problem?

Provide an answer of your own, or ask mcmorj for more information if necessary.

To post a message you must log in.