Unable to install NVIDIA driver on 9.04

Asked by Scædugenga on 2009-07-18

I continue to have a graphical issue; I'm getting convinced that I have craptastic cards. When I download the drivers, from the nVidia site, and follow their directions, I receive an error that says I cannot run he following command:

"sudo sh NVIDA-Linux-x86_x64-185.18.17-pkg2.run"

Can anyone shed some insight? I've tinkered and poked and prodded so much hat now my Ubuntu install won't even load correctly, so I'm going to be strting from a completely fresh install.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Scædugenga
Solved:
2009-07-23
Last query:
2009-07-23
Last reply:
2009-07-23
Campbell (campbell-hennessy) said : #1

Hi, hopefully we will be able to help. Could you please provide us with some more information. Specifically your NVIDIA card type (use the command lspci, find the NVIDIA entry and post the output) and the error that you receive when you try to run the command.

Thanks!

Scædugenga (mbtftic2002) said : #2

Hey - finally got me some updating done.. Swapped the card, and no longer have the absolutely hideous display issue.

This, however, is the same error message I was getting before:

sh: Can't open NVIDIA-Linux-x86_64-185.18.14-pkg2.run

Here is the text of the lscpi check:
sh: Can't open lscpi

I can only imagine I have failed to do something, or I have done something that I shouldn't have.

Jeruvy (jeruvy) said : #3

Nothing major, try running:

$ lspci

Instead, that may work without the typo :)

Good luck.

Scædugenga (mbtftic2002) said : #4

I'm not 100% sure what I did, but the problem is no longer extant. I tried following a few step-by-steps, and kept getting one error messgae after another. I tried working in xconfig and got lost. Finally, I simply reset my computer, and when it finished booting back up, everything was working perfectly.

Thank you both for your help, and as more difficulties arise, I'll be sure to pop back in for help in fixing them!